Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#26 18/04/2012 0:56:20

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 3 556

Re : flightgear 2.6.0

Un grand merci, tu m'ouvres des horizons.
Mais pas de bol, ils ne sont pas très coopératifs, ou je m'y prends mal.
Déjà, curieusement j'ai trouvé fgviewer, osgconv dans mes vieux FG191b et FG200, mais pas dans FG260.... Enfin bon, tant pis.
Quand je fais :
C:\Program Files\FlightGear\bin\Win32>osgconv C:\Users\Daniel_2\Desktop\ess\moteur.3ds C:\Users\Daniel_2\Desktop\ess\moteur.ac
Il me répond
Warning: in 3ds loader: file has no nodes, traversing by meshes instead
Data written to 'C:\Users\Daniel_2\Desktop\ess\moteur.ac'.

(ce "Warning" apparaît aussi 2 fois dans ma console FG au chargement)

et le fichier moteur.ac contient :

AC3Db
OBJECT world
kids 0

C'est un peu court, jeune homme... ? Est-ce que c'est dû à l'erreur "Warning" ?

Si ça te prends trop de temps, laisse tomber, je crois que je suis un peu limite pour ce sport...

Amicalement,

Dany


FG 2020.3.0 (et 2019.2.0), OSG 3.4.2, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB
Boeing 787-8 (YASim, avec nickyivyca, aco)
Hangar avions Patten (PAF) Robin  DR400 JSBSim, Douglas DC3 JSBSim, CAP10B, Tecnam P92 JSBSim.

Hors ligne

#27 18/04/2012 1:09:17

helijah
Banni(e)

Re : flightgear 2.6.0

Hum... Cas sent le 3DS mal foutu ça ! Quoique se soit un pléonasme en fait. Peut tu me fournir ce 3DS que je l'analyse plus en profondeur (pour info j'ai analysé des 3DS bit par bit et octet par octet il y a quelques années pour faire ma propre moulinettes d'import smile http://helijah.free.fr/pages/formats.htm ) alors je devrais pouvoir retrouver dans ma mémoire quelques souvenirs qui nous donnerons la solution smile

Amicalement Emmanuel

#28 18/04/2012 12:28:57

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 3 556

Re : flightgear 2.6.0

Demi fausse alerte : une erreur de ma part, et une autre qui me semble vraie dans un fichier.3ds.
Mon erreur : J'avais cherché à convertir (en .ac) les fichiers .3ds préalablement bidouillés par moi dans lesquels j'avais sauvagement remplacé .BMP par .png avec un traitement de texte ou Notepad++ (j'avais fait ça dans les .ac avec succès, mes textures étant converties en .png).

J'ai donc repris les fichiers.3ds initiaux de guigar (avec les textures.BMP).
Si je demande à osgconv de convertir les deux fichiers.3ds louches, ceci me donne :

- pour l'un (moteur.3ds), pas de messsage d'erreur et un fichier moteur.ac dont le texte me semble correct (le texte !!!), dans lequel je vois mentionnés le même nombre de textures.BMP que dans le .3ds original. J'imagine qu'en y remplaçant .BMP par .png j'appellerai mes fichiers .png convertis.
(Je ne peux pas vérifier avec fgviewer car il me donne un message d'erreur sur le path (FGROOT). Je dois encore m'y prendre comme un pied mais je ne veux pas tout mélanger.)

- pour l'autre (a300.3ds), un message  "osgconv a cessé de fonctionner", et un fichier a300.ac ne comportant que 5 textures .BMP sur les 10 que je "vois" dans le a300.3ds. Ce fichier est donc peut-être la source du désarroi.

Quelle est la meilleure façon de te le (les) faire parvenir ? Les fichiers.3ds sont possibles par mail (moins de 1 Mo). mais j'ai remarqué qu'il fallait que les textures.BMP soient présentes dans le même dossier pour que osgconv puisse faire la conversion. On passe à 33 Mo.

Encore merci Emmanuel pour ton assistance,

Amicalement,

Dany


FG 2020.3.0 (et 2019.2.0), OSG 3.4.2, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB
Boeing 787-8 (YASim, avec nickyivyca, aco)
Hangar avions Patten (PAF) Robin  DR400 JSBSim, Douglas DC3 JSBSim, CAP10B, Tecnam P92 JSBSim.

Hors ligne

#29 18/04/2012 19:16:32

helijah
Banni(e)

Re : flightgear 2.6.0

Alors, tout d'abord je tiens à préciser que le format 3DS est un format binaire et non ASCII. Aussi modifier du texte dans un tel fichier est assez risqué. Même en le faisant avec un éditeur héxadécimal. De tout façon il ne faut pas le faire avec un éditeur de texte.

Coté AC3D c'est différent puisque le format est ASCII un simple éditeur de texte suffit.

Pour m'envoyer cela plusieur solution. Soit tu fait un ZIP (ou autre 7z, tar.ge etc..) puis tu le place sur un site de partage de fichier (free.download ou autre)

Soit tu m'envois par mail en plusieur fois (fichier par fichier smile )

Amicalement Emmanuel

#30 19/04/2012 1:18:37

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 3 556

Re : flightgear 2.6.0

Fait par mail (1.6 Mo compressé !)

Dany


FG 2020.3.0 (et 2019.2.0), OSG 3.4.2, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB
Boeing 787-8 (YASim, avec nickyivyca, aco)
Hangar avions Patten (PAF) Robin  DR400 JSBSim, Douglas DC3 JSBSim, CAP10B, Tecnam P92 JSBSim.

Hors ligne

#31 21/04/2012 20:02:49

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 3 556

Re : flightgear 2.6.0

Tout fonctionne. Voir LFBO en ligne.
Un grand merci, Emmanuel !

Dany


FG 2020.3.0 (et 2019.2.0), OSG 3.4.2, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB
Boeing 787-8 (YASim, avec nickyivyca, aco)
Hangar avions Patten (PAF) Robin  DR400 JSBSim, Douglas DC3 JSBSim, CAP10B, Tecnam P92 JSBSim.

Hors ligne

#32 13/10/2013 18:11:23

KBEC
Membre
Inscription : 26/03/2012
Messages : 5

Re : flightgear 2.6.0

Salut vous tous,
je commence à avoir une bonne collection de bâtiments pour la ville de Québec (Canada) que je partagerai un jour.
Il me reste un problème. Certaines "scèneries" de FG comportent des erreurs qui me dérangent. Je suis sûrement perfectionniste, mais ce ne sont pas des erreurs banales, et qui concernent des endroits que je connais très bien
(piste 16 de CSL3 qui finit dans le Lac, des lacs assez grands qui n'existe pas, des rivières ou des routes qui finissent en cul-de-sac, etc...). Ce n'est vraiment pas une critique, ces terrains sont sûrement générés pas informatique et je ne saurais aucunement  faire mieux. Mais à côté de la très grande qualité de tout le reste de FG, c'est ma seule déception.
Jadis, j'ai corrigé de ces scènes avec FGSD (FG Scenery Designer 0.3.0 ou 0.3.1). Je trouvais cet outil génial... Malheureusement, aucune des versions de cet outil ne fonctionne maintenant sur Windows ( XP ou 7).
J'ai une version 0.3.91 de 2006 qui plante moins mais qui ne permet plus de modifier le terrain.
S.V.P. Y aurait-il quelqu'un qui nous ferait un immense cadeau d'une version  plus moderne, y compris pour Windows 7, et qui permettrait de corriger des terrains (btg.gz)...

KBEC, de Québec

Hors ligne

#33 13/10/2013 18:47:23

f-ojac
Membre
Inscription : 15/03/2012
Messages : 2 007

Re : flightgear 2.6.0

Non FGSD n'est plus utilisé.
Ce que tu décris, ce sont que les données utilisées pour créer le terrain de FG, en l'occurrence, VMAP0 pour le Canada, ne sont pas assez précise, comme te le confirme le mapserver : http://mapserver.flightgear.org/map/?lo … FTFFFFFFFF
Il faut donc corriger ces données, et les soumettre, pour que tout le monde puisse en profiter. Jette un œil sur QGis, notamment, et TerragearGUI.

Une possibilité, à laquelle on réfléchit, c'est d'utiliser OSM pour le traits de côte, de rivières, de lacs, pour ce qui est hors Europe. A suivre, pas dans la prochaine génération, peut-être dans la n+1.

Dernière modification par f-ojac (13/10/2013 19:15:03)


FG git - GNU/Linux 64 bits - Quadcore i7500 2,7 GHz - RAM 8 Go + GTX940MX

Hors ligne

#34 14/10/2013 8:56:13

Clm76
Membre
Lieu : LFOH
Inscription : 22/10/2012
Messages : 1 380

Re : flightgear 2.6.0

Bonjour à tous,

Pour ma part, après avoir débuté avec Sketchup pour la modélisation 3D, j'ai trouvé réellement mon bonheur avec Blender (dernière version 2.68a) et je converti ensuite en .ac au moyen d'un script. Il y a en fait 2 scripts possibles: J'utilise celui appelé AC3D - Mr No qui ne provoque pas d'erreurs lors du transfert.

En ce qui concerne FgViewer, cela m’intéresse bigrement mais je ne le trouve pas dans Fg 2.12 (windows).

Christian


Fg 2020.2.1 et 2020.4.0 - Linux Mint 20.1 Ulyssa - Cinnamon et Mate en dual boot - CM Asus P8H67 MLE - CPU i7 3770K - 12 Go Ram - Nvidia Geforce GTX 1660TI - Driver Nvidia 460.56
+ Hp notebook-15 - Linux Mint 20.1 Ulyssa -  CPU i3-7020u - Ram 4Go - Intel Graphics 620.

Hors ligne

Pied de page des forums