Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#26 24/03/2014 9:42:03

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : Script download_and_compile.sh

Salut sashitsu,

En console après t'être positionné dans ton dossier MON FGFS*,  tu as bien lancé une ligne de ce type: ./download_and_compile.sh -j12 ALL                  ?

Le -j12 permettra d'utiliser tous les cpu de ton ordi, même si tu en as que 3 ou 4, toute la ressource sera pour la compile=> gain de temps certain.

*je n'aurais pas mis d'espace, sans doute pas grave, mais c'est devenu une habitude.

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#27 24/03/2014 10:15:58

f-jjth
Administrateur
Inscription : 11/02/2012
Messages : 632

Re : Script download_and_compile.sh

ça aurait été tellement super d'avoir en même temps le contenu de ton terminal... big_smile
Pour info tu peu copier/coller du texte ici, pas besoin de prendre une photo d'un fichier texte pour nous en montrer le contenu.


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#28 24/03/2014 10:19:54

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 193

Re : Script download_and_compile.sh

A priori il a bien mis le script dans /MON FGFS/

Mais il ne lance pas une ligne du style ./download_and_compile.sh +arguments, mais download_and_compile.sh tout court.

Première remarque, je me méfie des noms de répertoires avec un espace, pas sûr qu'ils soient bien interprétés pour la création de tous les chemins.
Il vaut mieux appeler répertoire MON_FGFS , là sûr qu'il n'y aura pas de problème.
Et pour lancer le script, avec ou sans l'argument -j12 (qui ne marche pas chez moi j'ai 24 coeurs ! lol ) c'est
./download_and_compile.sh ALL ou éventuellement bash download_and_compile.sh ALL


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#29 24/03/2014 10:24:50

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 193

Re : Script download_and_compile.sh

Oups Clément m'a doublé...
Pas sûr qu'il y ait grand chose dans la terminal.
Et sashitsu se précipite pour mettre des messages quand ça ne marche pas, avec le merci de votre aide.
On te remercie de nous dire merci, sashitsu, mais pas la peine de le dire à chaque fois, on est là pour ça.
Au lieu de dire toujours merci, tu ferais mieux, comme le demande Clément, de donner un maximum d'informations précises.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#30 24/03/2014 13:26:08

sashitsu
Membre
Inscription : 11/03/2014
Messages : 23

Re : Script download_and_compile.sh

Merci et désolé je vais faire comme vous l'avez dit et je vous donne des nouvelles

Et sashitsu se précipite pour mettre des messages quand ça ne marche pas, avec le merci de votre aide

Je commence tout simplement à desespèrer !!!!!!!! ça fait presque 2 mois que j'essaie d'avoir mon FGFS mais rien ...
Merci de votre aide


Core i 3 2120 3,30 GHZ / Ram 5 Go / Carte graphique Nvidia GT 630 2Go, driver propriétaire Nvidia 331.20, Flightgear 3.0, Linux Mint 16

Hors ligne

#31 24/03/2014 15:15:18

sashitsu
Membre
Inscription : 11/03/2014
Messages : 23

Re : Script download_and_compile.sh

[ 41%] Building CXX object src/Main/CMakeFiles/fgfs.dir/__/Scripting/NasalPositioned_cppbind.cxx.o
In file included from /usr/include/c++/4.8/bits/stl_algobase.h:67:0,
                 from /usr/include/c++/4.8/algorithm:61,
                 from /home/sashitsu/MON_FGFS/flightgear/src/Scripting/NasalPositioned_cppbind.cxx:28:
/usr/include/c++/4.8/bits/stl_iterator.h: In instantiation of ‘std::reverse_iterator<_Iterator>::reverse_iterator(const std::reverse_iterator<_Iterator>&) [with _Iterator = __gnu_cxx::__normal_iterator<naGhostType* (**)(const FGNavRecord*), std::vector<naGhostType* (*)(const FGNavRecord*), std::allocator<naGhostType* (*)(const FGNavRecord*)> > >]’:
/home/sashitsu/MON_FGFS/install/simgear/include/simgear/nasal/cppbind/Ghost.hxx:697:67:   required from ‘static typename boost::enable_if<boost::is_polymorphic<typename BaseGhost::raw_type>, naGhostType*>::type nasal::Ghost<T>::getTypeFor(const typename BaseGhost::raw_type*) [with BaseGhost = nasal::Ghost<SGSharedPtr<FGPositioned> >; T = SGSharedPtr<FGNavRecord>; typename boost::enable_if<boost::is_polymorphic<typename BaseGhost::raw_type>, naGhostType*>::type = naGhostType*; typename BaseGhost::raw_type = FGPositioned]’
/home/sashitsu/MON_FGFS/install/simgear/include/simgear/nasal/cppbind/Ghost.hxx:361:9:   required from ‘typename boost::enable_if<boost::is_base_of<nasal::internal::GhostMetadata, BaseGhost>, nasal::Ghost<T> >::type& nasal::Ghost<T>::bases() [with BaseGhost = nasal::Ghost<SGSharedPtr<FGPositioned> >; T = SGSharedPtr<FGNavRecord>; typename boost::enable_if<boost::is_base_of<nasal::internal::GhostMetadata, BaseGhost>, nasal::Ghost<T> >::type = nasal::Ghost<SGSharedPtr<FGNavRecord> >]’
/home/sashitsu/MON_FGFS/flightgear/src/Scripting/NasalPositioned_cppbind.cxx:512:29:   required from here
/usr/include/c++/4.8/bits/stl_iterator.h:132:32: internal compiler error: Erreur de segmentation
       : current(__x.current) { }
                                ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.8/README.Bugs> for instructions.
Preprocessed source stored into /tmp/cc5EJziU.out file, please attach this to your bugreport.
make[2]: *** [src/Main/CMakeFiles/fgfs.dir/__/Scripting/NasalPositioned_cppbind.cxx.o] Erreur 1
make[1]: *** [src/Main/CMakeFiles/fgfs.dir/all] Erreur 2
make: *** [all] Erreur 2
****************************************
**************** DATA ******************
****************************************
./download_and_compile.sh: ligne 833 : cd: /home/sashitsu/MON_FGFS/install/flightgear: Aucun fichier ou dossier de ce type

Tout marche jusquàa cette partie ... je comprends pas. je dois refaire ?
Note : J'ai relancé et ça donne a peu prés la même chose soit :

[ 54%] Building CXX object src/Main/CMakeFiles/fgfs.dir/__/Viewer/renderer.cxx.o
In file included from /usr/include/c++/4.8/vector:63:0,
                 from /home/sashitsu/MON_FGFS/flightgear/src/Viewer/renderer.cxx:35:
/usr/include/c++/4.8/bits/stl_uninitialized.h: In instantiation of ‘_ForwardIterator std::__uninitialized_move_if_noexcept_a(_InputIterator, _InputIterator, _ForwardIterator, _Allocator&) [with _InputIterator = osgUtil::StateGraph**; _ForwardIterator = osgUtil::StateGraph**; _Allocator = std::allocator<osgUtil::StateGraph*>]’:
/usr/include/c++/4.8/bits/vector.tcc:365:38:   required from ‘void std::vector<_Tp, _Alloc>::_M_insert_aux(std::vector<_Tp, _Alloc>::iterator, const _Tp&) [with _Tp = osgUtil::StateGraph*; _Alloc = std::allocator<osgUtil::StateGraph*>; std::vector<_Tp, _Alloc>::iterator = __gnu_cxx::__normal_iterator<osgUtil::StateGraph**, std::vector<osgUtil::StateGraph*> >; typename std::_Vector_base<_Tp, _Alloc>::pointer = osgUtil::StateGraph**]’
/usr/include/c++/4.8/bits/stl_vector.h:913:28:   required from ‘void std::vector<_Tp, _Alloc>::push_back(const value_type&) [with _Tp = osgUtil::StateGraph*; _Alloc = std::allocator<osgUtil::StateGraph*>; std::vector<_Tp, _Alloc>::value_type = osgUtil::StateGraph*]’
/home/sashitsu/MON_FGFS/install/OpenSceneGraph/include/osgUtil/StateGraph:214:49:   required from here
/usr/include/c++/4.8/bits/stl_uninitialized.h:274:5: internal compiler error: Erreur de segmentation
     __uninitialized_move_if_noexcept_a(_InputIterator __first,
     ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.8/README.Bugs> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [src/Main/CMakeFiles/fgfs.dir/__/Viewer/renderer.cxx.o] Erreur 1
make[1]: *** [src/Main/CMakeFiles/fgfs.dir/all] Erreur 2
make: *** [all] Erreur 2
****************************************
**************** DATA ******************
****************************************
./download_and_compile.sh: ligne 833 : cd: /home/sashitsu/MON_FGFS/install/flightgear: Aucun fichier ou dossier de ce type

J'ai refait une installation aprés avoir tout supprimé et encore une erreur ... est ce qu'un jour j'aurai FGFS sur mon ordi?  sad

Dernière modification par sashitsu (24/03/2014 15:58:23)


Core i 3 2120 3,30 GHZ / Ram 5 Go / Carte graphique Nvidia GT 630 2Go, driver propriétaire Nvidia 331.20, Flightgear 3.0, Linux Mint 16

Hors ligne

#32 24/03/2014 15:25:42

f-jjth
Administrateur
Inscription : 11/02/2012
Messages : 632

Re : Script download_and_compile.sh


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#33 24/03/2014 16:25:19

sashitsu
Membre
Inscription : 11/03/2014
Messages : 23

Re : Script download_and_compile.sh

Pour f-jjth ... j'essayerai la prochaine fois mais j'ai déjà fermé le terminal !

Juste une remarque ... sur les deux messages il y a erreurs de segmentation . Est ce qu'il y a une relation avec l'erreur de segmentation quand je lançais FGFS sous le terminal ?
Sinon il me disent tous (les 2 messages ) erreur sur la ligne 833 ... est ce qu'il faut modifier quelque chose sur cette ligne ?

Dernière modification par sashitsu (24/03/2014 16:27:29)


Core i 3 2120 3,30 GHZ / Ram 5 Go / Carte graphique Nvidia GT 630 2Go, driver propriétaire Nvidia 331.20, Flightgear 3.0, Linux Mint 16

Hors ligne

#34 24/03/2014 18:40:57

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 193

Re : Script download_and_compile.sh

sashitsu a écrit :

Merci et désolé je vais faire comme vous l'avez dit et je vous donne des nouvelles

Et sashitsu se précipite pour mettre des messages quand ça ne marche pas, avec le merci de votre aide

Je commence tout simplement à desespèrer !!!!!!!! ça fait presque 2 mois que j'essaie d'avoir mon FGFS mais rien ...
Merci de votre aide

On ne dit pas ça pour t'embêter, sashitsu, mais au contraire pour t'aider.
Et on essaie de te faire comprendre que dès que quelque chose ne marche pas, il faut agir de façon réfléchie, demander conseil en donnant les renseignements nécessaires complets, attendre la réponse, etc !

C'est comme tu veux, mais sinon tu ne mettras pas 2 mois, mais 4 mois, 6 mois, et ce ne sera toujours pas installé !
Par exemple pour cette histoire d'aéroports que tu aimes bien et que tu as téléchargé, je n'ai toujours pas compris avec tes explications ce que tu as fait exactement pour les installer, mais ne revenons pas là dessus...

Une preuve de ce que je dis :

sashitsu a écrit :

J'ai refait une installation aprés avoir tout supprimé et encore une erreur ... est ce qu'un jour j'aurai FGFS sur mon ordi?  sad

sashitsu a écrit :

Pour f-jjth ... j'essayerai la prochaine fois mais j'ai déjà fermé le terminal !

sashitsu a écrit :

difficile... même le script que j'ai téléchargé ne marche pas ... rien ... je vais refaire une autre installation et faire comme tu as dit

Note : Aprés desinstallation de tout et reinstallation  ! TOUJOURS LE MEME PROBLEME ! Incroyable ! J'ai reinstaller FGFS et j'ai rien touché mais toujours le même message sous le terminal :

"ERREUR DE SEGMENTATION"

Je desespère grave la !! sad

la compilation n'ayant pas encore fonctionné, tu reviens à ton installation qui marche encore moins bien, donc pas une preuve, mais trois !

Dès que ça ne marche pas tu te précipites, tu effaces, tu recommences, et comme le problème n'a été ni identifié ni corrigé, c'est pareil.

S'il te plaît, lorsque ça ne marche pas, donne toutes les informations nécessaires, poste un message, et attends la réponse.
Même si elle met deux jours à arriver (je sais bien qu'avec toi ce serait mieux si ça arrivait au bout de 30 secondes), c'est mieux que d'en être toujours au même point que depuis 2 mois.
Et pour savoir quelles sont toutes les informations nécessaires, va dans la section "Problèmes", clique en haut et à droite sur "Nouvelle discussion" et lis attentivement la redbox, la boîte rouge.

Donc là, au besoin, recommence effectivement l'installation pour nous donner, cette fois-ci, toutes les informations nécessaires, comme le demade d'ailleurs fort justement Clément dans ce message.
Mais en compilant avec le script, tu es sur la bonne voie pour avoir une installation de qualité.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#35 24/03/2014 19:13:34

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 610

Re : Script download_and_compile.sh

Dans mon dossier d'installation (je crois, pour toi, "MON FGFS/" ) je vois un "compilation_log.txt".
Ça pourrait peut-être aider ?


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#36 24/03/2014 19:43:07

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 193

Re : Script download_and_compile.sh

Si, c'est son contenu qu'on demande de copier et de communiquer en intégralité.

Mais c'est long, donc entre les balises code.

C'est à dire :

[*code*]contenu du log[*/code*]

en enlevant les étoiles.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#37 27/03/2014 19:21:35

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 193

Re : Script download_and_compile.sh

f-toro a écrit :

Sinon je viens de lancer une compilation sur mon vieux poste en debian stable pour voir si FG compile bien en stable avec le script.
Cette installation sera inutilisable, processeur trop lent, ram trop faible, carte graphique pas assez puissante, mais je saurai si une stable compile !

Je n'avais pas donné la réponse à mon essai.
FG compile parfaitement en Debian stable.
Par contre il ne se lance pas :

fgfs: /usr/local/include/boost/range/iterator_range.hpp:281: IteratorT boost::iterator_range<IteratorT>::end() const [with IteratorT = const char*]: Assertion `!is_singular()' failed.

D'où cela vient-il ?

En stable, les boost sont en version 1.49 et en testing en version 1.54, mais ça ne me paraît pas être une raison suffisante.

La configuration de mon ancien poste, trop ancienne ?
A mon avis ça va plus que ramer surtout en graphique mais ça devrait se lancer, non ?


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#38 6/10/2014 14:00:55

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 610

Re : Script download_and_compile.sh

Bonjour,

download_and_compile.sh contient apt-get update et apt-get install (mise à jour des "Paquets"). Sauf si on ajoute -an dans les options (ce que je ne fais pas en général)

De quels "Paquets" s'agit-il ? Linux Mint (comme le "Gestionnaire de mises à jour") ? Seulement paquets ajoutés en rapport avec FG ?
Étant sous Linux Mint 16 (qui n'est plus maintenu), y a t-il un risque de paquets inadaptés et de dysfonctionnement maintenant que Linux Mint 17 est paru et seul maintenu ?
Ou est-ce que cela ne fait tout simplement plus rien sous Linux Mint 16 ?

Merci.

Dany


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#39 6/10/2014 22:52:08

f-jjth
Administrateur
Inscription : 11/02/2012
Messages : 632

Re : Script download_and_compile.sh

Pour faire simple: tu n'as aucun soucis à te faire ;-)


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#40 6/10/2014 23:07:59

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 193

Re : Script download_and_compile.sh

Oui mais pour expliquer à Dany (donc faisons compliqué !) l'apt-get update ne fait pas d'opération sur les paquets autre que vérifier si la liste des paquets présents dans la distribution est à jour, ou s'il y a de nouvelles versions.

Ceci va permettre de voir si les paquets nécessaires à la compilation de FG sont bien présents dans la liste, pour pouvoir les installer s'ils ne le sont pas encore.

L'apt-get install est une commande qui ne fait rien toute seule, elle doit être suivi d'un nom de paquet ou d'une liste de noms, et va les installer.
En l’occurrence il s'agit d'installer des paquets (et la bonne version, d'où l'apt-get update préalable)nécessaires à la compilation de FG mais qui ne sont peut être pas installés dans le système pour l'utilisation qui en était faite antérieurement.
Et cette liste de noms de paquets est contenue dans une variable du nom de DISTRO_PACKAGES qui peut contenir des paquets standard (nécessaires à la compilation de FG) mais aussi des paquets spécifiques à certains types de distributions.

Les paquets système, qu'ils soient vu en interface graphique de gestionnaire de mise à jour, ou gérés par apt-get ou aptitude en console, sont les mêmes.
Un apt-get update est l'équivalent de la commande "Recharger" du gestionnaire graphique de mise à jour (si c'est le même sous Linux Mint).
En fait la commande "Recharger" lance en toile de fond un apt-get update.

Un risque de paquets inadaptés ou de dysfonctionnement sous Linux Mint 16 ça m'étonnerait.
Le risque c'est que si les versions de paquets ne sont plus présentes sous 16, FG ne puisse pas être compilé, pour cause de paquets obsolètes.
Mais à mon avis ça doit très bien passer aussi sous Linux Mint 16.
Faut essayer.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#41 7/10/2014 0:08:15

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 610

Re : Script download_and_compile.sh

Merci à tous les deux.

Merci Clément pour "simplicité" et la clarté de ta réponse, tu me tranquillises.
et Merci André pour t'être donné la peine de rédiger cette longue explication car j'aime bien tout ce qui m’aide à mieux comprendre (autant que je peux... avec mes limites).

J'ai effectivement trouvé la variable DISTRO_PACKAGES, et maintenant je sais ce que ça veut dire.

Amicalement,

Dany


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#42 14/03/2015 13:54:34

f-jjth
Administrateur
Inscription : 11/02/2012
Messages : 632

Re : Script download_and_compile.sh

Bonjour à tous et toutes (on peut rêver tongue )

Suite à l'annonce de la fermeture de gitorious.org nous avons décidé d'héberger notre code source sur sourceforge.net
Cette modification importante oblige de mettre à jour votre script d&c.sh, la dernière version est désormais disponible ici:: http://sourceforge.net/p/flightgear/fgm … compile.sh

Il ne suffit pas de remplacer votre ancien script par celui-ci, il vous faut supprimer l'intégralité de votre dossier et repartir sur un dossier tout neuf (dossier vide) dans lequel vous y mettrez le nouveau d&c.sh et l'exécuterez.
La compilation devrait prendre entre 25 et 45 min et vous aurez un FG totalement fonctionnel (on arrête pas l'progrès smile )

Amicalement,
Clément


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#43 15/03/2015 9:49:23

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : Script download_and_compile.sh

Salut à tous,

Compilation ultra rapide désormais (40mn), fgdata est allégé de tout son superflu, libre à chacun de choisir ce dont il a besoin dans Aircraft-fgaddon (svn).

http://fr.flightgear.org/forums/viewtop … 892#p28892

Merci aux dev, et surtout à Clément.

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#44 15/03/2015 10:09:21

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 193

Re : Script download_and_compile.sh

J'essaie ça dans une dizaine de jours, quand mes pieds auront quitté les planches...

Sinon, les avions qu'on avait auparavant dans son fgdata, peut-on tout simplement les recopier dans son nouveau dossier Flightgear/Aircraft de son répertoire personnel, sans cloner dans le dépôt SVN ? (pour démarrer illico presto quand on a une ligne lente)

Patten a écrit :

Merci aux dev, et surtout à Clément. smile

+ 1


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#45 15/03/2015 10:19:42

Sancho
Membre
Lieu : LFQS
Inscription : 22/07/2013
Messages : 90

Re : Script download_and_compile.sh

Bonjour à tous,

idem ichi,
compilation script 2.33 réussie.

Pour les utilisateurs de FGRUN il est nécessaire de purger les fichiers préférences de fgrun sous le dossier .fltk, sinon les chemins de l'Exécutable et du FG_root pose problème au premier lancement de l'Assistant Flightgear.
Promis j'essaierai de lancer en .fgsrc un jour prochain. wink

Encore merci aux devs et à Clément pour ce remarquable travail.
bon vols.


Debian Jessie, FG 3.7,  i7 4820K 3,7 GHz,16 Go DDR3 1866Mhz, GTX770 4Go, T-FLIGHT-HOTAS-X
F-SCHO sur DHC6, ec135P2, Mirage2000-5, Boeing 777,A6 Intruder, CAP10, DR400,
Padawan heureux

Hors ligne

#46 15/03/2015 11:08:19

Biloute974
Membre
Inscription : 2/02/2014
Messages : 990

Re : Script download_and_compile.sh

BOnjour,

merci Clément pour ce nouveau script et pour les explications, je vais mettre ce script 2.33 dans un dossier en attente de le lancer. Faut que je finisse mon petit projet d'annonce de steward en français/anglais avant toute chose.


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

#47 15/03/2015 21:52:22

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 219

Re : Script download_and_compile.sh

Bonsoir,
je me joins aux féliicitations! tout baigne smile


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#48 18/03/2015 0:11:07

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 219

Re : Script download_and_compile.sh

Bonjour,
Il y a un souci pour compiler la version stable.

J'ai lancé: ./d&c -j4 -s SIMGEAR FGFS
Le log: http://pastebin.com/XC0TL0aB


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#49 18/03/2015 8:57:22

f-jjth
Administrateur
Inscription : 11/02/2012
Messages : 632

Re : Script download_and_compile.sh

Bien vu, ça me démangeais tellement d'enlever cette option '-s'... (après tout si quelqu'un veut la version stable il n'a qu'à utiliser la version de son manager de package, non ?)

2 solutions:
1) soit je corrige le problème dans FG  (ça prend 5min)
2) soit je vire cette option '-s' (ça prend 3min)

à votre avis ?  (pour ce genre de chose je préfère avoir d'autres avis tel que les votre avant de foncer 'seul' tête baisser)


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#50 18/03/2015 8:59:14

Biloute974
Membre
Inscription : 2/02/2014
Messages : 990

Re : Script download_and_compile.sh

BOnjour,

perso je n'ai jamais utilisé le " -s" dans le script big_smile


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

Pied de page des forums