Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#101 31/01/2015 14:24:09

lann
Membre
Inscription : 10/01/2010
Messages : 136

Re : Comment installer Flightgear-Osgearth pour Linux

et

locate libgdal.a

Pour les paquets libgdal installés, j'ai :
libgdal-dev et libgdalh
mais pas libgdal1-dev

Dernière modification par lann (31/01/2015 14:40:15)


Debian stable 64 bits - Core I7 - 14 Go de RAM - NVIDIA GTX-260 - FG 2017.3.1 ou flightgear-osgearth 3.1.0
Logitech Extreme 3D PRO

Hors ligne

#102 31/01/2015 14:49:15

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 227

Re : Comment installer Flightgear-Osgearth pour Linux

~ > locate libgdal.a
/usr/lib/libgdal.a

je l'ai aussi.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#103 31/01/2015 14:49:41

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

Moi je l'ai. [EDIT]libgdal1-dev[/EDIT]

Ça pourrait être ça ?

M'étonne mais je reteste sans.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#104 31/01/2015 15:14:23

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

Recompilation juste de flightgear, sans paquet système libgdal1-dev  (en ce qui concerne libgdal.a je l'ai aussi).

Aucune différence.
La compilation passe parfaitement, donc libgdal1-dev n'a pas d'influence.
Mais l'erreur est la même à la fin du chargement des données de la fenêtre simulateur.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#105 31/01/2015 18:55:24

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

Attention, long ! lol

En fait, après avoir fait moult et moult essais, j'en arrive à conclure que mon problème n'est pas un problème de compilation, mais un problème de paramétrage de FG qui fait qu'au lancement quelque chose ne se passe pas bien.
La compilation de flightgear se passe bien, et le simulateur se lance, donc à priori il est parfaitement compilé.

Le problème est : comment flightgear, avec intégration osgearth, fait-il pour trouver les sceneries avec rendu osgearth ?

Reprenons la fin de ton tuto, lann :

lann a écrit :

6. Démarrage de flightgear
Dans le dossier racine flightgear_osgearth, créez un fichier se nommant Flightgear.sh
Rendez le exécutable
Puis collez ces commandes dans le fichier :

#! /bin/sh

CHEMIN=/debut_installation

export LD_LIBRARY_PATH=file:$CHEMIN/flightgear_osgearth/install/simgear/lib/x86_64-linux-gnu:$CHEMIN/flightgear_osgearth/install/osgearth/lib64:$CHEMIN/flightgear_osgearth/install/osg/lib64

cd $CHEMIN/flightgear_osgearth/install/flightgear/bin

./fgfs   --prop:/sim/rendering/rembrandt/enabled=false --fg-root=$CHEMIN/flightgear_osgearth/install/flightgear/fgdata --aircraft=UFO --airport=LFRB

Modifiez la variable CHEMIN pour faire correspondre avec le début du chemin d'installation qui précède le répertoire flightgear_osgearth
Pour moi, cette variable était égale à /media/disk


Vous pouvez bien entendu changer les aéronefs et aéroport de départ en modifiant les variables --aircraft et --airport

Enregistrez le fichier et lancez le

7/ Activation d'Osgearth
Allez dans Affichage/Rendu
Cliquez sur OsgEarth Options et faites les réglages désirés
Cliquez sur enable

Et puis voilà, le rendu avec osgearth va démarrer

Je m'étais déjà posé la question dans un précédent message :
(auquel tu n'avais pas réellement répondu du reste, pas grave)

f-toro a écrit :

@ lann

Je rectifie.

libgdal.so.1 (dans /usr/local/lib) est à priori bien installé par la compilation de gdal, donc compilation nécéssaire, je retire ce que j'avais dit.

Par contre je n'ai pas bien compris sur quelles bases de scènes tu t'étais basé, lann, pour lancer Flightgear.
Aussi pour ma part j'ai activé Terrasync avec le flightgear.sh suivant :

#! /bin/sh

export LD_LIBRARY_PATH=file:/home/andre/flightgear_osgearth/install/simgear/lib/x86_64-linux-gnu:/home/andre/flightgear_osgearth/install/osgearth/lib64:/home/andre/flightgear_osgearth/install/osg/lib64

cd /home/andre/flightgear_osgearth/install/flightgear/bin

./fgfs   --prop:/sim/rendering/rembrandt/enabled=false --fg-root=/home/andre/flightgear_osgearth/install/flightgear/fgdata --aircraft=c172p-2dpanel --airport=LFGK --enable-terrasync

Flightgear se lance, j'ai bien en image de fond le 172.
Les données se chargent (Terrasync a créé un répertoire dans .fgfs avec les sous répertoires Models Objects et Terrain.

Puis à la fin du chargement, plantage et FG se referme.

ce qui n'était pas conforme au script de ton flightgear.sh où tu ne lançais pas Terrasync.
J'ai donc remis ton script, pour avoir un test similaire, ce qui donne pour moi :

#! /bin/sh

export LD_LIBRARY_PATH=file:/home/andre/flightgear_osgearth/install/simgear/lib/x86_64-linux-gnu:/home/andre/flightgear_osgearth/install/osgearth/lib64:/home/andre/flightgear_osgearth/install/osg/lib64

cd /home/andre/flightgear_osgearth/install/flightgear/bin

./fgfs   --prop:/sim/rendering/rembrandt/enabled=false --fg-root=/home/andre/flightgear_osgearth/install/flightgear/fgdata --aircraft=UFO --airport=LFRB

Ensuite je lance flightgear.sh avec un /home/andre/.fgfs vide.
Que se passe-t-il ?

La fenêtre simulateur s'ouvre.
Chargement des données (avec le traditionnel curseur rotatif)
Création des sous-systèmes
Initialisation des sous-systèmes
Chargement des scènes...

Dès ce moment là j'ai les menus et ils sont actifs.

Dans mon .fgfs se sont créées 2 fichiers, fgfs.log et navdata_3_1.cache, et deux répertoires, Export, qui reste désespérément vide alors que le curseur continue inlassablement de tourner, et Terrasync, qui contient deux sous-répertoires, Objects, et Terrain, qui... restent désepérément vides.
Dois-je laisser le curseur tourner des heures ou des jours ? Je n'ai pas l'impression.

Mais la présence du répertoire Terrasync créé automatiquement me laisse pense qu'il faut bien que des scènes soit chargées, pour ensuite en avoir un rendu osgearth !

Donc les menus étant actifs, je vais dans fichier -> téléchargement des scènes
et dans la fenêtre, qui elle est en anglais, je clique sur Enable automatic download/update, puis apply puis ok.

La console le prend bien en compte :

Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/home/andre/.fgfs/TerraSync'.

Le curseur continue à tourner.
Je ne vois rien se télécharger dans Objects et Terrain, ce qui me semble normal car quand les scènes se téléchargent, la vitesse de téléchargement s'affiche à côté du message de téléchargement des scènes, alors que là, rien.
Donc je crois que je peux laisser tourner le curseur des heures, il ne se passera rien.
D'ailleurs, là, je suis pas sur téléchargement des scènes, mais sur chargement des scènes, pas pareil...

Par contre dans la console des messages apparaissent :

Error in ground network. Failed to find first waypoint: 0 at EGJJ
Error in ground network. Failed to find first waypoint: 0 at EGJJ
Error in ground network. Failed to find first waypoint: 0 at EGTE

Donc Terrasync ne semble pas aimer Jersey.
Est-cela qui bloque ? Bizarre.

Je finis donc par interrompre le processus en quittant flightgear (j'ai toujours les menus actifs !).

Puis je le relance, en laissant bien sûr tout ce qui s'est créé automatiquement dans mon .fgfs .

Et là, jai téléchargement des scènes, avec la vitesse (lent chez moi du reste, en pleine campagne, 250kbytes/s).
Car la fonction d'activation de téléchargement s'est mémorisée.

Et là j'ai l'erreur suivante, en cours ou en fin de téléchargement :

andre@990FX6100:~/flightgear_osgearth$ ./flightgear.sh
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/home/andre/.fgfs/TerraSync'.
environment init
Error in ground network. Failed to find first waypoint: 0 at EGKK
[osgEarth]* [VirtualProgram] Program link failure!
[osgEarth]* [VirtualProgram] Program link failure!
Segmentation fault
andre@990FX6100:~/flightgear_osgearth$

Cette fois-ci c'est Gatwick, pourquoi pas.

Mais si je remplace LFRB par LFGK, le téléchargement reprend (car je ne suis plus sur la même tuile), j'obtiens :

andre@990FX6100:~/flightgear_osgearth$ ./flightgear.sh
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/home/andre/.fgfs/TerraSync'.
environment init
Error in ground network. Failed to find first waypoint: 0 at EGKK
Error in ground network. Failed to find first waypoint: 0 at LFQQ
Error in ground network. Failed to find first waypoint: 0 at LFPO
Error in ground network. Failed to find first waypoint: 0 at LFPG
Error in ground network. Failed to find first waypoint: 0 at EBBR
Error in ground network. Failed to find first waypoint: 0 at LFPO
Error in ground network. Failed to find first waypoint: 0 at LFPG
Error in ground network. Failed to find first waypoint: 0 at LFSB
Error in ground network. Failed to find first waypoint: 0 at LSZH
[osgEarth]* [VirtualProgram] Program link failure!
[osgEarth]* [VirtualProgram] Program link failure!
Segmentation fault
andre@990FX6100:~/flightgear_osgearth$

Donc toujours un certain nombres d'erreurs et même message à la fin.

Ceci dit, lorsque les menus sont actifs, le menu Affichage -> Options de rendu comporte bien la possibilité d'activation de osgearth avec les options de réglage.
Si j'active le rendu osgearth pendant que les scènes se téléchargent (je ne peux pas après puisque le fenêtre s'est refermée), le téléchargement des scènes se poursuit et au bout du compte j'ai l'erreur suivante :

andre@990FX6100:~/flightgear_osgearth$ ./flightgear.sh
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/home/andre/.fgfs/TerraSync'.
environment init
Error in ground network. Failed to find first waypoint: 0 at LFLL
Error in ground network. Failed to find first waypoint: 0 at LFQQ
Error in ground network. Failed to find first waypoint: 0 at LFPO
Error in ground network. Failed to find first waypoint: 0 at LFPG
Error in ground network. Failed to find first waypoint: 0 at LFQQ
Error in ground network. Failed to find first waypoint: 0 at LSGG
Error in ground network. Failed to find first waypoint: 0 at EBBR
Error in ground network. Failed to find first waypoint: 0 at LFPG
Error in ground network. Failed to find first waypoint: 0 at EDDK
Error in ground network. Failed to find first waypoint: 0 at LSZH
Error in ground network. Failed to find first waypoint: 0 at LFPG
Segmentation fault
andre@990FX6100:~/flightgear_osgearth$ 

Donc cette fois-ci, le rendu osgearth ayant été activé, il n'y a plus d'erreur :

[osgEarth]* [VirtualProgram] Program link failure!

Donc du progrès !

Mais sur le :

Segmentation fault

là je bute.

Et le canard était toujours vivant ! lol

Allez, cerise sur le gateau, juste une petite tof pour vous montrer que je ne raconta pas d'histoires !

captur10.jpg

Comment avoir ces fichues scènes ?

[EDIT] les erreurs de terrain semblent mineures car si je relance, après que les scènes aient été téléchargées, et en activant le rendu osgearth qui ne se mémorise pas, j'obtiens :

andre@990FX6100:~/flightgear_osgearth$ ./flightgear.sh
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/home/andre/.fgfs/TerraSync'.
environment init
Segmentation fault
andre@990FX6100:~/flightgear_osgearth$

[/EDIT]


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#106 31/01/2015 20:16:21

Biloute974
Membre
Inscription : 2/02/2014
Messages : 991

Re : Comment installer Flightgear-Osgearth pour Linux

Salut, au moins tu avance, de mon côté, impossible de compiler simgear, j'ai vérifié, revérifié les librairies et les chemins, rine à faire, erreur à 97% cmake de simgear...


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

#107 31/01/2015 21:38:25

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

@ctesc356

Tu avais répondu à ma question à ce niveau :

ctesc356 a écrit :
f-toro a écrit :

Mais si les paquets système libgdal1h, libgdal-dev et libgdal1-dev sont installés, et si la compilation est bien relancée, il n'y a aucune raison qu'il y ait l'erreur :

/usr/bin/ld: CMakeFiles/fgfs.dir/__/Viewer/OsgEarthHeightField.cxx.o: référence au symbole non défini «GDALSetRasterNoDataValue@@GDAL_1.8»
/usr/lib/gcc/x86_64-linux-gnu/4.8/../../../../lib/libgdal.so: error adding symbols: DSO missing from command line

et ce avec le cmake que tu nous as indiqué, ctesc356.

libgdal1h, libgdal-dev et libgdal1-dev sont installés, cmake semble s'éxecuter sans souci mais make renvoie toujours pareil (ci-dessus)

mais par contre sauf erreur de ma part je n'ai pas vu ta réponse à ce niveau :

f-toro a écrit :

Suite aux quatre derniers messages :
............................................
2) C'est tout le contenu du répertoire home/tt/flightgear_osgearth/build/flightgear/ qu'il faut supprimer.
Si la compilation n'a pas abouti par un make install, il ne doit pas exister de répertoire home/tt/flightgear_osgearth/install/flightgear/ (sinon, le supprimer pour recommencer la compilation).

3) bien sûr tout relancer, cmake et make.

surtout au niveau du 2)


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#108 31/01/2015 21:41:10

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

@Biloute

f-toro a écrit :

Attention, en plus du répertoire /home/theddy/fgos/flightgear_osgearth/install/osg/lib64, il faut aussi un répertoire /home/theddy/fgos/flightgear_osgearth/install/osg/lib, donc faire un lien symbolique de répertoire symbolique lib vers le répertoire lib64.

Es-tu bien certain que ce lien symbolique a été créé, as-tu vérifié ?


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#109 31/01/2015 22:09:42

lann
Membre
Inscription : 10/01/2010
Messages : 136

Re : Comment installer Flightgear-Osgearth pour Linux

@f-toro

Voici mes réglages d'osgearth
mini_732596Capturedcran31012015210646.png


Debian stable 64 bits - Core I7 - 14 Go de RAM - NVIDIA GTX-260 - FG 2017.3.1 ou flightgear-osgearth 3.1.0
Logitech Extreme 3D PRO

Hors ligne

#110 31/01/2015 23:59:22

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 227

Re : Comment installer Flightgear-Osgearth pour Linux

@ f-toro: j'avais bien compris qu'il faut supprimer le contenu de "flightgear_osgearth/build/flightgear/" avant de relancer une compil (cmake + make)
mais ça coince toujours au make hmm

Si j'ai bien compris osgearth télécharge les scène à la volée, terrain et textures. Terrasync n'a donc rien à voir. J'essayerais sans.

Une explication que nous avait donné Clément:
http://equipe-flightgear.forumactif.com … rain#22184
hé oui on avait déjà essayé, mais pas pu hmm


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#111 1/02/2015 0:03:16

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

@ lann

Toujours l'erreur de segmentation, avec les mêmes réglages.

Avec en plus le même genre d'erreur que déjà vu, cette fois-ci à Francfort ! (va savoir pourquoi) :
(mais plus d'erreur de programme virtuel osgearth)

andre@990FX6100:~/flightgear_osgearth$ ./flightgear.sh
Enabling ATI viewport hack
Starting automatic scenery download/synchronization. Using built-in SVN support. Directory: '/home/andre/.fgfs/TerraSync'.
environment init
Error in ground network. Failed to find first waypoint: 0 at EDDF
Segmentation fault
andre@990FX6100:~/flightgear_osgearth$ 

A priori il ne me reste plus qu'une solution, quand même essayer de tout recompiler.
Car même si la compilation de flightgear a abouti, je n'ai quand même recompilé que flightgear, dans mes vessais avec gdal compilé ou libgdal système.

Mais sans beaucoup d'espoir que ce soit ça.

Et pas ce soir ! big_smile


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#112 1/02/2015 0:06:47

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

@ ctesc356

Je vais regarder la méthode Clément, intéressant ça.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#113 1/02/2015 0:24:13

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 227

Re : Comment installer Flightgear-Osgearth pour Linux

f-toro a écrit :

Je vais regarder la méthode Clément, intéressant ça.

Ca n'avait pas abouti, et ça date un peu.

Pour ton souci: essaie de lancer fg sans terrasync, après avoir purgé ".fgfs" (supprimer autosave, fgfs.log, navdata.cache, terrasync.cache)

Je vais essayer de tout reprendre de zéro aussi, faudra bien que ça y fasse, comme ils disent par ici smile

Dernière modification par ctesc356 (1/02/2015 0:26:23)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#114 1/02/2015 3:32:36

f-jjth
Administrateur
Inscription : 11/02/2012
Messages : 632

Re : Comment installer Flightgear-Osgearth pour Linux

Bonsoir à tous,
Voyant que vous vous cassez les dents depuis quelques semaines là dessus et que vous êtes plusieurs à vous y intéresser je me suis pencher sur la chose ce soir.
Le résultat: http://clement.delhamaide.free.fr/downl … sgearth.sh
J'ai testé à KSFO... ça marche mais c'est franchement moche hmm les photos aériennes sont vraiment de mauvaise qualités, et le temps de chargement est assez long (attendez vous à démarrez dans le vide !)

Avec ceci ça devrait être plus simple wink à utiliser comme le d&c normal sauf qu'il y a OSGEARTH en plus.

PS: il faut sans doute afficher la ligne WHATTOBUILDALL et il se peut qu'il manque une dépendance QtWidget dans ce cas il suffit de l'installer via votre manager de paquet (je ne me souvient plus quelle dépendance j'ai installé malheureusement)

Amicalement,
Clément


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#115 1/02/2015 10:20:33

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

Merci Clément.

Je voulais précisément, en fonction de tes indications sur le message de la PAF, reprendre le d&c et y intégrer les instructions osgearth.

Mais je me serais sûrement planté, merci de nous l'avoir fourni.

De toutes façons c'est vraiment la curiosité, l'envie d'en savoir plus, qui me pousse.
Car si, comme j'ai cru comprendre, les scènes osgearth sont téléchargées en live, avec la ligne que j'ai, ça ne va rien donner...

Ce sera testé dans les jours qui viennent.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#116 1/02/2015 10:53:51

Biloute974
Membre
Inscription : 2/02/2014
Messages : 991

Re : Comment installer Flightgear-Osgearth pour Linux

Merci Clément de ton aide et pour le script.
Je test tout cela ce matin et je reviendrais donner des news. J'aime tout essayer dès qu'un truc me passionne, je commençais à me ronger le frein de na pas y parvenir, j'avais encore tout recommencer hier soir mais en vain.

@f-toro: oui j'ai bine créé le lilen symbolique mais sans succès. J'étais prêt à partir sur un PC fraîchement installé pour installer osgearth smile


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

#117 1/02/2015 11:13:49

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 227

Re : Comment installer Flightgear-Osgearth pour Linux

Bonjour,

f-jjth a écrit :

(Non vous n'arriverez pas à me faire compiler OSGEarth  lol )

vous avez vu comme il s'est fait avoir lol lol lol

Merci Clément, apparemment ça se passe bien. J'attends le fgdata. Il arrive à 255 KiB/s hmm:/ peut-être que d'ici demain...


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#118 1/02/2015 11:23:16

Biloute974
Membre
Inscription : 2/02/2014
Messages : 991

Re : Comment installer Flightgear-Osgearth pour Linux

Idem, cela se passe bien, j'en suis aux fgdata et ça tourne 1.40 MiB, j'en suis à 12% en 15 minutes.

Dernière modification par Biloute974 (1/02/2015 11:23:39)


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

#119 1/02/2015 11:31:45

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 227

Re : Comment installer Flightgear-Osgearth pour Linux

15% en 2 heures, c'est pôô juste!


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#120 1/02/2015 12:06:01

Biloute974
Membre
Inscription : 2/02/2014
Messages : 991

Re : Comment installer Flightgear-Osgearth pour Linux

J'imagine la frustration de toute cette attente neutral
Et dire que j'arrive encore à me plaindre que c'est trop long... Aller, 37%...


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

#121 1/02/2015 12:16:23

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 227

Re : Comment installer Flightgear-Osgearth pour Linux

19% ça avance roll roll
J'ai essayé de récupérer le fgdata téléchargé par la méthode du tuto de Iann, mais il est vérolé, il manque un tas de fichiers. Il avait pourtant mis 12 heures a arriver!?


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#122 1/02/2015 12:46:33

f-jjth
Administrateur
Inscription : 11/02/2012
Messages : 632

Re : Comment installer Flightgear-Osgearth pour Linux

Si vous en êtes au fgdata ça veut dire que toutes les compilations se sont bien passé ?? SG/FG ?
Je demande car j'ai fait ça vraiment vite fait hier soir sans trop vérifier donc j'aurais pas été étonné qu'on me dise "ça marche pô !!"


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#123 1/02/2015 15:04:03

Biloute974
Membre
Inscription : 2/02/2014
Messages : 991

Re : Comment installer Flightgear-Osgearth pour Linux

Toutes les compilations se sont bien passées, pas de souci, génial wink

Je m'apprête à tester tout cela.


Edit: ça plante après le chargement des scènes, la fenêtre reste quelques secondes ouvrte avec possibiité d'accès au menu mais fini par planter.

Contenu de la console:

Enabling ATI viewport hack
environment init
KMA20 audio panel initialized
KI266 dme indicator #0 initialized
[osgEarth]* [TileSource] Open failed: Dataset has no spatial reference information (/home/theddy/.fgfs/OsgEarthCache//GeneratedHeightFields//KSFO.tiff)
[osgEarth]* [TerrainLayer] "KSFO": Could not initialize driver
[osgEarth]  [TerrainLayer] "KSFO": Could not initialize TileSource , but a cache exists. Setting layer to cache-only mode.
[osgEarth]* [TerrainLayer] "KSFO": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [TerrainLayer] "KSFO": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [ElevationLayer] "KSFO" : Error: layer does not have a valid TileSource, cannot create heightfield

Dernière modification par Biloute974 (1/02/2015 15:08:11)


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

#124 1/02/2015 15:50:27

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Comment installer Flightgear-Osgearth pour Linux

Ah ?

Pas grave, si ça marche pas, essaie la méthode à lann !


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#125 1/02/2015 15:55:32

Biloute974
Membre
Inscription : 2/02/2014
Messages : 991

Re : Comment installer Flightgear-Osgearth pour Linux

Je suis parvenu à lancer un vol avec le Cessna en changeant d'aéroport, mais le cessna est impilotable, je vous met la vidéo pour vous faire une idée.
Puis là, je n'ai plus accès aux menus une fois FG lancé, retour de la console:

Enabling ATI viewport hack
environment init
KMA20 audio panel initialized
KI266 dme indicator #0 initialized
[osgEarth]* [TileSource] Open failed: Dataset has no spatial reference information (/home/theddy/.fgfs/OsgEarthCache//GeneratedHeightFields//LFRB.tiff)
[osgEarth]* [TerrainLayer] "LFRB": Could not initialize driver
[osgEarth]  [TerrainLayer] "LFRB": Could not initialize TileSource , but a cache exists. Setting layer to cache-only mode.
[osgEarth]* [TerrainLayer] "LFRB": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [TerrainLayer] "LFRB": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [ElevationLayer] "LFRB" : Error: layer does not have a valid TileSource, cannot create heightfield
[osgEarth]* [TileSource] Open failed: Dataset has no spatial reference information (/home/theddy/.fgfs/OsgEarthCache//GeneratedHeightFields//LFKF.tiff)
[osgEarth]* [TerrainLayer] "LFKF": Could not initialize driver
[osgEarth]  [TerrainLayer] "LFKF": Could not initialize TileSource , but a cache exists. Setting layer to cache-only mode.
[osgEarth]* [TerrainLayer] "LFKF": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [TerrainLayer] "LFKF": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [ElevationLayer] "LFKF" : Error: layer does not have a valid TileSource, cannot create heightfield
[osgEarth]* [TileSource] Open failed: Dataset has no spatial reference information (/home/theddy/.fgfs/OsgEarthCache//GeneratedHeightFields//KSFO.tiff)
[osgEarth]* [TerrainLayer] "KSFO": Could not initialize driver
[osgEarth]  [TerrainLayer] "KSFO": Could not initialize TileSource , but a cache exists. Setting layer to cache-only mode.
[osgEarth]* [TerrainLayer] "KSFO": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [TerrainLayer] "KSFO": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [ElevationLayer] "KSFO" : Error: layer does not have a valid TileSource, cannot create heightfield
[osgEarth]* [TileSource] Open failed: Dataset has no spatial reference information (/home/theddy/.fgfs/OsgEarthCache//GeneratedHeightFields//KOAK.tiff)
[osgEarth]* [TerrainLayer] "KOAK": Could not initialize driver
[osgEarth]  [TerrainLayer] "KOAK": Could not initialize TileSource , but a cache exists. Setting layer to cache-only mode.
[osgEarth]* [TerrainLayer] "KOAK": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [TerrainLayer] "KOAK": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [ElevationLayer] "KOAK" : Error: layer does not have a valid TileSource, cannot create heightfield
[osgEarth]* [TileSource] Open failed: Dataset has no spatial reference information (/home/theddy/.fgfs/OsgEarthCache//GeneratedHeightFields//KHWD.tiff)
[osgEarth]* [TerrainLayer] "KHWD": Could not initialize driver
[osgEarth]  [TerrainLayer] "KHWD": Could not initialize TileSource , but a cache exists. Setting layer to cache-only mode.
[osgEarth]* [TerrainLayer] "KHWD": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [TerrainLayer] "KHWD": Failed to open a cache for layer because cache_only policy is in effect and bin [heightFields_71170a4a] could not be located.
[osgEarth]* [ElevationLayer] "KHWD" : Error: layer does not have a valid TileSource, cannot create heightfield
Electrical system initialized
KAP140 power up
[OsgEarthHeightCache] Height queries ARE now within tolerance

De même quand je modifie certaines options de osgearth, plantage. Mais je tire mon chapeau à f-fjth pour son script. Un grand merci à lann et f-toro pour leur persévérance.

Dernière modification par Biloute974 (1/02/2015 16:16:06)


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

Pied de page des forums