Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#1 25/05/2017 12:47:44

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

[RÉSOLU] Erreur de segmentation (core dumped)

Bonjour tout le monde,

Ce matin j'ai voulu mettre à jour ma version de Flightgear pour passer de la 2017.1.3 à la 2017.2.1! Étant sous ubuntu j'ai utilisé le script ./download_and_compile.sh. J'ai donc lancé en ligne de commande

./download_and_compile.sh -i

(pour SIMGEAR) puis

./download_and_compile.sh -s DATA FGFS TERRAGEAR

. Une fois la m.à.j. terminée je lance Flightgear en ligne de commande avec le QT launcher comme d'habitude:

Flightgear/install/flightgear/bin/fgfs --launcher

Là je sélectionne le C172 avec l'aéroport de Pierrefonds FMEP et je cliques sur "FLY". J'ai le splash screen et FG charge tranquillement jusqu'à ce que j'arrive aux sous systèmes ou aux scènes (ça dépend de l'avion que j'utilise) et là Flightgear crash sans raison apparente à part ce message d'erreur qui m'a l'air connu du monde Flightgearien d'après les recherches que j'ai faites:

Erreur de segmentation (core dumped)

. Comme je vous l'ai laissé entendre j'ai ratissé les forums anglais et français à propos de ce message mais je ne trouve de solutions nul part hmm C'est une erreur que je n'ai jamais eu depuis que j'utilise Flightgear (3ans depuis peu). Voici tout le message de la console depuis que je lance le Qt Launcher jusqu'à l'erreur de segmentation:

Flightgear/install/flightgear/bin/fgfs --launcher
FlightGear:  Version 2017.2.1
FlightGear:  Build Type Dev
Built with GNU C++ version 4.9
Jenkins number/ID 0:none
platform default fg_root = Path "/home/pop/Flightgear/install/flightgear/lib/FlightGear"
Reading global defaults
Finished Reading global defaults
Reading user settings from Path "/home/pop/.fgfs/autosave_2017_2.xml"
scenery path not found:Path "/home/pop/Flightgear/install/flightgear/fgdata/Scenery"
NavCache at:Path "/home/pop/.fgfs/navdata_2017_2.cache"
NavCache read-only flags is:0
NavCache: no main cache rebuild required
init package root at:Path "/home/pop/.fgfs/Aircraft"
scenery path not found:Path "/home/pop/Flightgear/install/flightgear/fgdata/Scenery"
aircraft = c172p
found aircraft in dir: /home/pop/Flightgear/install/flightgear/fgdata/Aircraft/c172p
Found language resource for: fr_FR
Reading localized strings for 'en' from Path "/home/pop/Flightgear/install/flightgear/fgdata/Translations/en/sys.xml"
Reading localized strings for 'fr' from Path "/home/pop/Flightgear/install/flightgear/fgdata/Translations/fr/sys.xml"
Reading localized strings for 'en' from Path "/home/pop/Flightgear/install/flightgear/fgdata/Translations/en/atc.xml"
Reading localized strings for 'fr' from Path "/home/pop/Flightgear/install/flightgear/fgdata/Translations/en/atc.xml"
No path in /sim[0]/intl[0]/locale[0]/strings[0]/tips.
No path in /sim[0]/intl[0]/locale[3]/strings[0]/tips.
	option:aircraft-dir = /home/pop/Flightgear/install/flightgear/fgdata/Aircraft/c172p
	option:aircraft = c172p
	option:airport = FMEP
	option:runway = 15
	option:disable-auto-coordination = 
	option:disable-terrasync = 
	option:disable-fullscreen = 
Setting geometry to 640x480

	option:geometry = 640x480
	option:prop = /sim/rendering/multi-sample-buffers=false
	option:prop = /sim/rendering/multi-samples=0
	option:disable-rembrandt = 
	option:season = summer
	option:disable-real-weather-fetch = 
	option:metar = XXXX 012345Z 15003KT 19SM FEW072 FEW350 25/07 Q1028 NOSIG
	option:launcher = 
Using default download dir: Path "/home/pop/.fgfs"
read-allowed path not found:Path "/home/pop/.fgfs/AI"
read-allowed path not found:Path "/home/pop/.fgfs/Liveries"
Using TerraSync dir: Path "/home/pop/.fgfs/TerraSync"
scenery path not found:Path "/home/pop/Flightgear/install/flightgear/fgdata/Scenery"
initializing cloud layers
Enabling ATI/AMD viewport hack
Configuration State
======= ==============
aircraft-dir = "/home/pop/Flightgear/install/flightgear/fgdata/Aircraft/c172p"
fghome-dir = "Path "/home/pop/.fgfs""
download-dir = "/home/pop/.fgfs"
terrasync-dir = "/home/pop/.fgfs/TerraSync"
aircraft-search-paths = 
	
scenery-search-paths = 
	/home/pop/.fgfs/TerraSync
ATI Technologies Inc.
AMD Radeon HD 8500M
4.4.13374 Compatibility Profile Context 15.20.1013
4.40
Splash screen progress loading-aircraft-list
Splash screen progress loading-nav-dat
Splash screen progress init-scenery
General Initialization
======= ==============
FG_ROOT = "Path "/home/pop/Flightgear/install/flightgear/fgdata""

Attempting to set starting position for FMEP:15
Reading timezone info from: Path "/home/pop/Flightgear/install/flightgear/fgdata/Timezone/zone.tab"
Selected scenery is tilecache
FGStgTerrain::init - init tilemgr
Initializing Tile Manager subsystem.
Initializing the tile cache.
  max cache size = 100
  current cache size = 0
  done with init()
Splash screen progress finalize-position
Splash screen progress creating-subsystems
Creating Subsystems
========== ==========
Reading materials from /home/pop/Flightgear/install/flightgear/fgdata/Materials/regions/materials.xml
Reading systems from Path "/home/pop/Flightgear/install/flightgear/fgdata/Aircraft/c172p/Systems/systems.xml"
Initializing HUD Instrument
Reading sound sound from Path "/home/pop/Flightgear/install/flightgear/fgdata/Aircraft/c172p/c172-sound.xml"
Creating subsystems took:774
Splash screen progress binding-subsystems
Erreur de segmentation (core dumped)

Voilà si l'un d'entre vous pourrait m'aider cela me ferait grand plaisir!
Merci par avance,
Amicalement.

Dernière modification par Texan78 (27/05/2017 12:44:11)


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#2 25/05/2017 13:28:17

Biloute974
Membre
Inscription : 2/02/2014
Messages : 991

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Salut,

quelle est la version de ton script ?
Essaye cette version là.


Config: Core I5 4690 (3.5 GHz*4) + 16 Go de Ram + Nvidia GTX 970+ GTX 760 (pilotes 361.28)+ LinuxMint 17.2 64 bits--> FG 2017.1.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols
Mes livrées

Hors ligne

#3 25/05/2017 13:35:07

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Salut Biloute,
Je ne sais pas exactement quelle version j'utilise. J'ai commencé à utiliser le script d&c avec la version 2016 de Flightgear et je n'ai jamais changé le script depuis... Je télécharges cette version et je te donne des nouvelles dès que j'en ai tongue
Merci de ta réponse.


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#4 25/05/2017 14:08:06

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Me revoilà,

Rien n'y fait toujours la même erreur et crash de Flightgear hmm


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#5 25/05/2017 14:49:00

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Bonjour Texan78,

Avec le dernier download_and_compile : as-tu compilé une version FG neuve (dans un dossier vierge) ou appliqué d_and_c sur ton ancienne compilation ? (comme une mise à jour ? A ne pas faire...)


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#6 25/05/2017 15:13:20

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Texan78 a écrit :

./download_and_compile.sh -i

./download_and_compile.sh -s DATA FGFS TERRAGEAR

Flightgear/install/flightgear/bin/fgfs --launcher

Juste par curiosité:
- pourquoi "-i"? cette option compile OPENRTI + SIMGEAR + FGFS.
  openrti ne sert pas et "simgear" et "fgfs" sont compilés automatiquement, donc tu obtiens un fg 2017.3.0 (version dev)
et là avec "./download_and_compile.sh -s DATA FGFS TERRAGEAR" tu mets une version stable de "fgfs" par dessus.

- pourquoi "TERRAGEAR"? tu l'utilises vraiment?

- pourquoi ne pas lancer par "Flightgear/run_fgfs.sh --launcher"?

Crées un dossier /home/pop/Flightgear_2 (ou ce que tu veux) copies-y le script.
Dans un terminal:

cd Flightgear_2
./download_and_compile.sh -j4 -s SIMGEAR FGFS

"-j4" pour bien exploiter ton i5 (ça compilera ~3x plus vite) et -s pour obtenir la dernière version stable, si c'est vraiment ce que tu veux.

Pour ne pas y passer la journée tu peux récupérer le dossier "fgdata" de /home/pop/Flightgear/ (a copier dans /home/pop/Flightgear_2/install/flightgear)
Pour finir un

./download_and_compile.sh -j4 -s DATA

et ça devrait rouler. wink

Dernière modification par ctesc356 (25/05/2017 15:19:43)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#7 25/05/2017 17:54:36

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Salut Dany,
En effet j'ai compilé sur une ancienne compilation. Pourquoi cela est il à éviter? Comment dois-je donc exactement procéder quand je souhaite installer une nouvelle version de Flightgear?

ctesc356 a écrit :

Juste par curiosité:
- pourquoi "-i"? cette option compile OPENRTI + SIMGEAR + FGFS.
  openrti ne sert pas et "simgear" et "fgfs" sont compilés automatiquement, donc tu obtiens un fg 2017.3.0 (version dev)
et là avec "./download_and_compile.sh -s DATA FGFS TERRAGEAR" tu mets une version stable de "fgfs" par dessus.
- pourquoi "TERRAGEAR"? tu l'utilises vraiment?
- pourquoi ne pas lancer par "Flightgear/run_fgfs.sh --launcher"?

A vrai dire je n'ai pas de raison: pour le d&c -i j'ai vu cette commande sur fgwiki et je me suis dit pourquoi pas l'utiliser et non je n'utilise pas TERRAGEAR mais j'aime bien avoir des fonctions qui ne me servent à rien aujourd'hui étant un peu touche à tout je me dis que je pourrai m'y intéresser en temps voulu alors je le mets de côté(ce sont de mauvaises habitudes je sais:rolleyes: ).
Et concernant le launcher j'utilise un peu leu deux commandes mais celle ci était la plus proche dans mon historique de console.

Concernant la suite de ton message j'ai bien tout suivi à la lettre mais rien n'y fait le problème persiste sad


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#8 25/05/2017 18:36:43

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Texan78 a écrit :

En effet j'ai compilé sur une ancienne compilation. Pourquoi cela est il à éviter? Comment dois-je donc exactement procéder quand je souhaite installer une nouvelle version de Flightgear?

Une nouvelle version de d_and_c peut faire appel à d'autres bibliothèques, classer les dossiers différemment, et d'autres choses que je ne sais pas. J'ai déjà eu un échec à la compilation pour ça.

Alors, surtout dans le doute comme toi, nouveau dossier vierge (Flightgear2), compilation avec les options par défaut. A la rigueur si tu veux, ajouter PLIB en premier dans WHATTOBUILDALL pour avoir le défilement par la molette dans les Internal Properties.

WHATTOBUILDALL=(PLIB SIMGEAR FGFS DATA)

et

./download_and_compile.sh -j4 -s

ou

./download_and_compile.sh -j4

Les Data (fgdata) et les librairies (dont OSG et SimGear) doivent être de la même version.

Si tu a suivi la procédure de ctesc356 c'est préoccupant car cela devrait revenir au même. J'espère que cette version avec ses bibliothèques est compatible avec ton Ubuntu 15.04 hmm .

Si tu utilises un raccourci pour le lanceur, pense à mettre l'adresse à jour.
En ligne de commande, tu ne risques pas d’oublier.


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#9 25/05/2017 20:03:07

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Contrôles si les versions de simgear, fgfs et fgdata sont identiques.
pour cela ouvres les fichiers:
- Flightgear_2/flightgear/version
- Flightgear_2/simgear/version
- Flightgear_2/install/flightgear/fgdata/version

leur contenu doit être identique.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#10 26/05/2017 10:26:42

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Essaie de lancer par

./run_fgfs.sh

Donne C172P, probablement à Bergen, peut-être en mer et cassé... tant pis.

D'après ce que je lis dans ma console, il ne passe pas par le Splash screen de cette manière (contrairement à celle par le lanceur Qt).

ou même :

./run_fgfs.sh --aircraft=ufo

(encore plus dénudé de systèmes)


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#11 26/05/2017 15:49:49

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Bonsoir tout le monde,

Alors j'ai bien fait tout ce que vous m'avez dit au-dessus à la lettre et sans plus et le problème continue d'apparaître sad même en lançant avec l'UFO l'erreur revient. Est-il possible de revenir à la version précédente de FG pour vérifier que l'erreur vient bien de FG2017.2.1?


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#12 26/05/2017 17:11:20

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Bizarre,
il n'y a pas eu de messages d'erreur de d&c? même en lançant DATA?
Tu peux nous montrer "compilation-log.txt"?

Essaie de compiler une dev (sans "-s") dans un dossier vierge.
Compiles chaque module à part.

./download_and_compile.sh -j4 SIMGEAR

puis FGFS puis DATA (éventuellement en mj d'un fgdata existant)
Surveilles la console au cas ou il y aurait de erreurs, et copies les ici au besoin.

Dernière modification par ctesc356 (26/05/2017 17:13:11)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#13 26/05/2017 17:27:03

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Non pas de messages d'erreur hmm
Voici le fichier:

./download_and_compile.sh DATA
VERSION=$Id
APT_GET_UPDATE=y
DOWNLOAD_PACKAGES=y
COMPILE=y
RECONFIGURE=y
DOWNLOAD=y
JOPTION=
OOPTION=
BUILD_TYPE=RelWithDebInfo
***********************************
DIRECTORY= /home/pop/Flightgear2
***********************************
****************************************
************** FLIGHTGEAR **************
****************************************
****************************************
**************** DATA ******************
****************************************

Alors justement je viens de le faire chaque module à part mais je n'ai pas regargdé si il y avait des quelconques messages d'erreur. Je peux recommencer mais à ce moment je vous envoies toutes les opérations de la console car je ne saurai pas notifier une erreur quelque part sad


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#14 26/05/2017 17:31:52

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Cette question me turlupine toujours :
Est-ce que cela pourrait être lié à Ubuntu 15.04 ?


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#15 26/05/2017 17:37:14

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

dany93 a écrit :

Cette question me turlupine toujours :
Est-ce que cela pourrait être lié à Ubuntu 15.04 ?

Je ne sais pas. Comment je pourrai le vérifier? hmm Et pourquoi te poses tu cette question? Alors que les anciens FG ont toujours très bien fonctionné avec Ubuntu 15.04


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#16 26/05/2017 17:40:17

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : [RÉSOLU] Erreur de segmentation (core dumped)

dany93 a écrit :

Cette question me turlupine toujours :
Est-ce que cela pourrait être lié à Ubuntu 15.04 ?

Il me semble que ça râlerait à la mise à jour des dépendances ou à la compilation?

@Texan Peux tu nous montrer le début de la console, jusqu'au téléchargement de SIMGEAR ou FGFS?

Tu peux essayer avec ce scipt: https://sourceforge.net/p/flightgear/fg … compile.sh

Dernière modification par ctesc356 (26/05/2017 17:44:16)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#17 26/05/2017 17:47:49

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : [RÉSOLU] Erreur de segmentation (core dumped)

ctesc356 a écrit :
dany93 a écrit :

Cette question me turlupine toujours :
Est-ce que cela pourrait être lié à Ubuntu 15.04 ?

Il me semble que ça râlerait à la mise à jour des dépendances ou à la compilation?

Cela me semble un bon argument.

En réponse à Texan78, c'est bien aux dépendances (disponibilité des bibliothèques) que je pensais. Mais je ne connais pas assez bien pour être précis. FG 2017.2 fait appel à des dépendances supplémentaires. Il faut qu'elles soient disponibles dans Ubuntu 15.04 (quoique d_and_c aille normalement les chercher sinon) et compatibles avec Ubuntu 15.04.


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#18 26/05/2017 18:28:55

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Rebonjour voilà ce que donne la console (utilisation du script 2.34):

root@Pierre:/home/pop/Flightgear2# bash ./download_and_compile.sh -j4 SIMGEAR
**************************************
*                                    *
* Warning, the compilation process   *
* is going to use 12 or more Gbytes  *
* of space and at least a couple of  *
* hours to download and build FG.    *
*                                    *
* Please, be patient ......          *
*                                    *
**************************************
Asking password for 'apt-get update'...
sudo: unable to resolve host Pierre
Atteint http://archive.canonical.com vivid InRelease                           
Atteint http://archive.ubuntu.com vivid InRelease                              
Ign http://dl.google.com stable InRelease                                      
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://archive.canonical.com vivid/partner Sources                     
Atteint http://archive.ubuntu.com vivid-updates InRelease                      
Ign http://dl.google.com stable InRelease                                      
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://archive.canonical.com vivid/partner amd64 Packages              
Atteint http://archive.ubuntu.com vivid-backports InRelease                    
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://archive.canonical.com vivid/partner i386 Packages               
Atteint http://archive.ubuntu.com vivid-security InRelease                     
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://archive.canonical.com vivid/partner Translation-en              
Atteint http://dl.google.com stable Release                                    
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://dl.google.com stable Release                                    
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Atteint http://archive.ubuntu.com vivid/universe Sources                       
Atteint http://dl.google.com stable/main amd64 Packages                        
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://archive.ubuntu.com vivid/multiverse Sources                     
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://archive.ubuntu.com vivid/main amd64 Packages                    
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Atteint http://archive.ubuntu.com vivid/restricted amd64 Packages              
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://dl.google.com stable/main amd64 Packages                        
Atteint http://archive.ubuntu.com vivid/universe amd64 Packages                
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://dl.google.com stable/main i386 Packages                         
Atteint http://archive.ubuntu.com vivid/multiverse amd64 Packages              
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Atteint http://archive.ubuntu.com vivid/main i386 Packages                     
Atteint http://archive.ubuntu.com vivid/restricted i386 Packages               
Atteint http://archive.ubuntu.com vivid/universe i386 Packages                 
Atteint http://archive.ubuntu.com vivid/multiverse i386 Packages               
Atteint http://archive.ubuntu.com vivid/main Translation-fr                    
Atteint http://archive.ubuntu.com vivid/main Translation-en                    
Atteint http://archive.ubuntu.com vivid/multiverse Translation-fr              
Atteint http://archive.ubuntu.com vivid/multiverse Translation-en              
Atteint http://archive.ubuntu.com vivid/restricted Translation-fr              
Atteint http://archive.ubuntu.com vivid/restricted Translation-en              
Atteint http://archive.ubuntu.com vivid/universe Translation-fr                
Atteint http://archive.ubuntu.com vivid/universe Translation-en                
Atteint http://archive.ubuntu.com vivid-updates/restricted Sources             
Atteint http://archive.ubuntu.com vivid-updates/universe Sources               
Atteint http://archive.ubuntu.com vivid-updates/main Sources                   
Atteint http://archive.ubuntu.com vivid-updates/multiverse Sources             
Atteint http://archive.ubuntu.com vivid-updates/main amd64 Packages            
Atteint http://archive.ubuntu.com vivid-updates/restricted amd64 Packages      
Atteint http://archive.ubuntu.com vivid-updates/universe amd64 Packages        
Atteint http://archive.ubuntu.com vivid-updates/multiverse amd64 Packages      
Atteint http://archive.ubuntu.com vivid-updates/main i386 Packages             
Atteint http://archive.ubuntu.com vivid-updates/restricted i386 Packages       
Atteint http://archive.ubuntu.com vivid-updates/universe i386 Packages         
Atteint http://archive.ubuntu.com vivid-updates/multiverse i386 Packages       
Ign http://dl.google.com stable/main Translation-fr_FR                         
Ign http://dl.google.com stable/main Translation-fr                            
Atteint http://archive.ubuntu.com vivid-updates/main Translation-en            
Ign http://dl.google.com stable/main Translation-en                            
Atteint http://archive.ubuntu.com vivid-updates/multiverse Translation-en      
Ign http://dl.google.com stable/main Translation-fr_FR                         
Atteint http://archive.ubuntu.com vivid-updates/restricted Translation-en      
Ign http://dl.google.com stable/main Translation-fr                            
Atteint http://archive.ubuntu.com vivid-updates/universe Translation-en        
Ign http://dl.google.com stable/main Translation-en                            
Atteint http://archive.ubuntu.com vivid-backports/main Sources                 
Atteint http://archive.ubuntu.com vivid-backports/restricted Sources           
Atteint http://archive.ubuntu.com vivid-backports/universe Sources             
Atteint http://archive.ubuntu.com vivid-backports/multiverse Sources           
Atteint http://archive.ubuntu.com vivid-backports/main amd64 Packages          
Atteint http://archive.ubuntu.com vivid-backports/restricted amd64 Packages    
Atteint http://archive.ubuntu.com vivid-backports/universe amd64 Packages      
Atteint http://archive.ubuntu.com vivid-backports/multiverse amd64 Packages    
Atteint http://archive.ubuntu.com vivid-backports/main i386 Packages           
Atteint http://archive.ubuntu.com vivid-backports/restricted i386 Packages     
Atteint http://archive.ubuntu.com vivid-backports/universe i386 Packages       
Atteint http://archive.ubuntu.com vivid-backports/multiverse i386 Packages     
Atteint http://archive.ubuntu.com vivid-backports/main Translation-en          
Atteint http://archive.ubuntu.com vivid-backports/multiverse Translation-en    
Atteint http://archive.ubuntu.com vivid-backports/restricted Translation-en    
Atteint http://archive.ubuntu.com vivid-backports/universe Translation-en      
Atteint http://archive.ubuntu.com vivid-security/restricted Sources            
Atteint http://archive.ubuntu.com vivid-security/universe Sources              
Atteint http://archive.ubuntu.com vivid-security/main Sources                  
Atteint http://archive.ubuntu.com vivid-security/multiverse Sources            
Atteint http://archive.ubuntu.com vivid-security/main amd64 Packages           
Atteint http://archive.ubuntu.com vivid-security/restricted amd64 Packages     
Atteint http://archive.ubuntu.com vivid-security/universe amd64 Packages       
Atteint http://archive.ubuntu.com vivid-security/multiverse amd64 Packages     
Atteint http://archive.ubuntu.com vivid-security/main i386 Packages            
Atteint http://archive.ubuntu.com vivid-security/restricted i386 Packages      
Atteint http://archive.ubuntu.com vivid-security/universe i386 Packages        
Atteint http://archive.ubuntu.com vivid-security/multiverse i386 Packages      
Atteint http://archive.ubuntu.com vivid-security/main Translation-en           
Atteint http://archive.ubuntu.com vivid-security/multiverse Translation-en     
Atteint http://archive.ubuntu.com vivid-security/restricted Translation-en     
Atteint http://archive.ubuntu.com vivid-security/universe Translation-en       
Atteint http://archive.ubuntu.com vivid/main Sources                           
Atteint http://archive.ubuntu.com vivid/restricted Sources                     
Lecture des listes de paquets... Fait                                          
Considering a package alternative: libopenscenegraph-3.4-dev libopenscenegraph-dev libopenscenegraph-[0-9]+\.[0-9]+-dev
Package alternative matched for libopenscenegraph-dev
Considering a package alternative: libpng-dev libpng12-dev libpng16-dev
Package alternative matched for libpng12-dev
Asking password for 'apt-get install build-essential cmake git libarchive-dev libbz2-dev libcurl4-gnutls-dev libexpat1-dev libjsoncpp-dev liblzma-dev libncurses5-dev procps zlib1g-dev libcgal-dev libgdal-dev libtiff5-dev libqt4-dev zlib1g-dev freeglut3-dev libboost-dev libopenscenegraph-dev libopenal-dev libudev-dev qt5-default qtdeclarative5-dev libdbus-1-dev libplib-dev libpng12-dev fluid libbz2-dev libfltk1.3-dev libxi-dev libxmu-dev libxinerama-dev libjpeg-dev libxft-dev python3-pyqt5 python3-pyqt5.qtmultimedia libqt5multimedia5-plugins python-tk'...
sudo: unable to resolve host Pierre
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
cmake est déjà la plus récente version disponible.
freeglut3-dev est déjà la plus récente version disponible.
libarchive-dev est déjà la plus récente version disponible.
libboost-dev est déjà la plus récente version disponible.
libbz2-dev est déjà la plus récente version disponible.
libdbus-1-dev est déjà la plus récente version disponible.
libjpeg-dev est déjà la plus récente version disponible.
liblzma-dev est déjà la plus récente version disponible.
libncurses5-dev est déjà la plus récente version disponible.
libqt5multimedia5-plugins est déjà la plus récente version disponible.
libtiff5-dev est déjà la plus récente version disponible.
libxft-dev est déjà la plus récente version disponible.
libxi-dev est déjà la plus récente version disponible.
libxinerama-dev est déjà la plus récente version disponible.
libxmu-dev est déjà la plus récente version disponible.
procps est déjà la plus récente version disponible.
python-tk est déjà la plus récente version disponible.
qtdeclarative5-dev est déjà la plus récente version disponible.
zlib1g-dev est déjà la plus récente version disponible.
fluid est déjà la plus récente version disponible.
libcgal-dev est déjà la plus récente version disponible.
libfltk1.3-dev est déjà la plus récente version disponible.
libgdal-dev est déjà la plus récente version disponible.
libjsoncpp-dev est déjà la plus récente version disponible.
libopenal-dev est déjà la plus récente version disponible.
libopenscenegraph-dev est déjà la plus récente version disponible.
libplib-dev est déjà la plus récente version disponible.
python3-pyqt5 est déjà la plus récente version disponible.
python3-pyqt5.qtmultimedia est déjà la plus récente version disponible.
git est déjà la plus récente version disponible.
libcurl4-gnutls-dev est déjà la plus récente version disponible.
libexpat1-dev est déjà la plus récente version disponible.
libpng12-dev est déjà la plus récente version disponible.
libqt4-dev est déjà la plus récente version disponible.
libudev-dev est déjà la plus récente version disponible.
qt5-default est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-3.19.0-15 linux-headers-3.19.0-15-generic
  linux-image-3.19.0-15-generic linux-image-extra-3.19.0-15-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

J'ai eu cette fois-ci un message d'erreur lors de la maj de fgdata en copiant collant celui que j'avais déjà:

root@Pierre:/home/pop/Flightgear2# bash ./download_and_compile.sh -j4 DATA
**************************************
*                                    *
* Warning, the compilation process   *
* is going to use 12 or more Gbytes  *
* of space and at least a couple of  *
* hours to download and build FG.    *
*                                    *
* Please, be patient ......          *
*                                    *
**************************************
Asking password for 'apt-get update'...
sudo: unable to resolve host Pierre
Ign http://dl.google.com stable InRelease                                      
Atteint http://archive.ubuntu.com vivid InRelease                              
Atteint http://archive.canonical.com vivid InRelease                           
Atteint http://archive.ubuntu.com vivid-updates InRelease                      
Ign http://dl.google.com stable InRelease                                      
Atteint http://archive.canonical.com vivid/partner Sources                     
Atteint http://archive.ubuntu.com vivid-backports InRelease                    
Atteint http://archive.canonical.com vivid/partner amd64 Packages              
Atteint http://archive.ubuntu.com vivid-security InRelease                     
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://archive.canonical.com vivid/partner i386 Packages               
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://archive.canonical.com vivid/partner Translation-en              
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://archive.ubuntu.com vivid/universe Sources                       
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Atteint http://dl.google.com stable Release                                    
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://dl.google.com stable Release                                    
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://archive.ubuntu.com vivid/multiverse Sources                     
Atteint http://dl.google.com stable/main amd64 Packages                        
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Atteint http://archive.ubuntu.com vivid/main amd64 Packages                    
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://archive.ubuntu.com vivid/restricted amd64 Packages              
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://archive.ubuntu.com vivid/universe amd64 Packages                
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Atteint http://archive.ubuntu.com vivid/multiverse amd64 Packages              
Atteint http://archive.ubuntu.com vivid/main i386 Packages                     
Atteint http://archive.ubuntu.com vivid/restricted i386 Packages               
Atteint http://archive.ubuntu.com vivid/universe i386 Packages                 
Atteint http://archive.ubuntu.com vivid/multiverse i386 Packages               
Atteint http://dl.google.com stable/main amd64 Packages                        
Atteint http://dl.google.com stable/main i386 Packages                         
Atteint http://archive.ubuntu.com vivid/main Translation-fr                    
Atteint http://archive.ubuntu.com vivid/main Translation-en                    
Atteint http://archive.ubuntu.com vivid/multiverse Translation-fr              
Atteint http://archive.ubuntu.com vivid/multiverse Translation-en              
Atteint http://archive.ubuntu.com vivid/restricted Translation-fr              
Atteint http://archive.ubuntu.com vivid/restricted Translation-en              
Atteint http://archive.ubuntu.com vivid/universe Translation-fr                
Atteint http://archive.ubuntu.com vivid/universe Translation-en                
Atteint http://archive.ubuntu.com vivid-updates/restricted Sources             
Atteint http://archive.ubuntu.com vivid-updates/universe Sources               
Atteint http://archive.ubuntu.com vivid-updates/main Sources                   
Atteint http://archive.ubuntu.com vivid-updates/multiverse Sources             
Atteint http://archive.ubuntu.com vivid-updates/main amd64 Packages            
Atteint http://archive.ubuntu.com vivid-updates/restricted amd64 Packages      
Atteint http://archive.ubuntu.com vivid-updates/universe amd64 Packages        
Atteint http://archive.ubuntu.com vivid-updates/multiverse amd64 Packages      
Atteint http://archive.ubuntu.com vivid-updates/main i386 Packages             
Atteint http://archive.ubuntu.com vivid-updates/restricted i386 Packages       
Atteint http://archive.ubuntu.com vivid-updates/universe i386 Packages         
Atteint http://archive.ubuntu.com vivid-updates/multiverse i386 Packages       
Atteint http://archive.ubuntu.com vivid-updates/main Translation-en            
Atteint http://archive.ubuntu.com vivid-updates/multiverse Translation-en      
Atteint http://archive.ubuntu.com vivid-updates/restricted Translation-en      
Ign http://dl.google.com stable/main Translation-fr_FR                         
Atteint http://archive.ubuntu.com vivid-updates/universe Translation-en        
Ign http://dl.google.com stable/main Translation-fr                            
Atteint http://archive.ubuntu.com vivid-backports/main Sources                 
Ign http://dl.google.com stable/main Translation-en                            
Atteint http://archive.ubuntu.com vivid-backports/restricted Sources           
Ign http://dl.google.com stable/main Translation-fr_FR                         
Atteint http://archive.ubuntu.com vivid-backports/universe Sources             
Ign http://dl.google.com stable/main Translation-fr                            
Atteint http://archive.ubuntu.com vivid-backports/multiverse Sources           
Ign http://dl.google.com stable/main Translation-en                            
Atteint http://archive.ubuntu.com vivid-backports/main amd64 Packages          
Atteint http://archive.ubuntu.com vivid-backports/restricted amd64 Packages    
Atteint http://archive.ubuntu.com vivid-backports/universe amd64 Packages      
Atteint http://archive.ubuntu.com vivid-backports/multiverse amd64 Packages    
Atteint http://archive.ubuntu.com vivid-backports/main i386 Packages           
Atteint http://archive.ubuntu.com vivid-backports/restricted i386 Packages     
Atteint http://archive.ubuntu.com vivid-backports/universe i386 Packages       
Atteint http://archive.ubuntu.com vivid-backports/multiverse i386 Packages     
Atteint http://archive.ubuntu.com vivid-backports/main Translation-en          
Atteint http://archive.ubuntu.com vivid-backports/multiverse Translation-en    
Atteint http://archive.ubuntu.com vivid-backports/restricted Translation-en    
Atteint http://archive.ubuntu.com vivid-backports/universe Translation-en      
Atteint http://archive.ubuntu.com vivid-security/restricted Sources            
Atteint http://archive.ubuntu.com vivid-security/universe Sources              
Atteint http://archive.ubuntu.com vivid-security/main Sources                  
Atteint http://archive.ubuntu.com vivid-security/multiverse Sources            
Atteint http://archive.ubuntu.com vivid-security/main amd64 Packages           
Atteint http://archive.ubuntu.com vivid-security/restricted amd64 Packages     
Atteint http://archive.ubuntu.com vivid-security/universe amd64 Packages       
Atteint http://archive.ubuntu.com vivid-security/multiverse amd64 Packages     
Atteint http://archive.ubuntu.com vivid-security/main i386 Packages            
Atteint http://archive.ubuntu.com vivid-security/restricted i386 Packages      
Atteint http://archive.ubuntu.com vivid-security/universe i386 Packages        
Atteint http://archive.ubuntu.com vivid-security/multiverse i386 Packages      
Atteint http://archive.ubuntu.com vivid-security/main Translation-en           
Atteint http://archive.ubuntu.com vivid-security/multiverse Translation-en     
Atteint http://archive.ubuntu.com vivid-security/restricted Translation-en     
Atteint http://archive.ubuntu.com vivid-security/universe Translation-en       
Atteint http://archive.ubuntu.com vivid/main Sources                           
Atteint http://archive.ubuntu.com vivid/restricted Sources                     
Lecture des listes de paquets... Fait                                          
Considering a package alternative: libopenscenegraph-3.4-dev libopenscenegraph-dev libopenscenegraph-[0-9]+\.[0-9]+-dev
Package alternative matched for libopenscenegraph-dev
Considering a package alternative: libpng-dev libpng12-dev libpng16-dev
Package alternative matched for libpng12-dev
Asking password for 'apt-get install build-essential cmake git libarchive-dev libbz2-dev libcurl4-gnutls-dev libexpat1-dev libjsoncpp-dev liblzma-dev libncurses5-dev procps zlib1g-dev libcgal-dev libgdal-dev libtiff5-dev libqt4-dev zlib1g-dev freeglut3-dev libboost-dev libopenscenegraph-dev libopenal-dev libudev-dev qt5-default qtdeclarative5-dev libdbus-1-dev libplib-dev libpng12-dev fluid libbz2-dev libfltk1.3-dev libxi-dev libxmu-dev libxinerama-dev libjpeg-dev libxft-dev python3-pyqt5 python3-pyqt5.qtmultimedia libqt5multimedia5-plugins python-tk'...
sudo: unable to resolve host Pierre
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
cmake est déjà la plus récente version disponible.
freeglut3-dev est déjà la plus récente version disponible.
libarchive-dev est déjà la plus récente version disponible.
libboost-dev est déjà la plus récente version disponible.
libbz2-dev est déjà la plus récente version disponible.
libdbus-1-dev est déjà la plus récente version disponible.
libjpeg-dev est déjà la plus récente version disponible.
liblzma-dev est déjà la plus récente version disponible.
libncurses5-dev est déjà la plus récente version disponible.
libqt5multimedia5-plugins est déjà la plus récente version disponible.
libtiff5-dev est déjà la plus récente version disponible.
libxft-dev est déjà la plus récente version disponible.
libxi-dev est déjà la plus récente version disponible.
libxinerama-dev est déjà la plus récente version disponible.
libxmu-dev est déjà la plus récente version disponible.
procps est déjà la plus récente version disponible.
python-tk est déjà la plus récente version disponible.
qtdeclarative5-dev est déjà la plus récente version disponible.
zlib1g-dev est déjà la plus récente version disponible.
fluid est déjà la plus récente version disponible.
libcgal-dev est déjà la plus récente version disponible.
libfltk1.3-dev est déjà la plus récente version disponible.
libgdal-dev est déjà la plus récente version disponible.
libjsoncpp-dev est déjà la plus récente version disponible.
libopenal-dev est déjà la plus récente version disponible.
libopenscenegraph-dev est déjà la plus récente version disponible.
libplib-dev est déjà la plus récente version disponible.
python3-pyqt5 est déjà la plus récente version disponible.
python3-pyqt5.qtmultimedia est déjà la plus récente version disponible.
git est déjà la plus récente version disponible.
libcurl4-gnutls-dev est déjà la plus récente version disponible.
libexpat1-dev est déjà la plus récente version disponible.
libpng12-dev est déjà la plus récente version disponible.
libqt4-dev est déjà la plus récente version disponible.
libudev-dev est déjà la plus récente version disponible.
qt5-default est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-3.19.0-15 linux-headers-3.19.0-15-generic
  linux-image-3.19.0-15-generic linux-image-extra-3.19.0-15-generic
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
****************************************
************** FLIGHTGEAR **************
****************************************
****************************************
**************** DATA ******************
****************************************
https://git.code.sf.net/p/flightgear/fgdata exists already
warning: CRLF will be replaced by LF in Aircraft/c172p/dev/blender.tar.gz.
The file will have its original line endings in your working directory.

*** Please tell me who you are.

Run

  git config --global user.email "you@example.com"
  git config --global user.name "Your Name"

to set your account's default identity.
Omit --global to set the identity only in this repository.

fatal: unable to auto-detect email address (got 'root@Pierre.(none)')
Impossible de sauver l'état courant de l'index 

En attendant je réessaye avec le lien du script que ctesc356 m'a envoyé...


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#19 26/05/2017 19:33:10

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

ctesc356 j'ai tout recommencé avec le lien du scipt d&c que tu m'as donné plus haut et le problème persiste... sad
Le problème pourrait aussi provenir du dossier fgdata, pensez-vous que le retélécharger complètement est une solution?


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#20 27/05/2017 0:19:00

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Essaie, ça prend du temps mais ne peut faire de mal wink

Sinon pour revenir à une version antérieure, tu peux télécharger les sources simgear et fgfs + fgdata ici: ( sous " More branches")
https://sourceforge.net/p/flightgear/fl … /branches/

puis les compiler avec d&c -dn

Dernière modification par ctesc356 (27/05/2017 0:20:08)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#21 27/05/2017 8:13:09

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Salut à tous,

J'ai pas tout suivi, mais il me semble que les dernières lignes concernant DATA concernent un fichier qui a été modifié, et git demande une identification sur le compte git.

**************** DATA ******************
****************************************
https://git.code.sf.net/p/flightgear/fgdata exists already
warning: CRLF will be replaced by LF in Aircraft/c172p/dev/blender.tar.gz.
The file will have its original line endings in your working directory.

*** Please tell me who you are.

Run

  git config --global user.email "you@example.com"
  git config --global user.name "Your Name"

to set your account's default identity.
Omit --global to set the identity only in this repository.

fatal: unable to auto-detect email address (got 'root@Pierre.(none)')
Impossible de sauver l'état courant de l'index 

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#22 27/05/2017 9:06:41

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Salut Patten,
oui j'ai compris cela mais que suis-je donc sensé faire au juste?


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#23 27/05/2017 10:00:57

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Bonjour,
tu as modifié quelque chose dans fgdata?
Si tu as un compte git, lances ces 3commandes depuis le répertoire "fgdata"

1.git init
2.git config user.name "someone"
3.git config user.email "someone@someplace.com"

sinon essaie "git pull" aussi depuis fgdata.
Tu peux aussi essayer de supprimer le dossier caché ".git" dans fgdata
Au pire il faudra re-télécharger fgdata


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#24 27/05/2017 11:28:57

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : [RÉSOLU] Erreur de segmentation (core dumped)

Dites-moi si je me trompe, mais je pense que tu peux vérifier ta bonne identification par git (en général, pas seulement pour fgdata) par :

git config --list --global | grep user

Réponse :

user.email=ton.email@mail-adresse.com
user.name=ton-username-pour-git

https://stackoverflow.com/questions/146 … 3#14662703

Cependant, je croyais que ce n'était utile que pour faire des "git push". A ma connaissance, la compilation par d_and_c ne nécessite pas d'avoir un compte git. Ce ne sont que des "git pull".


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#25 27/05/2017 12:19:56

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : [RÉSOLU] Erreur de segmentation (core dumped)

ctesc356 a écrit :

Bonjour,
tu as modifié quelque chose dans fgdata?
Si tu as un compte git, lances ces 3commandes depuis le répertoire "fgdata"

1.git init
2.git config user.name "someone"
3.git config user.email "someone@someplace.com"

sinon essaie "git pull" aussi depuis fgdata.
Tu peux aussi essayer de supprimer le dossier caché ".git" dans fgdata
Au pire il faudra re-télécharger fgdata

Pas mieux, tu peux aussi remettre le dossier dans l'état dans lequel il était avant que tu le bidouilles.

CRLF will be replaced by LF in Aircraft/c172p/dev/blender.tar.gz.

https://sourceforge.net/p/flightgear/fg … c172p/dev/

smile

Dernière modification par Patten (27/05/2017 12:22:34)


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

Pied de page des forums