Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#51 3/03/2015 11:44:05

f-jjth
Membre
Inscription : 11/02/2012
Messages : 632

Re : Download_and_compile.sh

@Ernest: content que ça plaise smile

Oui OSG est désormais maintenu par la distrib ça évite 45 min de compilation alors que le paquet est dans le manager de paquets de nos chère distri wink
Du coup pour mettre à jour OSG il te suffit de faire une banale mise à jour de tes paquets comme si tu mettais à jour Firefox ou Gimp, tu mettra à jour OSG de la même manière

PLIB est facultatif aussi puisque là encore j'installe la version du manager de paquet, je laisse l'option PLIB parce que selon les distri certaines fournisse une version de PLIB qui n'inclu pas le scroll up/down de la roulette dans les menus (genre arbre de propriété)

Pour OPENRTI: il est aussi facultatif et même inutile actuellement puisqu'il faut compiler SG et FG avec l'option -DENABLE_RTI=1 (ou un truc du genre, j'ai pas le script sous les yeux) or le script 2.31 n'a pas cette option.
Disons que c'est pour les aventuriers qui souhaitent expérimenter RTI (qui ne fait absolument rien de plus à l'heure actuelle... malheureusement Mathias (le dev de OpenRTI) à quitté le navire il y a quelques mois même si je sais qu'il garde un oeil sur le projet)
Pour résumer: OPENRTI il sert à rien actuellement (à mon grand désespoir)

J'ai presque hésité à l'enlever... tu en penses quoi ? à garder ? ou à jeter parce que ça donne de faux espoir (on le compile mais il sert à rien) ?

Et bien vu pour la création des dossiers vide !! j'vais voir ça ! smile



@Biloute: cool ! pour info c'était juste une erreur de rm -f ../../CMakeCache.txt qu'il fallait remplacer en rm -f CMakeCache.txt

@Dany:  download_and_compile.sh -j12 est parfait en tout temps: pour une première installe mais aussi pour les mise à jours suivant l'installe wink


(P'tite info: Bientôt un fgdata allégé !! ça arrive lentement mais sûrement  cool )


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#52 3/03/2015 11:52:53

ctesc356
Membre
Inscription : 18/05/2010
Messages : 3 004

Re : Download_and_compile.sh

dany93 a écrit :

ou

./download_and_compile.sh -j12 ALL

apporte-t-il quelque chose ?

oui, il utilisera mieux ton cpu, qoique je trouve -j12 prétentieux smile smile smile  -j4 fera pareil, sinon le ALL n'apportera rien.
si tu es pressé tu fais minimaliste : ./download_and_compile.sh -j4 SIMGEAR FGFS, c'est là qu'il y a le plus de modifs


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint/Debian testing

Hors ligne

#53 3/03/2015 11:59:40

ctesc356
Membre
Inscription : 18/05/2010
Messages : 3 004

Re : Download_and_compile.sh

f-jjth a écrit :

Pour résumer: OPENRTI il sert à rien actuellement (à mon grand désespoir)

J'ai presque hésité à l'enlever... tu en penses quoi ? à garder ? ou à jeter parce que ça donne de faux espoir (on le compile mais il sert à rien) ?

Du moment qu'on le sait, on peut aussi bien le laisser, en espérant une suite, il y a bien tout les autres modules facultatifs.
C'est la force de ce script, on peut faire son marché selon ses besoins smile

en somme pour un fg fonctionnel : d&c -j4 SIMGEAR FGFS
PLIB la 1ere fois et encore à voir avec sa disribution.
Et on peut toujours compiler un module supplémentaire au besoin par d&c XXX, pas besoin de toucher "WHATOBUILDALL"

Dernière modification par ctesc356 (3/03/2015 12:04:38)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint/Debian testing

Hors ligne

#54 3/03/2015 12:02:11

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 3 391

Re : Download_and_compile.sh

Merci pour vos réponses.


FG 2020.3.0 (et 2019.2.0), OSG 3.4.2, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB
Boeing 787-8 (YASim, avec nickyivyca, aco)
Hangar avions Patten (PAF) Robin  DR400 JSBSim, Douglas DC3 JSBSim, CAP10B, Tecnam P92 JSBSim.

Hors ligne

#55 3/03/2015 13:29:04

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 691
Site Web

Re : Download_and_compile.sh

Bonjour à tous,

dany93 a écrit :

Bonjour,

Téléchargement et exécution de download_and_compile version 2.31 (lien Clément ci-dessus, avec WHATTOBUILDALL par défaut, au moins pour cette première exécution) :
Tout OK dans la console d_and_c, FGRun fonctionne tel quel, FG aussi.

Merci Clément pour cette maintenance et ces mises au point ! smile

Dany

Config initiale :
(LM 17, FG 3.5 inchangé) avec download_and_compile version 2.28.

Pour les mises à jour futures, quelle est l'instruction suffisante ?

./download_and_compile.sh

me semblerait suffisant;

ou

./download_and_compile.sh -j12 ALL

apporte-t-il quelque chose ?

Compilé aussi avec la 2.31 ce matin, RAS, (sans TERRAGEAR & TERRGEARGUI, je ne m'en sert pas).

À l'avenir, mon ALL sera ainsi:

WHATTOBUILDALL=(OPENRTI SIMGEAR FGFS ATCPIE)

Pour les m-à-J:

./download_and_compile.sh -j 12  -u ALL

-J12 fait bosser tes 12 cœurs du processeur lol , en tous cas çà gruge le script et lui fait croire que tu en a 12, toute la ressource est dans la compilation, c'est ce que j'avais cru comprendre.

le -u, j'ai oublié et surtout la flemme de chercher pourquoi je m'en sert, mais çà mange pas de pain.  tongue

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.CM MSI Z270 Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:3*500Go SSD 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot LinuxMint 19.3 Tricia/Windows10 FG2019.2
http://pattenflightgear.wifeo.com/

Hors ligne

#56 3/03/2015 13:36:27

ctesc356
Membre
Inscription : 18/05/2010
Messages : 3 004

Re : Download_and_compile.sh

Patten a écrit :

le -u, j'ai oublié et surtout la flemme de chercher pourquoi je m'en sert, mais çà mange pas de pain.

-u ou UPDATE même combat smile

f-jjth a écrit :

Du coup j'en ai profité pour simplifier et améliorer: l'option UPDATE n'existe plus  (en fait... elle n'a jamais servit à rien cette option, désolé pour ceux qui s'enquiquinait à mettre UPDATE dans la ligne de commande, vous inquiétez pas ça fait pas mal wink )

Ho! Christian faut suivre un peu! lol


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint/Debian testing

Hors ligne

#57 3/03/2015 14:07:08

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 691
Site Web

Re : Download_and_compile.sh

ctesc356 a écrit :
Patten a écrit :

le -u, j'ai oublié et surtout la flemme de chercher pourquoi je m'en sert, mais çà mange pas de pain.

-u ou UPDATE même combat smile

f-jjth a écrit :

Du coup j'en ai profité pour simplifier et améliorer: l'option UPDATE n'existe plus  (en fait... elle n'a jamais servit à rien cette option, désolé pour ceux qui s'enquiquinait à mettre UPDATE dans la ligne de commande, vous inquiétez pas ça fait pas mal wink )

Ho! Christian faut suivre un peu! lol

[Mode faux ku ON] Oui, c'est çà, je savais, mais c'était pour voir si toi tu suivais  tongue   [Mode faux ku OFF]


Intel I7.7700k 4.2 GHz 4 C 8 tr.CM MSI Z270 Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:3*500Go SSD 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot LinuxMint 19.3 Tricia/Windows10 FG2019.2
http://pattenflightgear.wifeo.com/

Hors ligne

#58 3/03/2015 20:36:00

Biloute974
Membre
Inscription : 2/02/2014
Messages : 1 011

Re : Download_and_compile.sh

Hé bien merci pour toutes ces précisions et un superbe travail de Clément wink


Config: Core I7 7700  + 16 Go de Ram  DDR4+ Nvidia GTX 970 + LinuxMint 18.2 64 bits--> FG 2017.4.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols

Hors ligne

#59 6/03/2015 19:34:41

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 691
Site Web

Re : Download_and_compile.sh

Salut à tous,

J'ai rien fait de spécial à part un vol LFLS-LOWI, donc rien à voir.
Cependant, les git pull ne passent plus:

titi17@ordi-de-titi17 ~/fgfs/install/flightgear/fgdata $ git pull
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
titi17@ordi-de-titi17 ~/fgfs/install/flightgear/fgdata $ 

Quand au ./download_and_compile.sh -j 12   ALL

titi17@ordi-de-titi17 ~/fgfs $ ./download_and_compile.sh -j 12   ALL
**************************************
*                                    *
* Warning, the compilation process   *
* is going to use 12 or more Gbytes  *
* of space and at least a couple of  *
* hours to download and build FG.    *
*                                    *
* Please, be patient ......          *
*                                    *
**************************************
Asking password for apt-get operations...
[sudo] password for titi17: 
Ign http://archive.canonical.com trusty InRelease
Ign http://archive.ubuntu.com trusty InRelease                                 
Atteint http://archive.canonical.com trusty Release.gpg                        
Ign http://security.ubuntu.com trusty-security InRelease                       
Ign http://dl.google.com stable InRelease                                      
Ign http://ppa.launchpad.net trusty InRelease                                  
Ign http://archive.ubuntu.com trusty-updates InRelease                         
Atteint http://archive.canonical.com trusty Release                            
Réception de : 1 http://security.ubuntu.com trusty-security Release.gpg [933 B]
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://archive.ubuntu.com trusty Release.gpg                           
Ign http://ppa.launchpad.net trusty InRelease                                  
Réception de : 2 http://security.ubuntu.com trusty-security Release [62,0 kB]  
Atteint http://dl.google.com stable Release                                    
Réception de : 3 http://archive.ubuntu.com trusty-updates Release.gpg [933 B]  
Ign http://ppa.launchpad.net trusty InRelease                                  
Atteint http://archive.canonical.com trusty/partner amd64 Packages             
Ign http://packages.linuxmint.com rebecca InRelease                            
Atteint http://archive.ubuntu.com trusty Release                               
Ign http://ppa.launchpad.net trusty InRelease                                  
Atteint http://archive.canonical.com trusty/partner i386 Packages              
Ign http://extra.linuxmint.com rebecca InRelease                               
Atteint http://dl.google.com stable/main amd64 Packages                        
Réception de : 4 http://archive.ubuntu.com trusty-updates Release [62,0 kB]    
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Atteint http://archive.canonical.com trusty/partner Translation-en             
Atteint http://dl.google.com stable/main i386 Packages                         
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Réception de : 5 http://packages.linuxmint.com rebecca Release.gpg [198 B]     
Réception de : 6 http://security.ubuntu.com trusty-security/main amd64 Packages [221 kB]
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Réception de : 7 http://extra.linuxmint.com rebecca Release.gpg [198 B]        
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Réception de : 8 http://packages.linuxmint.com rebecca Release [24,1 kB]       
Atteint http://archive.ubuntu.com trusty/main amd64 Packages                   
Atteint http://archive.ubuntu.com trusty/restricted amd64 Packages             
Réception de : 9 http://extra.linuxmint.com rebecca Release [3 212 B]          
Atteint http://archive.ubuntu.com trusty/universe amd64 Packages               
Atteint http://archive.ubuntu.com trusty/multiverse amd64 Packages             
Réception de : 10 http://security.ubuntu.com trusty-security/restricted amd64 Packages [8 875 B]
Atteint http://archive.ubuntu.com trusty/main i386 Packages                    
Réception de : 11 http://extra.linuxmint.com rebecca/main amd64 Packages [7 902 B]
Atteint http://archive.ubuntu.com trusty/restricted i386 Packages              
Réception de : 12 http://packages.linuxmint.com rebecca/main amd64 Packages [32,8 kB]
Atteint http://ppa.launchpad.net trusty Release                                
Atteint http://archive.ubuntu.com trusty/universe i386 Packages                
Réception de : 13 http://security.ubuntu.com trusty-security/universe amd64 Packages [87,7 kB]
Atteint http://ppa.launchpad.net trusty Release                                
Atteint http://archive.ubuntu.com trusty/multiverse i386 Packages              
Atteint http://ppa.launchpad.net trusty Release                                
Réception de : 14 http://extra.linuxmint.com rebecca/main i386 Packages [7 888 B]
Atteint http://ppa.launchpad.net trusty Release                                
Atteint http://archive.ubuntu.com trusty/main Translation-fr                   
Atteint http://archive.ubuntu.com trusty/main Translation-en                   
Atteint http://ppa.launchpad.net trusty/main Sources                           
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Réception de : 15 http://packages.linuxmint.com rebecca/upstream amd64 Packages [30,0 kB]
Ign http://dl.google.com stable/main Translation-fr_FR                         
Atteint http://archive.ubuntu.com trusty/multiverse Translation-fr             
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Réception de : 16 http://security.ubuntu.com trusty-security/multiverse amd64 Packages [3 458 B]
Ign http://dl.google.com stable/main Translation-fr                            
Réception de : 17 http://security.ubuntu.com trusty-security/main i386 Packages [211 kB]
Ign http://dl.google.com stable/main Translation-en                            
Réception de : 18 http://packages.linuxmint.com rebecca/import amd64 Packages [218 kB]
Atteint http://ppa.launchpad.net trusty/main Sources                           
Atteint http://archive.ubuntu.com trusty/multiverse Translation-en             
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Réception de : 19 http://security.ubuntu.com trusty-security/restricted i386 Packages [8 846 B]
Atteint http://archive.ubuntu.com trusty/restricted Translation-fr             
Atteint http://archive.ubuntu.com trusty/restricted Translation-en             
Réception de : 20 http://security.ubuntu.com trusty-security/universe i386 Packages [87,7 kB]
Atteint http://archive.ubuntu.com trusty/universe Translation-fr               
Atteint http://ppa.launchpad.net trusty/main Sources                           
Atteint http://archive.ubuntu.com trusty/universe Translation-en               
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Réception de : 21 http://archive.ubuntu.com trusty-updates/main amd64 Packages [447 kB]
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Atteint http://ppa.launchpad.net trusty/main Sources                           
Réception de : 22 http://security.ubuntu.com trusty-security/multiverse i386 Packages [3 624 B]
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Atteint http://security.ubuntu.com trusty-security/main Translation-en         
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Atteint http://security.ubuntu.com trusty-security/multiverse Translation-en   
Réception de : 23 http://packages.linuxmint.com rebecca/main i386 Packages [32,1 kB]
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Atteint http://security.ubuntu.com trusty-security/restricted Translation-en   
Atteint http://security.ubuntu.com trusty-security/universe Translation-en     
Réception de : 24 http://packages.linuxmint.com rebecca/upstream i386 Packages [30,0 kB]
Réception de : 25 http://archive.ubuntu.com trusty-updates/restricted amd64 Packages [9 296 B]
Réception de : 26 http://packages.linuxmint.com rebecca/import i386 Packages [219 kB]
Réception de : 27 http://archive.ubuntu.com trusty-updates/universe amd64 Packages [254 kB]
Réception de : 28 http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages [11,2 kB]
Réception de : 29 http://archive.ubuntu.com trusty-updates/main i386 Packages [437 kB]
Ign http://extra.linuxmint.com rebecca/main Translation-fr_FR                  
Ign http://ppa.launchpad.net trusty/main Translation-fr_FR                     
Ign http://ppa.launchpad.net trusty/main Translation-fr                        
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Ign http://ppa.launchpad.net trusty/main Translation-fr_FR                     
Ign http://ppa.launchpad.net trusty/main Translation-fr                        
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Ign http://extra.linuxmint.com rebecca/main Translation-fr                     
Ign http://extra.linuxmint.com rebecca/main Translation-en                     
Réception de : 30 http://archive.ubuntu.com trusty-updates/restricted i386 Packages [9 297 B]
Réception de : 31 http://archive.ubuntu.com trusty-updates/universe i386 Packages [255 kB]
Réception de : 32 http://archive.ubuntu.com trusty-updates/multiverse i386 Packages [11,3 kB]
Atteint http://archive.ubuntu.com trusty-updates/main Translation-en           
Atteint http://archive.ubuntu.com trusty-updates/multiverse Translation-en     
Atteint http://archive.ubuntu.com trusty-updates/restricted Translation-en     
Atteint http://archive.ubuntu.com trusty-updates/universe Translation-en       
Ign http://archive.ubuntu.com trusty/main Translation-fr_FR                    
Ign http://archive.ubuntu.com trusty/multiverse Translation-fr_FR       
Ign http://archive.ubuntu.com trusty/restricted Translation-fr_FR
Ign http://archive.ubuntu.com trusty/universe Translation-fr_FR
Ign http://packages.linuxmint.com rebecca/import Translation-fr_FR             
Ign http://packages.linuxmint.com rebecca/import Translation-fr                
Ign http://packages.linuxmint.com rebecca/import Translation-en                
Ign http://packages.linuxmint.com rebecca/main Translation-fr_FR               
Ign http://packages.linuxmint.com rebecca/main Translation-fr                  
Ign http://packages.linuxmint.com rebecca/main Translation-en                  
Ign http://packages.linuxmint.com rebecca/upstream Translation-fr_FR           
Ign http://packages.linuxmint.com rebecca/upstream Translation-fr              
Ign http://packages.linuxmint.com rebecca/upstream Translation-en              
2 797 ko réceptionnés en 10s (275 ko/s)                                        
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
cmake est déjà la plus récente version disponible.
freeglut3-dev est déjà la plus récente version disponible.
libboost-dev est déjà la plus récente version disponible.
libbz2-dev est déjà la plus récente version disponible.
libjpeg-dev est déjà la plus récente version disponible.
libpng12-dev est déjà la plus récente version disponible.
libqt4-dev est déjà la plus récente version disponible.
libqt5multimedia5-plugins est déjà la plus récente version disponible.
libxft-dev est déjà la plus récente version disponible.
libxi-dev est déjà la plus récente version disponible.
libxinerama-dev est déjà la plus récente version disponible.
libxmu-dev est déjà la plus récente version disponible.
python-tk est déjà la plus récente version disponible.
python3-pyqt5 est déjà la plus récente version disponible.
python3-pyqt5.qtmultimedia est déjà la plus récente version disponible.
zlib1g-dev est déjà la plus récente version disponible.
fluid est déjà la plus récente version disponible.
libcgal-dev est déjà la plus récente version disponible.
libfltk1.3-dev est déjà la plus récente version disponible.
libgdal-dev est déjà la plus récente version disponible.
libopenal-dev est déjà la plus récente version disponible.
libplib-dev est déjà la plus récente version disponible.
git est déjà la plus récente version disponible.
libdbus-1-dev est déjà la plus récente version disponible.
libtiff5-dev est déjà la plus récente version disponible.
libudev-dev est déjà la plus récente version disponible.
qt5-default est déjà la plus récente version disponible.
libopenscenegraph-dev est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  ghc libbsd-dev libffi-dev libglee0d1 liboil0.3 libquicktime2 libunicap2
  libweed0 lives-data ogmtools shared-desktop-ontologies
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 47 non mis à jour.
****************************************
**************** OPENRTI ***************
****************************************
git://gitorious.org/openrti/openrti.git exists already
Déjà sur 'master'
Votre branche est à jour avec 'origin/master'.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Le compilation_log.txt, pas besoin de pastebin tongue :

./download_and_compile.sh ALL
VERSION=2.31
APT_GET_UPDATE=y
DOWNLOAD_PACKAGES=y
COMPILE=y
RECONFIGURE=y
DOWNLOAD=y
JOPTION= -j12 
OOPTION=
DEBUG=
***********************************
DIRECTORY= /home/titi17/fgfs
***********************************
****************************************
**************** OPENRTI ***************
****************************************

un  ./download_and_compile.sh -j 12   DATA

titi17@ordi-de-titi17 ~/fgfs $ ./download_and_compile.sh -j 12   DATA
**************************************
*                                    *
* Warning, the compilation process   *
* is going to use 12 or more Gbytes  *
* of space and at least a couple of  *
* hours to download and build FG.    *
*                                    *
* Please, be patient ......          *
*                                    *
**************************************
Asking password for apt-get operations...
Ign http://dl.google.com stable InRelease
Ign http://ppa.launchpad.net trusty InRelease                                  
Ign http://archive.canonical.com trusty InRelease                              
Atteint http://dl.google.com stable Release.gpg                                
Ign http://ppa.launchpad.net trusty InRelease                                  
Atteint http://archive.canonical.com trusty Release.gpg                        
Atteint http://dl.google.com stable Release                                    
Atteint http://archive.canonical.com trusty Release                            
Ign http://ppa.launchpad.net trusty InRelease                                  
Atteint http://dl.google.com stable/main amd64 Packages                        
Atteint http://archive.canonical.com trusty/partner amd64 Packages             
Ign http://ppa.launchpad.net trusty InRelease                                  
Ign http://archive.ubuntu.com trusty InRelease                                 
Atteint http://dl.google.com stable/main i386 Packages                         
Atteint http://archive.canonical.com trusty/partner i386 Packages              
Ign http://extra.linuxmint.com rebecca InRelease                               
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Ign http://security.ubuntu.com trusty-security InRelease                       
Ign http://packages.linuxmint.com rebecca InRelease                            
Atteint http://archive.canonical.com trusty/partner Translation-en             
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Ign http://archive.ubuntu.com trusty-updates InRelease                         
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Atteint http://security.ubuntu.com trusty-security Release.gpg                 
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Réception de : 1 http://extra.linuxmint.com rebecca Release.gpg [198 B]        
Réception de : 2 http://packages.linuxmint.com rebecca Release.gpg [198 B]     
Atteint http://ppa.launchpad.net trusty Release                                
Atteint http://archive.ubuntu.com trusty Release.gpg                           
Atteint http://ppa.launchpad.net trusty Release                                
Atteint http://security.ubuntu.com trusty-security Release                     
Atteint http://ppa.launchpad.net trusty Release                                
Réception de : 3 http://packages.linuxmint.com rebecca Release [24,1 kB]       
Atteint http://archive.ubuntu.com trusty-updates Release.gpg                   
Réception de : 4 http://extra.linuxmint.com rebecca Release [3 212 B]          
Atteint http://ppa.launchpad.net trusty Release                                
Atteint http://security.ubuntu.com trusty-security/main amd64 Packages         
Atteint http://ppa.launchpad.net trusty/main Sources                           
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Atteint http://archive.ubuntu.com trusty Release                               
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Atteint http://security.ubuntu.com trusty-security/restricted amd64 Packages   
Réception de : 5 http://extra.linuxmint.com rebecca/main amd64 Packages [7 902 B]
Atteint http://archive.ubuntu.com trusty-updates Release                       
Ign http://dl.google.com stable/main Translation-fr_FR                         
Atteint http://security.ubuntu.com trusty-security/universe amd64 Packages     
Ign http://dl.google.com stable/main Translation-fr                            
Réception de : 6 http://packages.linuxmint.com rebecca/main amd64 Packages [32,8 kB]
Ign http://dl.google.com stable/main Translation-en                            
Atteint http://ppa.launchpad.net trusty/main Sources                           
Réception de : 7 http://extra.linuxmint.com rebecca/main i386 Packages [7 888 B]
Atteint http://archive.ubuntu.com trusty/main amd64 Packages                   
Atteint http://security.ubuntu.com trusty-security/multiverse amd64 Packages   
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Atteint http://archive.ubuntu.com trusty/restricted amd64 Packages             
Atteint http://security.ubuntu.com trusty-security/main i386 Packages          
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Atteint http://archive.ubuntu.com trusty/universe amd64 Packages               
Réception de : 8 http://packages.linuxmint.com rebecca/upstream amd64 Packages [30,0 kB]
Atteint http://security.ubuntu.com trusty-security/restricted i386 Packages    
Atteint http://ppa.launchpad.net trusty/main Sources                           
Atteint http://archive.ubuntu.com trusty/multiverse amd64 Packages             
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Atteint http://security.ubuntu.com trusty-security/universe i386 Packages      
Réception de : 9 http://packages.linuxmint.com rebecca/import amd64 Packages [218 kB]
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Atteint http://archive.ubuntu.com trusty/main i386 Packages                    
Atteint http://security.ubuntu.com trusty-security/multiverse i386 Packages    
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Atteint http://ppa.launchpad.net trusty/main Sources                           
Atteint http://archive.ubuntu.com trusty/restricted i386 Packages              
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Atteint http://security.ubuntu.com trusty-security/main Translation-en         
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Atteint http://archive.ubuntu.com trusty/universe i386 Packages                
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Atteint http://security.ubuntu.com trusty-security/multiverse Translation-en   
Atteint http://archive.ubuntu.com trusty/multiverse i386 Packages              
Atteint http://security.ubuntu.com trusty-security/restricted Translation-en   
Atteint http://security.ubuntu.com trusty-security/universe Translation-en     
Atteint http://archive.ubuntu.com trusty/main Translation-fr                   
Atteint http://archive.ubuntu.com trusty/main Translation-en                   
Réception de : 10 http://packages.linuxmint.com rebecca/main i386 Packages [32,1 kB]
Atteint http://archive.ubuntu.com trusty/multiverse Translation-fr             
Réception de : 11 http://packages.linuxmint.com rebecca/upstream i386 Packages [30,0 kB]
Atteint http://archive.ubuntu.com trusty/multiverse Translation-en             
Ign http://ppa.launchpad.net trusty/main Translation-fr_FR                     
Ign http://ppa.launchpad.net trusty/main Translation-fr                        
Réception de : 12 http://packages.linuxmint.com rebecca/import i386 Packages [219 kB]
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Ign http://ppa.launchpad.net trusty/main Translation-fr_FR                     
Ign http://ppa.launchpad.net trusty/main Translation-fr                        
Atteint http://archive.ubuntu.com trusty/restricted Translation-fr             
Ign http://ppa.launchpad.net trusty/main Translation-en                        
Atteint http://archive.ubuntu.com trusty/restricted Translation-en             
Atteint http://archive.ubuntu.com trusty/universe Translation-fr               
Ign http://extra.linuxmint.com rebecca/main Translation-fr_FR                  
Atteint http://archive.ubuntu.com trusty/universe Translation-en               
Atteint http://archive.ubuntu.com trusty-updates/main amd64 Packages           
Atteint http://archive.ubuntu.com trusty-updates/restricted amd64 Packages     
Ign http://extra.linuxmint.com rebecca/main Translation-fr                     
Atteint http://archive.ubuntu.com trusty-updates/universe amd64 Packages       
Ign http://extra.linuxmint.com rebecca/main Translation-en                     
Atteint http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages     
Atteint http://archive.ubuntu.com trusty-updates/main i386 Packages            
Atteint http://archive.ubuntu.com trusty-updates/restricted i386 Packages      
Atteint http://archive.ubuntu.com trusty-updates/universe i386 Packages        
Atteint http://archive.ubuntu.com trusty-updates/multiverse i386 Packages      
Atteint http://archive.ubuntu.com trusty-updates/main Translation-en           
Atteint http://archive.ubuntu.com trusty-updates/multiverse Translation-en     
Atteint http://archive.ubuntu.com trusty-updates/restricted Translation-en     
Atteint http://archive.ubuntu.com trusty-updates/universe Translation-en       
Ign http://archive.ubuntu.com trusty/main Translation-fr_FR                    
Ign http://archive.ubuntu.com trusty/multiverse Translation-fr_FR              
Ign http://archive.ubuntu.com trusty/restricted Translation-fr_FR              
Ign http://archive.ubuntu.com trusty/universe Translation-fr_FR                
Ign http://packages.linuxmint.com rebecca/import Translation-fr_FR             
Ign http://packages.linuxmint.com rebecca/import Translation-fr                
Ign http://packages.linuxmint.com rebecca/import Translation-en                
Ign http://packages.linuxmint.com rebecca/main Translation-fr_FR               
Ign http://packages.linuxmint.com rebecca/main Translation-fr                  
Ign http://packages.linuxmint.com rebecca/main Translation-en                  
Ign http://packages.linuxmint.com rebecca/upstream Translation-fr_FR           
Ign http://packages.linuxmint.com rebecca/upstream Translation-fr              
Ign http://packages.linuxmint.com rebecca/upstream Translation-en              
605 ko réceptionnés en 9s (61,6 ko/s)                                          
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
cmake est déjà la plus récente version disponible.
freeglut3-dev est déjà la plus récente version disponible.
libboost-dev est déjà la plus récente version disponible.
libbz2-dev est déjà la plus récente version disponible.
libjpeg-dev est déjà la plus récente version disponible.
libpng12-dev est déjà la plus récente version disponible.
libqt4-dev est déjà la plus récente version disponible.
libqt5multimedia5-plugins est déjà la plus récente version disponible.
libxft-dev est déjà la plus récente version disponible.
libxi-dev est déjà la plus récente version disponible.
libxinerama-dev est déjà la plus récente version disponible.
libxmu-dev est déjà la plus récente version disponible.
python-tk est déjà la plus récente version disponible.
python3-pyqt5 est déjà la plus récente version disponible.
python3-pyqt5.qtmultimedia est déjà la plus récente version disponible.
zlib1g-dev est déjà la plus récente version disponible.
fluid est déjà la plus récente version disponible.
libcgal-dev est déjà la plus récente version disponible.
libfltk1.3-dev est déjà la plus récente version disponible.
libgdal-dev est déjà la plus récente version disponible.
libopenal-dev est déjà la plus récente version disponible.
libplib-dev est déjà la plus récente version disponible.
git est déjà la plus récente version disponible.
libdbus-1-dev est déjà la plus récente version disponible.
libtiff5-dev est déjà la plus récente version disponible.
libudev-dev est déjà la plus récente version disponible.
qt5-default est déjà la plus récente version disponible.
libopenscenegraph-dev est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  ghc libbsd-dev libffi-dev libglee0d1 liboil0.3 libquicktime2 libunicap2
  libweed0 lives-data ogmtools shared-desktop-ontologies
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 47 non mis à jour.
****************************************
************** FLIGHTGEAR **************
****************************************
****************************************
**************** DATA ******************
****************************************
git://gitorious.org/fg/fgdata.git exists already
Déjà sur 'master'
Votre branche est à jour avec 'origin/master'.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

J'aime pas très beaucoup çà...

Aujourd'hui PHI ne fonctionnait pas (juste l'interface, pas de données.

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.CM MSI Z270 Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:3*500Go SSD 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot LinuxMint 19.3 Tricia/Windows10 FG2019.2
http://pattenflightgear.wifeo.com/

Hors ligne

#60 6/03/2015 19:42:46

f-jjth
Membre
Inscription : 11/02/2012
Messages : 632

Re : Download_and_compile.sh

Gitorious.org a quelques soucis en ce moment, je viens de faire un git pull sans problème à l'instant. Rééssaye wink


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#61 6/03/2015 19:48:02

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 691
Site Web

Re : Download_and_compile.sh

f-jjth a écrit :

Gitorious.org a quelques soucis en ce moment, je viens de faire un git pull sans problème à l'instant. Rééssaye wink

Pareil,

titi17@ordi-de-titi17 ~/fgfs/install/flightgear/fgdata $ git pull
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
titi17@ordi-de-titi17 ~/fgfs/install/flightgear/fgdata $ 

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.CM MSI Z270 Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:3*500Go SSD 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot LinuxMint 19.3 Tricia/Windows10 FG2019.2
http://pattenflightgear.wifeo.com/

Hors ligne

#62 6/03/2015 20:39:10

f-jjth
Membre
Inscription : 11/02/2012
Messages : 632

Re : Download_and_compile.sh

yep, gitorious a semble-t-il supprimé l'accès aux dépôts par le protocole git:// du coup ça passe par https:// (ils sont vraiment en train de fermer boutique...)

Du coup je t'invite à télécharger la version 2.32 du script (qui contient l'amélioration de Ernest concernant la création des dossiers wink ) et ça corrige ce soucis de git pull.
https://gitorious.org/fg/fgmeta/source/ … compile.sh


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#63 6/03/2015 20:55:59

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 691
Site Web

Re : Download_and_compile.sh

Tu as envoyé plus de choses que prévu?. (fg-meta)
Bon, j'ai récupéré le script, pareil, du reste un git pull dans le dépôt de la paf ne fonctionne plus non plus. mad

https://gitorious.org/fg/fgdata/commits/master
Le bandeau en haut en orange, c'est pour May, pas Mars!

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.CM MSI Z270 Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:3*500Go SSD 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot LinuxMint 19.3 Tricia/Windows10 FG2019.2
http://pattenflightgear.wifeo.com/

Hors ligne

#64 6/03/2015 21:37:40

f-jjth
Membre
Inscription : 11/02/2012
Messages : 632

Re : Download_and_compile.sh

oui la version 2.32 passe toutes les url en https:// au lieu de git://
Pour la PAF je suis en train de m'en occuper wink


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#65 6/03/2015 22:47:10

Biloute974
Membre
Inscription : 2/02/2014
Messages : 1 011

Re : Download_and_compile.sh

Bonsoir,

j'ai essayé une mise à jour aussi avec le script 2.31 et 2.32, je me retrouve au même point que Patten.


Config: Core I7 7700  + 16 Go de Ram  DDR4+ Nvidia GTX 970 + LinuxMint 18.2 64 bits--> FG 2017.4.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols

Hors ligne

#66 6/03/2015 23:51:44

f-jjth
Membre
Inscription : 11/02/2012
Messages : 632

Re : Download_and_compile.sh

hmmm vous allez croire que c'est la faute du script mais c'est vraiment une coincidence ^^
il vous faut éditer votre .git/config du fgdata et remplacer git://gitor....blabla par https://gitor...blabla


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#67 7/03/2015 10:03:14

Sancho
Membre
Lieu : LFQS
Inscription : 22/07/2013
Messages : 92

Re : Download_and_compile.sh

Bonjour à tous,
j'ai cloturé la discussion du git pull pas content pour garder un peu de cohérence
compilation

./download_and_compile.sh

OK
fgfs et le c172 se lance.
la compilation de

./download_and_compile.sh FGRUN

avec la version D&C_2.32 donne ceci:

./download_and_compile.sh FGRUN
VERSION=2.32
APT_GET_UPDATE=y
DOWNLOAD_PACKAGES=y
COMPILE=y
RECONFIGURE=y
DOWNLOAD=y
JOPTION=
OOPTION=
DEBUG=
***********************************
DIRECTORY= /home/emmanuel/flightgear/installation
***********************************
****************************************
**************** FGRUN *****************
****************************************
-- version is 3 dot 5
-- ignoring: \\.svn;Makefile.am;~$;
-- Boost version: 1.55.0
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8") 
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so  
-- Found FLTK: fltk_images;fltk_forms;fltk_gl;/usr/lib/x86_64-linux-gnu/libGL.so;fltk  
-- Found osgText: /usr/lib/x86_64-linux-gnu/libosgText.so  
-- Found osgDB: /usr/lib/x86_64-linux-gnu/libosgDB.so  
-- Found osgParticle: /usr/lib/x86_64-linux-gnu/libosgParticle.so  
-- Found osgUtil: /usr/lib/x86_64-linux-gnu/libosgUtil.so  
-- Found osgViewer: /usr/lib/x86_64-linux-gnu/libosgViewer.so  
-- Found osgGA: /usr/lib/x86_64-linux-gnu/libosgGA.so  
-- Found osg: /usr/lib/x86_64-linux-gnu/libosg.so  
-- Found OpenThreads: /usr/lib/x86_64-linux-gnu/libOpenThreads.so  
-- Found OpenSceneGraph: /usr/lib/x86_64-linux-gnu/libosgText.so;/usr/lib/x86_64-linux-gnu/libosgDB.so;/usr/lib/x86_64-linux-gnu/libosgParticle.so;/usr/lib/x86_64-linux-gnu/libosgUtil.so;/usr/lib/x86_64-linux-gnu/libosgViewer.so;/usr/lib/x86_64-linux-gnu/libosgGA.so;/usr/lib/x86_64-linux-gnu/libosg.so;/usr/lib/x86_64-linux-gnu/libOpenThreads.so (found suitable version "3.2.1", minimum required is "2.8.1") 
-- SimGear include directory: /home/emmanuel/flightgear/installation/install/simgear/include
-- found SimGear version: 3.5.0 (needed 3.5.0)
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- looking for static SimGear libraries
-- Looking for clock_gettime in rt
-- Looking for clock_gettime in rt - found
-- found SimGear libraries
-- Performing Test SIMGEAR_COMPILE_TEST
-- Performing Test SIMGEAR_COMPILE_TEST - Success
-- Found SimGear: optimized;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearScene.a;debug;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearScene.a;optimized;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearCore.a;debug;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearCore.a;optimized;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearCore.a;debug;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearCore.a (Required is at least version "3.5.0") 
-- Could NOT find Gettext (missing:  GETTEXT_MSGMERGE_EXECUTABLE GETTEXT_MSGFMT_EXECUTABLE) 
-- Looking for unistd.h
-- Looking for unistd.h - found
-- Looking for stdlib.h
-- Looking for stdlib.h - found
-- Looking for sys/wait.h
-- Looking for sys/wait.h - found
-- Looking for termios.h
-- Looking for termios.h - found
-- Looking for pty.h
-- Looking for pty.h - found
-- Looking for utmp.h
-- Looking for utmp.h - found
-- Looking for fcntl.h
-- Looking for fcntl.h - found
-- Looking for string.h
-- Looking for string.h - found
-- Looking for openpty
-- Looking for openpty - not found
-- Looking for openpty
-- Looking for openpty - found
-- Looking for login_tty
-- Looking for login_tty - found
-- Looking for _getpty
-- Looking for _getpty - not found
-- Found X11_Xinerama...
-- Found X11_Xft...
-- Using FLTK_LIBRARIES for fgrun: fltk_images;fltk_forms;fltk_gl;/usr/lib/x86_64-linux-gnu/libGL.so;fltk;/usr/lib/x86_64-linux-gnu/libSM.so;/usr/lib/x86_64-linux-gnu/libICE.so;/usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so;/usr/lib/x86_64-linux-gnu/libm.so;/usr/lib/x86_64-linux-gnu/libXinerama.so;/usr/lib/x86_64-linux-gnu/libXft.so;dl
-- Performing Test HAVE_FLTK_1_3
-- Performing Test HAVE_FLTK_1_3 - Success
-- Configuring done
-- Generating done
-- Build files have been written to: /home/emmanuel/flightgear/installation/build/fgrun
MAKE fgrun
[  9%] Built target Advanced
[ 19%] Built target Wizard
[ 74%] Built target fgrun
[ 77%] Generating de.gmo
/bin/sh: 1: GETTEXT_MSGMERGE_EXECUTABLE-NOTFOUND: not found
po/CMakeFiles/translations_1.dir/build.make:59: recipe for target 'po/de.gmo' failed
make[2]: *** [po/de.gmo] Error 127
CMakeFiles/Makefile2:241: recipe for target 'po/CMakeFiles/translations_1.dir/all' failed
make[1]: *** [po/CMakeFiles/translations_1.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
INSTALL fgrun
[  9%] Built target Advanced
[ 19%] Built target Wizard
[ 74%] Built target fgrun
[ 77%] Generating de.gmo
/bin/sh: 1: GETTEXT_MSGMERGE_EXECUTABLE-NOTFOUND: not found
po/CMakeFiles/translations_1.dir/build.make:59: recipe for target 'po/de.gmo' failed
make[2]: *** [po/de.gmo] Error 127
CMakeFiles/Makefile2:241: recipe for target 'po/CMakeFiles/translations_1.dir/all' failed
make[1]: *** [po/CMakeFiles/translations_1.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
***********************************

Il y a bien des paquets qui comporte le mot "gettex" dans le gestionnaire de paquets, y a-t-il un lien?


Debian Stretch, FG 2018.3.0,  i7 4820K 3,7 GHz,16 Go DDR3 1866Mhz, GTX770 4Go, T-FLIGHT-HOTAS-X
F-SCHO sur DHC6, ec135P2, Mirage2000-5, Boeing 777,A6 Intruder, CAP10, DR400,
Padawan heureux

Hors ligne

#68 7/03/2015 10:52:23

Biloute974
Membre
Inscription : 2/02/2014
Messages : 1 011

Re : Download_and_compile.sh

Bonjour tout le monde,

ce matin, comme le suggère f-jjth, j'ai édité le fichier /fgdata/.git/config. J'ai relancé une MAJ via le script 2.32 mais hélas toujours le même pépin:

theddy@theddy-H97M-D3H ~/fg3g $ ./download_and_compile.sh -j 12 ALL
**************************************
*                                    *
* Warning, the compilation process   *
* is going to use 12 or more Gbytes  *
* of space and at least a couple of  *
* hours to download and build FG.    *
*                                    *
* Please, be patient ......          *
*                                    *
**************************************
Asking password for apt-get operations...
[sudo] password for theddy: 
Ign http://dl.google.com stable InRelease
Ign http://security.ubuntu.com trusty-security InRelease                       
Ign http://archive.ubuntu.com trusty InRelease                                 
Ign http://ppa.launchpad.net trusty InRelease                                  
Atteint http://dl.google.com stable Release.gpg                                
Ign http://archive.canonical.com trusty InRelease                              
Atteint http://security.ubuntu.com trusty-security Release.gpg                 
Ign http://archive.ubuntu.com trusty-updates InRelease                         
Ign http://ppa.launchpad.net trusty InRelease                                  
Atteint http://dl.google.com stable Release                                    
Atteint http://archive.ubuntu.com trusty Release.gpg                           
Atteint http://security.ubuntu.com trusty-security Release                     
Atteint http://archive.canonical.com trusty Release.gpg                        
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Atteint http://archive.canonical.com trusty Release                            
Atteint http://archive.ubuntu.com trusty-updates Release.gpg                   
Atteint http://dl.google.com stable/main amd64 Packages                        
Atteint http://ppa.launchpad.net trusty Release.gpg                            
Atteint http://security.ubuntu.com trusty-security/main amd64 Packages         
Atteint http://archive.ubuntu.com trusty Release                               
Atteint http://dl.google.com stable/main i386 Packages                         
Atteint http://ppa.launchpad.net trusty Release                                
Atteint http://archive.canonical.com trusty/partner amd64 Packages             
Atteint http://security.ubuntu.com trusty-security/restricted amd64 Packages   
Atteint http://archive.ubuntu.com trusty-updates Release                       
Ign http://packages.linuxmint.com rebecca InRelease                            
Atteint http://ppa.launchpad.net trusty Release                                
Atteint http://archive.canonical.com trusty/partner i386 Packages              
Atteint http://security.ubuntu.com trusty-security/universe amd64 Packages     
Atteint http://archive.ubuntu.com trusty/main amd64 Packages                   
Ign http://extra.linuxmint.com rebecca InRelease                               
Atteint http://ppa.launchpad.net trusty/main Sources                           
Atteint http://archive.canonical.com trusty/partner Translation-en             
Atteint http://security.ubuntu.com trusty-security/multiverse amd64 Packages   
Atteint http://archive.ubuntu.com trusty/restricted amd64 Packages             
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Atteint http://security.ubuntu.com trusty-security/main i386 Packages          
Atteint http://archive.ubuntu.com trusty/universe amd64 Packages               
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Réception de : 1 http://packages.linuxmint.com rebecca Release.gpg [198 B]     
Atteint http://security.ubuntu.com trusty-security/restricted i386 Packages    
Atteint http://archive.ubuntu.com trusty/multiverse amd64 Packages             
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Atteint http://security.ubuntu.com trusty-security/universe i386 Packages      
Atteint http://archive.ubuntu.com trusty/main i386 Packages                    
Réception de : 2 http://extra.linuxmint.com rebecca Release.gpg [198 B]        
Atteint http://ppa.launchpad.net trusty/main Sources                           
Atteint http://security.ubuntu.com trusty-security/multiverse i386 Packages    
Atteint http://archive.ubuntu.com trusty/restricted i386 Packages              
Atteint http://ppa.launchpad.net trusty/main amd64 Packages                    
Atteint http://security.ubuntu.com trusty-security/main Translation-en         
Atteint http://archive.ubuntu.com trusty/universe i386 Packages                
Réception de : 3 http://packages.linuxmint.com rebecca Release [24,1 kB]       
Atteint http://ppa.launchpad.net trusty/main i386 Packages                     
Atteint http://security.ubuntu.com trusty-security/multiverse Translation-en   
Atteint http://archive.ubuntu.com trusty/multiverse i386 Packages              
Atteint http://ppa.launchpad.net trusty/main Translation-en                    
Atteint http://security.ubuntu.com trusty-security/restricted Translation-en   
Réception de : 4 http://extra.linuxmint.com rebecca Release [3 212 B]          
Atteint http://security.ubuntu.com trusty-security/universe Translation-en     
Atteint http://archive.ubuntu.com trusty/main Translation-fr                   
Atteint http://archive.ubuntu.com trusty/main Translation-en                   
Ign http://dl.google.com stable/main Translation-fr_FR                         
Atteint http://archive.ubuntu.com trusty/multiverse Translation-fr             
Ign http://dl.google.com stable/main Translation-fr                            
Réception de : 5 http://extra.linuxmint.com rebecca/main amd64 Packages [7 902 B]
Ign http://dl.google.com stable/main Translation-en                            
Réception de : 6 http://packages.linuxmint.com rebecca/main amd64 Packages [32,8 kB]
Atteint http://archive.ubuntu.com trusty/multiverse Translation-en             
Réception de : 7 http://extra.linuxmint.com rebecca/main i386 Packages [7 888 B]
Atteint http://archive.ubuntu.com trusty/restricted Translation-fr             
Atteint http://archive.ubuntu.com trusty/restricted Translation-en             
Atteint http://archive.ubuntu.com trusty/universe Translation-fr               
Réception de : 8 http://packages.linuxmint.com rebecca/upstream amd64 Packages [30,0 kB]
Atteint http://archive.ubuntu.com trusty/universe Translation-en               
Atteint http://archive.ubuntu.com trusty-updates/main amd64 Packages           
Atteint http://archive.ubuntu.com trusty-updates/restricted amd64 Packages     
Atteint http://archive.ubuntu.com trusty-updates/universe amd64 Packages       
Réception de : 9 http://packages.linuxmint.com rebecca/import amd64 Packages [218 kB]
Atteint http://archive.ubuntu.com trusty-updates/multiverse amd64 Packages     
Atteint http://archive.ubuntu.com trusty-updates/main i386 Packages            
Atteint http://archive.ubuntu.com trusty-updates/restricted i386 Packages      
Atteint http://archive.ubuntu.com trusty-updates/universe i386 Packages        
Atteint http://archive.ubuntu.com trusty-updates/multiverse i386 Packages      
Atteint http://archive.ubuntu.com trusty-updates/main Translation-en           
Atteint http://archive.ubuntu.com trusty-updates/multiverse Translation-en     
Atteint http://archive.ubuntu.com trusty-updates/restricted Translation-en     
Atteint http://archive.ubuntu.com trusty-updates/universe Translation-en       
Réception de : 10 http://packages.linuxmint.com rebecca/main i386 Packages [32,1 kB]
Réception de : 11 http://packages.linuxmint.com rebecca/upstream i386 Packages [30,0 kB]
Ign http://archive.ubuntu.com trusty/main Translation-fr_FR                    
Ign http://archive.ubuntu.com trusty/multiverse Translation-fr_FR              
Ign http://archive.ubuntu.com trusty/restricted Translation-fr_FR              
Ign http://archive.ubuntu.com trusty/universe Translation-fr_FR                
Réception de : 12 http://packages.linuxmint.com rebecca/import i386 Packages [219 kB]
Ign http://extra.linuxmint.com rebecca/main Translation-fr_FR                  
Ign http://extra.linuxmint.com rebecca/main Translation-fr                     
Ign http://extra.linuxmint.com rebecca/main Translation-en
Ign http://packages.linuxmint.com rebecca/import Translation-fr_FR             
Ign http://packages.linuxmint.com rebecca/import Translation-fr                
Ign http://packages.linuxmint.com rebecca/import Translation-en                
Ign http://packages.linuxmint.com rebecca/main Translation-fr_FR               
Ign http://packages.linuxmint.com rebecca/main Translation-fr                  
Ign http://packages.linuxmint.com rebecca/main Translation-en                  
Ign http://packages.linuxmint.com rebecca/upstream Translation-fr_FR           
Ign http://packages.linuxmint.com rebecca/upstream Translation-fr              
Ign http://packages.linuxmint.com rebecca/upstream Translation-en              
605 ko réceptionnés en 9s (62,5 ko/s)                                          
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
build-essential est déjà la plus récente version disponible.
cmake est déjà la plus récente version disponible.
freeglut3-dev est déjà la plus récente version disponible.
libboost-dev est déjà la plus récente version disponible.
libbz2-dev est déjà la plus récente version disponible.
libjpeg-dev est déjà la plus récente version disponible.
libpng12-dev est déjà la plus récente version disponible.
libqt4-dev est déjà la plus récente version disponible.
libqt5multimedia5-plugins est déjà la plus récente version disponible.
libxft-dev est déjà la plus récente version disponible.
libxi-dev est déjà la plus récente version disponible.
libxinerama-dev est déjà la plus récente version disponible.
libxmu-dev est déjà la plus récente version disponible.
python-tk est déjà la plus récente version disponible.
python3-pyqt5 est déjà la plus récente version disponible.
python3-pyqt5.qtmultimedia est déjà la plus récente version disponible.
zlib1g-dev est déjà la plus récente version disponible.
fluid est déjà la plus récente version disponible.
libcgal-dev est déjà la plus récente version disponible.
libfltk1.3-dev est déjà la plus récente version disponible.
libgdal-dev est déjà la plus récente version disponible.
libopenal-dev est déjà la plus récente version disponible.
libplib-dev est déjà la plus récente version disponible.
git est déjà la plus récente version disponible.
libdbus-1-dev est déjà la plus récente version disponible.
libtiff5-dev est déjà la plus récente version disponible.
libudev-dev est déjà la plus récente version disponible.
qt5-default est déjà la plus récente version disponible.
libopenscenegraph-dev est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 36 non mis à jour.
****************************************
************** FLIGHTGEAR **************
****************************************
https://gitorious.org/fg/flightgear.git exists already
Déjà sur 'next'
Votre branche est à jour avec 'origin/next'.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
theddy@theddy-H97M-D3H ~/fg3g $

Voilà le contenu de mon fichier /.git/config:

[core]
	repositoryformatversion = 0
	filemode = true
	bare = false
	logallrefupdates = true
[remote "origin"]
	url = https://gitorious.org/fg/fgdata.git
	fetch = +refs/heads/*:refs/remotes/origin/*
[branch "master"]
	remote = origin
	merge = refs/heads/master

En revanche, un git pull du fgdata a été concluant:

theddy@theddy-H97M-D3H ~/fg3g/install/flightgear/fgdata $ git pull
remote: Counting objects: 9, done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 5 (delta 4), reused 0 (delta 0)
Unpacking objects: 100% (5/5), done.
Depuis https://gitorious.org/fg/fgdata
   3655d83..919710d  master     -> origin/master
Mise à jour 3655d83..919710d
Fast-forward
 webgui/widgets/metar.js | 18 ++++++++++++++----
 1 file changed, 14 insertions(+), 4 deletions(-)
theddy@theddy-H97M-D3H ~/fg3g/install/flightgear/fgdata $ 

Config: Core I7 7700  + 16 Go de Ram  DDR4+ Nvidia GTX 970 + LinuxMint 18.2 64 bits--> FG 2017.4.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols

Hors ligne

#69 7/03/2015 11:10:07

Biloute974
Membre
Inscription : 2/02/2014
Messages : 1 011

Re : Download_and_compile.sh

Je pense avoir compris mon erreur, il faut modifier tout les fichier .git/config sinon l'erreur revient, j'ai par conséquent modifier les .git/config des dossier: fgrun, install/flightgear/fgdata, opensecengraph, openrti, plib, simgear, terragear et terrageargui.
Et là, magie, un ./download_and_compile. sh -j 4 ALL c'est parfaitement déroulé.

Merci Clément, je mets du temps à comprendre mais ça fini par rentrer.

@Sancho: dans ton dossier fgrun, as-tu un dossier nommé "po" ?


Config: Core I7 7700  + 16 Go de Ram  DDR4+ Nvidia GTX 970 + LinuxMint 18.2 64 bits--> FG 2017.4.0
Yoke et pédale Saitek Proflight - Avions: 777 et DHC 6
Mes vols

Hors ligne

#70 7/03/2015 11:10:26

f-jjth
Membre
Inscription : 11/02/2012
Messages : 632

Re : Download_and_compile.sh

@Biloute: lit bien le contenu de ta console, tu as modifier ce qu'il faut pour ton fgdata (et d'ailleurs ton git pull de fgdata a bien fonctionné) mais tu n'as pas fais la modification pour flightgear, du coup forcément le script t'engueule au moment de faire un git pull sur flightgear.
Il faut donc faire la même manip pour flightgear/fgdata/simgear/openrti/libplib/atc-pie... tout ce qui est sur gitorious.org en fait

@Sancho: jamais vu cette erreur, je te conseil de supprimer ton dossier /build/fgrun et install/fgrun ainsi que /fgrun et relancer la commande de compilation pour voir


OS: Linux Mint 17.1 | RAM: 12Go | GPU: GTX460SE | CPU: Intel I5 | FG: GIT

POIs: DR400-dauphin | FGCom | Jenkins | download_and_compile.sh

Hors ligne

#71 7/03/2015 11:48:06

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 691
Site Web

Re : Download_and_compile.sh

Salut à tous, salut Clément,

f-jjth a écrit :

hmmm vous allez croire que c'est la faute du script mais c'est vraiment une coincidence ^^
il vous faut éditer votre .git/config du fgdata et remplacer git://gitor....blabla par https://gitor...blabla

Pas du tout, je n'ai jamais pensé que le script était en cause, et pour cause, un git pull dans fgdata_paf ne fonctionne pas non plus.

Je suis reparti propre avec ton paquet d'hier fg-meta (que j'ai renommé fgfs) lancé le script en rajoutant OPENRTI FGRUN et ATCPIE (pour cette fois ) , tout va bien FG fonctionne, çà vole merci.

3h15 passé partout, avec le DATA, ils dégagent quand les Aircraft's ?.

Quid de PLIB, on peut s'en passer?.

smile

Dernière modification par Patten (7/03/2015 13:38:29)


Intel I7.7700k 4.2 GHz 4 C 8 tr.CM MSI Z270 Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:3*500Go SSD 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot LinuxMint 19.3 Tricia/Windows10 FG2019.2
http://pattenflightgear.wifeo.com/

Hors ligne

#72 7/03/2015 12:49:54

Sancho
Membre
Lieu : LFQS
Inscription : 22/07/2013
Messages : 92

Re : Download_and_compile.sh

f-jjth a écrit :

je te conseil de supprimer ton dossier /build/fgrun et install/fgrun ainsi que /fgrun et relancer la commande de compilation pour voir

résultat identique

./download_and_compile.sh FGRUN
VERSION=2.32
APT_GET_UPDATE=y
DOWNLOAD_PACKAGES=y
COMPILE=y
RECONFIGURE=y
DOWNLOAD=y
JOPTION=
OOPTION=
DEBUG=
***********************************
DIRECTORY= /home/emmanuel/flightgear/installation
***********************************
****************************************
**************** FGRUN *****************
****************************************
-- version is 3 dot 5
-- ignoring: \\.svn;Makefile.am;~$;
-- Boost version: 1.55.0
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8") 
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so  
-- Found FLTK: fltk_images;fltk_forms;fltk_gl;/usr/lib/x86_64-linux-gnu/libGL.so;fltk  
-- Found osgText: /usr/lib/x86_64-linux-gnu/libosgText.so  
-- Found osgDB: /usr/lib/x86_64-linux-gnu/libosgDB.so  
-- Found osgParticle: /usr/lib/x86_64-linux-gnu/libosgParticle.so  
-- Found osgUtil: /usr/lib/x86_64-linux-gnu/libosgUtil.so  
-- Found osgViewer: /usr/lib/x86_64-linux-gnu/libosgViewer.so  
-- Found osgGA: /usr/lib/x86_64-linux-gnu/libosgGA.so  
-- Found osg: /usr/lib/x86_64-linux-gnu/libosg.so  
-- Found OpenThreads: /usr/lib/x86_64-linux-gnu/libOpenThreads.so  
-- Found OpenSceneGraph: /usr/lib/x86_64-linux-gnu/libosgText.so;/usr/lib/x86_64-linux-gnu/libosgDB.so;/usr/lib/x86_64-linux-gnu/libosgParticle.so;/usr/lib/x86_64-linux-gnu/libosgUtil.so;/usr/lib/x86_64-linux-gnu/libosgViewer.so;/usr/lib/x86_64-linux-gnu/libosgGA.so;/usr/lib/x86_64-linux-gnu/libosg.so;/usr/lib/x86_64-linux-gnu/libOpenThreads.so (found suitable version "3.2.1", minimum required is "2.8.1") 
-- SimGear include directory: /home/emmanuel/flightgear/installation/install/simgear/include
-- found SimGear version: 3.5.0 (needed 3.5.0)
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- looking for static SimGear libraries
-- Looking for clock_gettime in rt
-- Looking for clock_gettime in rt - found
-- found SimGear libraries
-- Performing Test SIMGEAR_COMPILE_TEST
-- Performing Test SIMGEAR_COMPILE_TEST - Success
-- Found SimGear: optimized;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearScene.a;debug;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearScene.a;optimized;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearCore.a;debug;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearCore.a;optimized;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearCore.a;debug;/home/emmanuel/flightgear/installation/install/simgear/lib/libSimGearCore.a (Required is at least version "3.5.0") 
-- Could NOT find Gettext (missing:  GETTEXT_MSGMERGE_EXECUTABLE GETTEXT_MSGFMT_EXECUTABLE) 
-- Looking for unistd.h
-- Looking for unistd.h - found
-- Looking for stdlib.h
-- Looking for stdlib.h - found
-- Looking for sys/wait.h
-- Looking for sys/wait.h - found
-- Looking for termios.h
-- Looking for termios.h - found
-- Looking for pty.h
-- Looking for pty.h - found
-- Looking for utmp.h
-- Looking for utmp.h - found
-- Looking for fcntl.h
-- Looking for fcntl.h - found
-- Looking for string.h
-- Looking for string.h - found
-- Looking for openpty
-- Looking for openpty - not found
-- Looking for openpty
-- Looking for openpty - found
-- Looking for login_tty
-- Looking for login_tty - found
-- Looking for _getpty
-- Looking for _getpty - not found
-- Found X11_Xinerama...
-- Found X11_Xft...
-- Using FLTK_LIBRARIES for fgrun: fltk_images;fltk_forms;fltk_gl;/usr/lib/x86_64-linux-gnu/libGL.so;fltk;/usr/lib/x86_64-linux-gnu/libSM.so;/usr/lib/x86_64-linux-gnu/libICE.so;/usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so;/usr/lib/x86_64-linux-gnu/libm.so;/usr/lib/x86_64-linux-gnu/libXinerama.so;/usr/lib/x86_64-linux-gnu/libXft.so;dl
-- Performing Test HAVE_FLTK_1_3
-- Performing Test HAVE_FLTK_1_3 - Success
-- Configuring done
-- Generating done
-- Build files have been written to: /home/emmanuel/flightgear/installation/build/fgrun
MAKE fgrun
[  9%] Built target Advanced
[ 19%] Built target Wizard
[ 74%] Built target fgrun
[ 77%] Generating de.gmo
/bin/sh: 1: GETTEXT_MSGMERGE_EXECUTABLE-NOTFOUND: not found
po/CMakeFiles/translations_1.dir/build.make:59: recipe for target 'po/de.gmo' failed
make[2]: *** [po/de.gmo] Error 127
CMakeFiles/Makefile2:241: recipe for target 'po/CMakeFiles/translations_1.dir/all' failed
make[1]: *** [po/CMakeFiles/translations_1.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
INSTALL fgrun
[  9%] Built target Advanced
[ 19%] Built target Wizard
[ 74%] Built target fgrun
[ 77%] Generating de.gmo
/bin/sh: 1: GETTEXT_MSGMERGE_EXECUTABLE-NOTFOUND: not found
po/CMakeFiles/translations_1.dir/build.make:59: recipe for target 'po/de.gmo' failed
make[2]: *** [po/de.gmo] Error 127
CMakeFiles/Makefile2:241: recipe for target 'po/CMakeFiles/translations_1.dir/all' failed
make[1]: *** [po/CMakeFiles/translations_1.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2
***********************************

Debian Stretch, FG 2018.3.0,  i7 4820K 3,7 GHz,16 Go DDR3 1866Mhz, GTX770 4Go, T-FLIGHT-HOTAS-X
F-SCHO sur DHC6, ec135P2, Mirage2000-5, Boeing 777,A6 Intruder, CAP10, DR400,
Padawan heureux

Hors ligne

#73 7/03/2015 13:10:22

Clm76
Membre
Lieu : LFOH
Inscription : 22/10/2012
Messages : 1 232

Re : Download_and_compile.sh

Compilation de ce matin dans un dossier vierge avec le script 2.32, sans le DATA :

**************************************** 
***************** FGX ****************** 
**************************************** 
Clonage dans '.'... 
remote: Counting objects: 9104, done. 
remote: Compressing objects: 100% (2729/2729), done. 
remote: Total 9104 (delta 6263), reused 8976 (delta 6189) 
Réception d'objets: 100% (9104/9104), 8.03 MiB | 150.00 KiB/s, done. 
Résolution des deltas: 100% (6263/6263), done. 
Vérification de la connectivité... fait. 
Déjà sur 'master' 
Votre branche est à jour avec 'origin/master'. 
La branche courante master est à jour. 
Project ERROR: Unknown module(s) in QT: webkit xmlpatterns 


**************************************** 
**************** PLIB ****************** 
**************************************** 
Clonage dans '.'... 
fatal: repository 'https://gitorious.org/libplib/libplib.git/' not found 

Le reste semble ok.


Fg 2020.2.0 et 2020.3.0 - Linux Mint 19.3 Tricia - CM Asus P8H67 MLE - CPU i3 2100T - 12 Go Ram - Nvidia Geforce GTX 770 - Driver Nvidia 440.100
+ Hp notebook-15 - Linux Mint 19.3 Tricia -  CPU i3-7020u - Ram 4Go - Intel Graphics 620.

Hors ligne

#74 7/03/2015 13:15:04

ctesc356
Membre
Inscription : 18/05/2010
Messages : 3 004

Re : Download_and_compile.sh

Bonjour Sancho,
bizarre, ici sous debian8 (testing) fgrun compile sans souci.
Essayé spécialement parce qu'il y a longtemps qu je me passe de lanceur et je m'en porte bien smile

essaie : d&c sans FgRun

./download_and_complile.sh -j4 SIMGEAR FGFS (DATA)

DATA que si tu ne les a pas déjà sur ton dd
avec un bon .fgfsrc tu auras un fg fonctionnel.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint/Debian testing

Hors ligne

#75 7/03/2015 13:42:59

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 691
Site Web

Re : Download_and_compile.sh

Clm76 a écrit :

Compilation de ce matin dans un dossier vierge avec le script 2.32, sans le DATA :
........

**************************************** 
**************** PLIB ****************** 
**************************************** 
Clonage dans '.'... 
fatal: repository 'https://gitorious.org/libplib/libplib.git/' not found 

Le reste semble ok.

Çà fonctionne sans PLIB avec Linuxmint 17.1, d'où ma question plus haut:

http://fr.flightgear.org/forums/viewtop … 701#p30701

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.CM MSI Z270 Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:3*500Go SSD 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot LinuxMint 19.3 Tricia/Windows10 FG2019.2
http://pattenflightgear.wifeo.com/

Hors ligne

Pied de page des forums