Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#126 22/09/2017 14:46:32

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : Soucis momentanés avec GIT.

dany93 a écrit :

Jouable ? et avec git + d&c ? (plus incertain...)

Je ne crois malheureusement pas, "git" fait un peu sa cuisine à part. "git clone" ne télécharge pas simplement les données, il rapatrie aussi l'historique, les index etc. Les données de fgdata représentent ~2Gio, le dossier cloné fait 6.7Gio.
Lorsque le serveur décroche au bout de 2 heures le répertoire est vide hmm
Merci quand même! ça peut servir wink

Finalement un "git fetch origin" suivi d'un "git reset --hard origin" sur mon ancien fgdata a tout remis d'équerre.
Réponse de "git pull": "Already up-to-date"
Réponse de "git pull -r" (ce que fait d&c): "La branche courante next est à jour"

Tout baigne smile

Dernière modification par ctesc356 (23/09/2017 5:52:12)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#127 28/09/2017 9:43:44

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : Soucis momentanés avec GIT.

Salut à tous,

Çà coince aujourd'hui (pour le moment) à la compilation de FGFS:

[ 37%] Building CXX object src/GUI/CMakeFiles/fglauncher.dir/ThumbnailImageItem.cxx.o
In file included from /home/titi38/FGFS/next/flightgear/src/GUI/ThumbnailImageItem.cxx:1:0:
/home/titi38/FGFS/next/flightgear/src/GUI/ThumbnailImageItem.hxx:53:10: error: ‘unique_ptr’ in namespace ‘std’ does not name a template type
     std::unique_ptr<ThumbnailPackageDelegate> m_delegate;
          ^
/home/titi38/FGFS/next/flightgear/src/GUI/ThumbnailImageItem.cxx: In constructor ‘ThumbnailImageItem::ThumbnailImageItem()’:
/home/titi38/FGFS/next/flightgear/src/GUI/ThumbnailImageItem.cxx:51:5: error: class ‘ThumbnailImageItem’ does not have any field named ‘m_delegate’
     m_delegate(new ThumbnailPackageDelegate(this)),
     ^
/home/titi38/FGFS/next/flightgear/src/GUI/ThumbnailImageItem.cxx:54:41: error: ‘m_delegate’ was not declared in this scope
     globals->packageRoot()->addDelegate(m_delegate.get());
                                         ^
/home/titi38/FGFS/next/flightgear/src/GUI/ThumbnailImageItem.cxx: In destructor ‘virtual ThumbnailImageItem::~ThumbnailImageItem()’:
/home/titi38/FGFS/next/flightgear/src/GUI/ThumbnailImageItem.cxx:62:44: error: ‘m_delegate’ was not declared in this scope
     globals->packageRoot()->removeDelegate(m_delegate.get());
                                            ^
src/GUI/CMakeFiles/fglauncher.dir/build.make:815 : la recette pour la cible « src/GUI/CMakeFiles/fglauncher.dir/ThumbnailImageItem.cxx.o » a échouée
make[2]: *** [src/GUI/CMakeFiles/fglauncher.dir/ThumbnailImageItem.cxx.o] Erreur 1
CMakeFiles/Makefile2:2374 : la recette pour la cible « src/GUI/CMakeFiles/fglauncher.dir/all » a échouée
make[1]: *** [src/GUI/CMakeFiles/fglauncher.dir/all] Erreur 2
Makefile:149 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2
****************************************
**************** DATA ******************

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#128 28/09/2017 11:14:16

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : Soucis momentanés avec GIT.

Hier, sourceforge.net a connu une rupture de service de plusieurs heures (rétablie), et aujourd'hui ça a l'air de retomber en panne.


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#129 28/09/2017 23:03:03

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : Soucis momentanés avec GIT.

Bonsoir,
j'ai dû installer "qtdeclarative5-private-dev" pour obtenir la mj de fgfs


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#130 29/09/2017 7:34:19

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : Soucis momentanés avec GIT.

ctesc356 a écrit :

Bonsoir,
j'ai dû installer "qtdeclarative5-private-dev" pour obtenir la mj de fgfs

Effectivement, çà marche (test avant et après installation), merci Ernest.

Par contre, je n'ai toujours pas les couleurs. sad

mini_318557Slection011.png

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#131 29/09/2017 8:15:56

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : Soucis momentanés avec GIT.

Bonjour,
j'ai les couleurs, mais avec 2017.4.0 j'ai ça dans la console, avec tous les avions:

Nasal runtime error: undefined symbol: _globals
  at /media/tt/data/fg/fgdata/Nasal/xyprops.nas, line 198
Nasal runtime error: undefined symbol: _globals
  at /media/tt/data/fg/fgdata/Nasal/towing/props(3).nas, line 198


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#132 29/09/2017 8:36:11

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : Soucis momentanés avec GIT.

ctesc356 a écrit :

Bonjour,
j'ai les couleurs, mais avec 2017.4.0 j'ai ça dans la console, avec tous les avions:

Nasal runtime error: undefined symbol: _globals
  at /media/tt/data/fg/fgdata/Nasal/xyprops.nas, line 198
Nasal runtime error: undefined symbol: _globals
  at /media/tt/data/fg/fgdata/Nasal/towing/props(3).nas, line 198

La console est nickel, mais il manque des couleurs avec ou sans Rembrandt. sad

titi38@titi38-MS-7A59 ~ $ /home/titi38/FGFS/next/run_fgfs.sh
FlightGear:  Version 2017.4.0
FlightGear:  Build Type Dev
Built with GNU C++ version 5.4
Jenkins number/ID 0:none
Aircraft does not specify a minimum FG version: please add one at /sim/minimum-fg-version
StatsHandler::StatsHandler() Setting up GL2 compatible shaders
Starting automatic scenery download/synchronization to '/home/titi38/.fgfs/TerraSync'.
Multiplayer mode active!
Volcanic activity on.
Loading local weather routines...
Animated jetways ... initialized
This aircraft uses yasim version 'YASIM_VERSION_CURRENT'
Electrical System ... Ok
Flight Director ... Ok
CDU ... Ok
MFD Canvas ... Ok
FMS ... Ok
VSD ... Ok
Vocal Checklists ... Ok
titi38@titi38-MS-7A59 ~ $ 

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#133 30/09/2017 15:20:51

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : Soucis momentanés avec GIT.

Bonjour,

Ce jour, d_n_c après installation de "qtdeclarative5-private-dev" (merci Ernest !).
"A utiliser à vos risques et périls" Je n'aime pas trop et je ne comprends pas que ce module nous soit imposé...

Compilation complète et apparemment propre.

Mais au lancement FG par Qt :
- fgfs se lance et fonctionne,
- mais dans Qt, la liste des avions n’apparaît plus.

Message

qrc:///AircraftList.qml:1:1: module "QtQuick" is not installed

J'ai essayé en installant "Qtquick1-qml-plugins" : pareil.

Je ne sais pas si c'est lié, mais James Turner est en train de débugger Qt.

Je vais essayer de rapporter ça à FG Devel.


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#134 30/09/2017 18:14:57

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : Soucis momentanés avec GIT.

James m'a répondu. Il faut QtQuick2.
Pour retrouver la liste des avions dans Qt, il faut installer "Qtdeclarative5-qtquick2-plugin" (depuis les Logiciels LM 18).

En prime, le défilement est devenu progressif.
Mais les chemins par survol souris n'apparaissent plus... hmm
[EDIT] D'après James, la fonction va revenir.


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#135 30/09/2017 18:32:58

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Soucis momentanés avec GIT.

dany93 a écrit :

Pour retrouver la liste des avions dans Qt, il faut installer "Qtdeclarative5-qtquick2-plugin" (depuis les paquets LM 18).

C'est de l'Ubuntu, ça, je ne le vois pas dans les paquets debian.
Il y a toujours moyen de l'installer, mais si FG devient spécifique Ubuntu...


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#136 30/09/2017 18:36:37

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : Soucis momentanés avec GIT.

La réponse de James:

QtQuick1 is the ‘old’ QtQuick, you need to modules called QtDeclarative (aka QtQuick 2)

Probably the packages are called qtdeclarative5-(something) based on what you wrote above - maybe -plugins since compilation succeeded?


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#137 30/09/2017 18:41:01

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Soucis momentanés avec GIT.

captur10.png


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#138 30/09/2017 18:53:46

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : Soucis momentanés avec GIT.

Ah oui, ça saute pas aux yeux... hmm . Mais mon message était une adaptation de la réponse de James dans le cadre de Linux Mint 18 que j'ai.
Tout ce que je peux dire de plus, c'est que si tu installes le bon, Qt montre immédiatement la liste des avions sans avoir à recompiler.

Et en regardant plus en détail les paquets contenus ?

Et celui-ci ? qml-module-qtquick2 (5.9.1-6)
https://packages.debian.org/sid/libs/qm … e-qtquick2


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#139 1/10/2017 1:14:28

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : Soucis momentanés avec GIT.

dany93 a écrit :

Mais au lancement FG par Qt :
- fgfs se lance et fonctionne,
- mais dans Qt, la liste des avions n’apparaît plus.

Bizarre, j'ai la liste des avions sans rien installer de plus.

Si on fait un "dpkg -L <paquet> on voit que "Qtdeclarative5-qtquick2-plugin" ne contient apparemment que de la doc, rien d'éxecutif là dedans.
De plus Synaptic dit que:

This is a transitional dummy package which can be safely removed.

Les mystères de l'informatique...

J'ai ici un paquet "qml-module-qtquick2" --> This package contains the Qt Quick 2 QML module for Qt declarative.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#140 1/10/2017 9:30:09

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Soucis momentanés avec GIT.

ctesc356 a écrit :

Si on fait un "dpkg -L <paquet> on voit que "Qtdeclarative5-qtquick2-plugin" ne contient apparemment que de la doc, rien d'éxecutif là dedans.
De plus Synaptic dit que:

This is a transitional dummy package which can be safely removed.

Ce qui explique que je ne le trouve pas dans les paquets debian.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#141 1/10/2017 9:39:26

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : Soucis momentanés avec GIT.

Salut à tous,

f-toro a écrit :

C'est de l'Ubuntu, ça, je ne le vois pas dans les paquets debian.
Il y a toujours moyen de l'installer, mais si FG devient spécifique Ubuntu...

Heureux temps, où on lançait le script, et celui ci se dépatouillait à installer le nécessaire pour faire fonctionner FG.
On s'en foutait si D&C installait une baraque à frites dans un coin du disque dur, l'essentiel c'était que çà fonctionne. tongue
Maintenant, il faut très souvent rajouter des trucs et des machins pour avoir le service minimum.
Le script n'est plus maintenu, ou bien?.
Nan, parce que je suis persuadé que lors d'une installation neuve d'un OS Debian ou Linux, tel qu'il est actuellement, le scripts D&C ne compile plus de façon acceptable, çà craint.
Bon, je sais, je suis un peu bourru ce matin hmm tongue lol .

smile

Dernière modification par Patten (1/10/2017 9:40:33)


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#142 1/10/2017 11:39:46

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : Soucis momentanés avec GIT.

Bonjour à tous,

"qml-module-qtquick2" est marqué dans les dépendances de "qtdeclarative5-qtquick2-plugin".
Il a d'ailleurs été marqué comme "qui seront installés" quand je l'ai fait.
Peut-être parce que je ne l'avais pas, ou dans une version pas à jour. Je l'ai donc eu de manière indirecte.
"qml-module-qtquick2" suffit.

De toutes façons, pas clair. Autant d'installations, autant de configurations.

@Christian,
Bourru mais clairvoyant. Je ressens la même chose que toi. De plus, on devient dépendant car les installations à ajouter sont difficiles à identifier (au moins pour moi).

Par contre, D&C est quand même maintenu. Dernière intervention 2017-05-18 de Florent Rougon [5fa233] (5éme dans 2017).
Par exemple, "qtdeclarative5-dev" que nous avions dû installer (ctesc356 12 avril 2017) a été ajouté dans D&C par Florent Rougon le 21 Avril.
C'est plutôt que D&C ne suit pas à la vitesse des développeurs.
Pas "top" mais pas désespéré.


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#143 1/10/2017 18:47:32

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : Soucis momentanés avec GIT.

J'ai posté dans FG-Devel pour ces paquets à ajouter dans D&C.
(Florent Rougon, sa réponse)

La forme conditionnelle reste à établir, mais le principe va vers :
qtdeclarative5-private-dev
ET
(qml-module-qtquick2 OU qtdeclarative5-qtquick2-plugin)

Florent pense que les deux derniers ("OU") sont les mêmes sous un autre nom.

Pas d'erreur, hein ? Ils sont bien installables par vos distributions ?

Il connaît Debian stretch (= current stable)

Il interroge sur Ubuntu mais je ne peux rien dire.


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#144 1/10/2017 19:45:24

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : Soucis momentanés avec GIT.

A mon avis il faut installer "qml-module-qtquick2", il est présent sous Debian, Ubuntu, Mint ...

"qtdeclarative5-qtquick2-plugin" n'est qu'une coquille vide qui installe "qml-module-qtquick2" comme dépendance

Et:
sylect15.png

Mais qu'arrivera t-il si quelqu'un utilise d&c avec une distribution pas tout à fait récente?
Est ce que "apt update" va juste un peu râler ou passer en défaut? C'est peut-être à traiter dans le script;

Dernière modification par ctesc356 (1/10/2017 20:17:43)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#145 1/10/2017 21:00:48

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Soucis momentanés avec GIT.

Personnellement :

- qtdeclarative5-private-dev

- qml-module-qtquick2

sont installés

et je n'ai pas de paquet qtdeclarative5-qtquick2-plugin

[ 36%] Built target fglauncher_autogen
[ 36%] Building CXX object src/GUI/CMakeFiles/fglauncher.dir/FlickableExtentQuery.cxx.o
In file included from /usr/include/x86_64-linux-gnu/qt5/QtQuick/5.9.1/QtQuick/private/qtquickglobal_p.h:43:0,
                 from /usr/include/x86_64-linux-gnu/qt5/QtQuick/5.9.1/QtQuick/private/qquickflickable_p.h:55,
                 from /home/andre/fgfs/flightgear/src/GUI/FlickableExtentQuery.cxx:3:
/usr/include/x86_64-linux-gnu/qt5/QtQml/5.9.1/QtQml/private/qtqmlglobal_p.h:54:10: fatal error: QtCore/private/qglobal_p.h: Aucun fichier ou dossier de ce type
 #include <QtCore/private/qglobal_p.h>
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
src/GUI/CMakeFiles/fglauncher.dir/build.make:839 : la recette pour la cible « src/GUI/CMakeFiles/fglauncher.dir/FlickableExtentQuery.cxx.o » a échouée
make[2]: *** [src/GUI/CMakeFiles/fglauncher.dir/FlickableExtentQuery.cxx.o] Erreur 1
CMakeFiles/Makefile2:2349 : la recette pour la cible « src/GUI/CMakeFiles/fglauncher.dir/all » a échouée
make[1]: *** [src/GUI/CMakeFiles/fglauncher.dir/all] Erreur 2
Makefile:162 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2 

André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#146 1/10/2017 21:51:43

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : Soucis momentanés avec GIT.

Tu as de l'avance sur nous et probablement sur les développeurs wink
Ici j'ai qt 5.5.1


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#147 1/10/2017 23:27:31

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Soucis momentanés avec GIT.

De l'avance sur vous oui mais sur les dev ça m'étonnerait.

Normalement ça ne doit plus compiler avec des paquets trop anciens mais avec des paquets plus récents je n'ai jamais eu de problème.

Du coup je me retrouve avec une compil de fgfs qui n'est pas allée jusqu'au bout, donc un fgfs 2017.3.0, avec un data étiqueté 2017.4.0, et FG ne se lance pas.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#148 1/10/2017 23:37:49

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 611

Re : Soucis momentanés avec GIT.

Vous rejoignez mon sentiment :
préference à
qtdeclarative5-private-dev
ET
qml-module-qtquick2

Et vu que qtdeclarative5-qtquick2-plugin est (ou serait) en "OU", cela ne gêne personne. J'ai suggéré son omission puisqu'il est inutile.

ctesc356 a écrit :

Mais qu'arrivera t-il si quelqu'un utilise d&c avec une distribution pas tout à fait récente?
Est ce que "apt update" va juste un peu râler ou passer en défaut? C'est peut-être à traiter dans le script;

La question est posée dans le message de Florent

The real question is: do we want d&c.sh to fail if it can't find
qtdeclarative5-private-dev AND
(qml-module-qtquick2 OR qtdeclarative5-qtquick2-plugin)?

If these packages are present in all current distros, then d&c.sh can
require them, that's the easiest way. OTOH, if they are too recent,
treating them as optional would allow people on not-so-current distros
to still build FG, but without the built-in launcher (or build older FG
revisions,....)

La vraie question est: voulons-nous que d & c.sh échoue s'il ne peut pas trouver
qtdeclarative5-private-dev AND
(qml-module-qtquick2 OU qtdeclarative5-qtquick2-plugin)?

Si ces paquets sont présents dans toutes les distros actuelles, alors d & c.sh peut
les exiger, c'est la manière la plus simple. Autrement, s'ils sont trop récents,
les traiter comme optionnels permettrait aux personnes qui se trouvent dans des distributions non-à-jour
d'encore créer FG, mais sans le lanceur intégré (ou créer un ancienne version de FG.....)

wkitty42 qui est sous Ubuntu 14.04 participe à la discussion, je ne pense pas que Florent prendra l'option de l’échec (bien que ce soit plus difficile). C'est ce que j'ai suggéré.


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#149 2/10/2017 8:47:17

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : Soucis momentanés avec GIT.

Bonjour,

f-toro a écrit :

De l'avance sur vous oui mais sur les dev ça m'étonnerait.

Normalement ça ne doit plus compiler avec des paquets trop anciens mais avec des paquets plus récents je n'ai jamais eu de problème.

Du coup je me retrouve avec une compil de fgfs qui n'est pas allée jusqu'au bout, donc un fgfs 2017.3.0, avec un data étiqueté 2017.4.0, et FG ne se lance pas.

Apparemment ça fonctionne avec Qt 5.9.1
Extrait d'un message de Slawek Mikula du 29/09/17

Compiled 5.9.1, Running with 5.9.1

Works OK.

Petite réflexion du lundi matin wink
Est-ce raisonnable de s'acharner à adapter d&c à la dernière dépendance utilisée par les développeurs il n'y a même pas une semaine?
Pour ceux qui mettons régulièrement à jour la version de dev nous trouvons plus ou moins la parade assez rapidement., et nous pouvons installer les nouvelles dépendances à la main, et aussi les retirer si besoin.
Nous faisons aussi le choix de tester les nouveautés, même si elles ne sont pas parfaitement abouties.
Laissons passer un mois et il sera bien temps de se préoccuper de modifier d&c. Les choses se seront décantées et on saura exactement ce qu'il convient d'ajouter.

Dernière modification par ctesc356 (2/10/2017 9:03:57)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#150 2/10/2017 9:18:41

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : Soucis momentanés avec GIT.

dany93 a écrit :

Vous rejoignez mon sentiment :
préference à
qtdeclarative5-private-dev
ET
qml-module-qtquick2

C'est pourtant ce que j'ai, avec l'erreur indiquée.

dany93 a écrit :

les traiter comme optionnels permettrait aux personnes qui se trouvent dans des distributions non-à-jour
d'encore créer FG, mais sans le lanceur intégré (ou créer un ancienne version de FG.....)

Ah bon ?
Et comment faire ?
Dans mon cas, la compilation de fglauncher, qui échoue, fait échouer celle de fgfs par la même occasion.

Je n'ai donc pas de lanceur, mais pas de FG non plus.

Du moins il ne me reste que l'ancien, en 2017.3.0 .
Avec un data 2017.4.0 .
Peut-on modifier l'étiquette du data, pour la repasser en 2017.3.0 ?


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

Pied de page des forums