Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#1 1/10/2017 7:11:09

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

[RESOLU] Download_and_compile vers 2017.3.1 ne fonctionne plus

Hello everyboody!

Donc voilà mon problème: je dispose de download_and_compile v2.34 téléchargé ici:https://sourceforge.net/p/flightgear/fg … compile.sh

Donc je lance le script et
Après avoir lancé cette command:

bash ./download_and_compile.sh -s FGFS SIMGEAR

Voici le message que j'obtiens (allez jusqu'à la fin pour voir l'erreur)

Atteint http://archive.canonical.com vivid InRelease                           
Atteint http://archive.ubuntu.com vivid InRelease                              
Atteint http://ppa.launchpad.net vivid InRelease                               
Ign http://dl.google.com stable InRelease                                      
Atteint http://archive.ubuntu.com vivid-updates InRelease                      
Ign http://dl.google.com stable InRelease                                      
Atteint http://archive.ubuntu.com vivid-security InRelease                     
Ign http://ppa.launchpad.net vivid InRelease                                   
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://dl.google.com stable Release.gpg                                
Atteint http://ppa.launchpad.net vivid InRelease                               
Atteint http://dl.google.com stable Release                                    
Atteint http://archive.canonical.com vivid/partner Sources                     
Atteint http://dl.google.com stable Release                                    
Atteint http://archive.canonical.com vivid/partner amd64 Packages              
Atteint http://ppa.launchpad.net vivid InRelease                               
Réception de : 1 http://dl.google.com stable/main amd64 Packages [1 393 B]     
Atteint http://archive.canonical.com vivid/partner i386 Packages               
Atteint http://archive.canonical.com vivid/partner Translation-en              
Atteint http://ppa.launchpad.net vivid/main Sources                            
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Réception de : 2 http://dl.google.com stable/main amd64 Packages [805 B]       
Réception de : 3 http://dl.google.com stable/main i386 Packages [800 B]        
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Ign http://ppa.launchpad.net vivid Release.gpg                                 
Ign http://ppa.launchpad.net vivid Release                                     
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Ign http://dl.google.com stable/main Translation-fr_FR                         
Ign http://dl.google.com stable/main Translation-fr                            
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Ign http://dl.google.com stable/main Translation-en                            
Ign http://dl.google.com stable/main Translation-fr_FR                         
Atteint http://ppa.launchpad.net vivid/main amd64 Packages                     
Ign http://dl.google.com stable/main Translation-fr                            
Ign http://dl.google.com stable/main Translation-en                            
Atteint http://ppa.launchpad.net vivid/main i386 Packages                      
Atteint http://ppa.launchpad.net vivid/main Translation-en                     
Atteint http://archive.ubuntu.com vivid/main Sources                           
Atteint http://archive.ubuntu.com vivid/restricted Sources                     
Atteint http://archive.ubuntu.com vivid/multiverse Sources                     
Atteint http://archive.ubuntu.com vivid/universe Sources                       
Atteint http://archive.ubuntu.com vivid/main amd64 Packages                    
Atteint http://archive.ubuntu.com vivid/restricted amd64 Packages              
Atteint http://archive.ubuntu.com vivid/universe amd64 Packages                
Atteint http://archive.ubuntu.com vivid/multiverse amd64 Packages              
Atteint http://archive.ubuntu.com vivid/main i386 Packages                     
Atteint http://archive.ubuntu.com vivid/restricted i386 Packages               
Atteint http://archive.ubuntu.com vivid/universe i386 Packages                 
Atteint http://archive.ubuntu.com vivid/multiverse i386 Packages               
Atteint http://archive.ubuntu.com vivid/main Translation-fr                    
Atteint http://archive.ubuntu.com vivid/main Translation-en                    
Atteint http://archive.ubuntu.com vivid/multiverse Translation-fr              
Atteint http://archive.ubuntu.com vivid/multiverse Translation-en              
Atteint http://archive.ubuntu.com vivid/restricted Translation-fr              
Atteint http://archive.ubuntu.com vivid/restricted Translation-en              
Atteint http://archive.ubuntu.com vivid/universe Translation-fr                
Atteint http://archive.ubuntu.com vivid/universe Translation-en                
Atteint http://archive.ubuntu.com vivid-updates/restricted Sources             
Atteint http://archive.ubuntu.com vivid-updates/multiverse Sources             
Atteint http://archive.ubuntu.com vivid-updates/main Sources                   
Atteint http://archive.ubuntu.com vivid-updates/universe Sources               
Atteint http://archive.ubuntu.com vivid-updates/main amd64 Packages            
Atteint http://archive.ubuntu.com vivid-updates/restricted amd64 Packages      
Atteint http://archive.ubuntu.com vivid-updates/universe amd64 Packages        
Atteint http://archive.ubuntu.com vivid-updates/multiverse amd64 Packages      
Atteint http://archive.ubuntu.com vivid-updates/main i386 Packages             
Atteint http://archive.ubuntu.com vivid-updates/restricted i386 Packages       
Atteint http://archive.ubuntu.com vivid-updates/universe i386 Packages         
Atteint http://archive.ubuntu.com vivid-updates/multiverse i386 Packages       
Err http://ppa.launchpad.net vivid/main Sources                                
  404  Not Found
Atteint http://archive.ubuntu.com vivid-updates/main Translation-en            
Err http://ppa.launchpad.net vivid/main amd64 Packages                         
  404  Not Found
Atteint http://archive.ubuntu.com vivid-updates/multiverse Translation-en      
Atteint http://archive.ubuntu.com vivid-updates/restricted Translation-en      
Err http://ppa.launchpad.net vivid/main i386 Packages                          
  404  Not Found
Atteint http://archive.ubuntu.com vivid-updates/universe Translation-en        
Atteint http://archive.ubuntu.com vivid-security/restricted Sources            
Ign http://ppa.launchpad.net vivid/main Translation-fr_FR                      
Atteint http://archive.ubuntu.com vivid-security/multiverse Sources            
Atteint http://archive.ubuntu.com vivid-security/main Sources                  
Ign http://ppa.launchpad.net vivid/main Translation-fr                         
Atteint http://archive.ubuntu.com vivid-security/universe Sources              
Atteint http://archive.ubuntu.com vivid-security/main amd64 Packages           
Ign http://ppa.launchpad.net vivid/main Translation-en                         
Atteint http://archive.ubuntu.com vivid-security/restricted amd64 Packages     
Atteint http://archive.ubuntu.com vivid-security/universe amd64 Packages       
Atteint http://archive.ubuntu.com vivid-security/multiverse amd64 Packages     
Atteint http://archive.ubuntu.com vivid-security/main i386 Packages            
Atteint http://archive.ubuntu.com vivid-security/restricted i386 Packages      
Atteint http://archive.ubuntu.com vivid-security/universe i386 Packages        
Atteint http://archive.ubuntu.com vivid-security/multiverse i386 Packages      
Atteint http://archive.ubuntu.com vivid-security/main Translation-en           
Atteint http://archive.ubuntu.com vivid-security/multiverse Translation-en     
Atteint http://archive.ubuntu.com vivid-security/restricted Translation-en     
Atteint http://archive.ubuntu.com vivid-security/universe Translation-en       
W: Impossible de récupérer http://ppa.launchpad.net/mdeguzis/libregeek/ubuntu/dists/vivid/main/source/Sources  404  Not Found

W: Impossible de récupérer http://ppa.launchpad.net/mdeguzis/libregeek/ubuntu/dists/vivid/main/binary-amd64/Packages  404  Not Found

W: Impossible de récupérer http://ppa.launchpad.net/mdeguzis/libregeek/ubuntu/dists/vivid/main/binary-i386/Packages  404  Not Found

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

En bref une erreur 404 Not Found!

Quelqu'un saurait d'où vient l'erreur?
Merci par avance de vos réponses...

Amicalement

Dernière modification par Texan78 (2/10/2017 17:25:31)


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

#2 1/10/2017 8:36:50

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 226

Re : [RESOLU] Download_and_compile vers 2017.3.1 ne fonctionne plus

Bonjour,
tu as téléchargé quelque chose de "ppa.launchpad.net/mdeguzis/libregeek/ubuntu/dists/vivid/main", ce depôt n'existe apparemment plus ou a été renommé.
Il faut voir dans "/etc/apt/sources.list" et dans les fichiers de "/etc/apt/sources.list.d" et supprimer ou commenter (par # en début de ligne) les entrées qui se rapportent à ce dépôt.
A faire en tant que "root" (avec sudo)

Tu devrais aussi récupérer une nouvelle version du script d&c ici: https://sourceforge.net/p/flightgear/fg … compile.sh


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#3 1/10/2017 9:25:42

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Download_and_compile vers 2017.3.1 ne fonctionne plus

Le script fonctionne en plusieurs temps.

Tout d'abord il va procéder à un "update".
C'est pendant cet "update" que tu rencontres une erreur.
Comme le dit ctesc 356, certaines lignes de ton sources.list ne sont plus valables.
Et elles font échouer l'update.

Puis il fait un "upgrade" des paquets système.
Du moins ceux qui sont nécessaires à la compilation de FG, et ce, suivant les options demandées.
De manière soit à avoir la dernière version disponible des paquets soit à en ajouter de nouveaux qui sont devenus nécessaires à la compilation.

Enfin, lorsque ces deux opérations sont réalisées, la compilation démarre (qui n'est pas toujours elle non plus exempte d'erreurs...).

Pour corriger ton sources.list, ctesc356 t'a indiqué la méthode.
Mais il y a aussi un outil en interface graphique pour qui n'est pas trop familiarisé à la ligne de commande.
C'est si je me souviens bien (je ne l'utilise jamais), source de logiciels.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#4 1/10/2017 9:56:58

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : [RESOLU] Download_and_compile vers 2017.3.1 ne fonctionne plus

f-toro a écrit :

...............
Mais il y a aussi un outil en interface graphique pour qui n'est pas trop familiarisé à la ligne de commande.
C'est si je me souviens bien (je ne l'utilise jamais), source de logiciels.

Depuis les Sources de logiciels, tu sélectionnes Sources de Logiciels, puis PPA, et tu décochent ceux qui sont évoqués dans ton message d'erreur.
En écrivant, je me rend compte que ton soucis ne vient pas forcément de là, est-ce que Ubuntu 15.04 est toujours maintenu?.

Bon, çà peut servir, voici la manip en photo et en couleur:

mini_916216Menu012.png

mini_836251Slection013.png

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#5 2/10/2017 17:25:06

Texan78
Membre
Lieu : FMEP
Inscription : 15/06/2014
Messages : 209

Re : [RESOLU] Download_and_compile vers 2017.3.1 ne fonctionne plus

Merci pour toutes vos réponses j'ai supprimé les dépots en question qui posaient problème le d&c fonctionne correctement merci encore big_smile

Amicalement.


Flightgear 2017.3.0
Ubuntu 15.04
Processeur: Intel Core i5-4258U CPU @ 2.40GHz x 4  RAM: 6Go   64bits
Carte Graphique: AMD Radeon HD 8500M

Hors ligne

Pied de page des forums