Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#26 10/11/2017 11:02:32

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

ctesc356 a écrit :

  il me semble qu'il y a déja eu des soucis avec osg3.4 installé par paquets ou synaptic donc on le compile par d&c

Il y avait il y a quelque temps une histoire de roulette de souris, non opérationnelle dans un cas bien particulier, dont je ne me remémore plus, quand on compilait avec les paquets système libosg au lieu de compiler osg et de ne pas utiliser les paquets système.
Mais petit inconvénient d'utilisation qui n'empêchait absolument pas FG d'être fonctionnel.
Je ne sais pas si les paquets système actuels ont résolu ce problème.

ctesc356 a écrit :

le strict minimum pour un fg fonctionnel sont: OSG SIMGEAR FGFS DATA

Le strict minimum est SIMGEAR FGFS DATA à condition de compiler avec les paquets système libosg.
Autrefois je compilais osg.
Mais maintenant je ne le fais plus, l'histoire de la roulette ne m'a jamais gêné, étant plus un pilote FG amateur que pro.
Et donc mon FG est du moins pour moi parfaitement fonctionnel.

Par contre il me semble que si on compile osg il faut faire attention que les paquets système libosg ne soient pas installés.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#27 10/11/2017 11:20:01

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 228

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

f-toro a écrit :

Il y avait il y a quelque temps une histoire de roulette de souris, non opérationnelle dans un cas bien particulier,

Ca c'est avec PLIB, si on ne compile pas plib la roulette ne fonctionne pas dans le menu. Mais je crois que ça bouge du côté dev's.

f-toro a écrit :
ctesc356 a écrit :

le strict minimum pour un fg fonctionnel sont: OSG SIMGEAR FGFS DATA

Le strict minimum est SIMGEAR FGFS DATA à condition de compiler avec les paquets système libosg.
Autrefois je compilais osg.
Mais maintenant je ne le fais plus, l'histoire de la roulette ne m'a jamais gêné, étant plus un pilote FG amateur que pro.
Et donc mon FG est du moins pour moi parfaitement fonctionnel.

Par contre il me semble que si on compile osg il faut faire attention que les paquets système libosg ne soient pas installés.

Ici, depuis quelque-temps fg ne compile pas si je ne compile pas osg, les paquets libosg installés par ailleurs ne m'ont jamais posé de problèmes.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#28 10/11/2017 13:09:03

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

ctesc356 a écrit :

Ca c'est avec PLIB, si on ne compile pas plib la roulette ne fonctionne pas dans le menu. Mais je crois que ça bouge du côté dev's.

Ah oui, c'est vrai, ce n'est pas osg mais ce fichu plib.
Moi j'ai libplib 8.5-8, et je suis en train de recompiler pour voir si ça compile chez moi avec les paquets système libosg.
La roulette ne marche pas dans le menu.
C'est à dire ?
Si je déroule un menu de FG avec le pointeur de la souris, je dois ensuite pouvoir voyager dans les articles à l'aide de la roulette ?


ctesc356 a écrit :

Ici, depuis quelque-temps fg ne compile pas si je ne compile pas osg, les paquets libosg installés par ailleurs ne m'ont jamais posé de problèmes.

Je viens de recompiler avec SIMGEAR FGFS DATA et les paquets système libosg.
Pas de souci chez moi.
Je suis en libopenscenegraph-3.4-131 et en libopenscenegraph-3.4-dev .


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#29 10/11/2017 13:38:05

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 613

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Je pensais aussi que, compte tenu de l'état du contenu de Flightgear-2017.4 de JackyB, le mieux était de refaire un compilation à neuf.
Ou en appliquant la méthode sélective de ctesc356 si liaison Internet insuffisante, mais avec cette idée en mémoire.

ctesc356 a écrit :

Remarque: le strict minimum pour un fg fonctionnel sont: OSG SIMGEAR FGFS DATA
(....)
Ici, depuis quelque-temps fg ne compile pas si je ne compile pas osg, les paquets libosg installés par ailleurs ne m'ont jamais posé de problèmes.

Et même pour OSG, je ne sais pas....

dany93 a écrit :

J'ai ensuite compilé FG 2017.4.0 à neuf sans OSG (je n'y ai même pas pensé), j'ai Open Scene Graph 3.2.1 dans FG, et ça fonctionne... tongue
Peut-être grâce à des bibliothèques installées lors des manips précédentes ?
Peut-être que je rate quelque chose ? Le rendu dans FG est normal, RAS.

Ce que j'ai d'openscenegraph (image Synaptic) :
mini_978352Synapticopenscenegraph.png

Je compile PLIB (en premier) uniquement pour avoir la roulette souris dans les Propriétés Internes.

Il faut avoir (dépôts LM 18)
qtdeclarative5-dev
qtdeclarative5-private-dev

Ce qui m'a fait, pour compiler à neuf FG 2017.4.0 :

WHATTOBUILDALL=(PLIB SIMGEAR FGFS DATA)

Donc j'ai PLIB (très facultatif),
Je n'ai pas OSG 3.4 compilé (en tous cas, pas avec FG 2017.4.0), FG m'affiche seulement OSG 3.2.1.
En fait, je n'ai que des bibliothèques <lib>OSG 3.2.1 des dépôts Linux Mint.
Sachant que j'ai OSG 3.4.0 compilé dans le dossier FG 2017.3.0... mais cela ne devrait pas influer.

Dernière modification par dany93 (10/11/2017 21:08:14)


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#30 10/11/2017 13:45:28

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 613

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

f-toro a écrit :

Ah oui, c'est vrai, ce n'est pas osg mais ce fichu plib.
La roulette ne marche pas dans le menu.
C'est à dire ?
Si je déroule un menu de FG avec le pointeur de la souris, je dois ensuite pouvoir voyager dans les articles à l'aide de la roulette ?

C'est pour faire fonctionner la roulette souris dans les Propriétés Internes (pas pour les menus, dans lesquels on descend de manière classique par glissement vertical du curseur).
PLIB doit être compilé en premier. Sinon, il faut recompiler (peut-être seulement fgfs ?).


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#31 10/11/2017 15:13:41

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Effectivement pas de roulette dans les propriétés internes.
Je zieuterai à l'avenir si elle marche en cas de maj de libplib.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#32 10/11/2017 16:44:13

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 228

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

dany93 a écrit :

Ce qui m'a fait, pour compiler à neuf FG 2017.4.0 :

WHATTOBUILDALL=(PLIB SIMGEAR FGFS DATA)

Donc j'ai PLIB (très facultatif),
Je n'ai pas OSG 3.4 compilé, seulement OSG 3.2.1 des dépôts Linux Mint.

J'ai voulu en avoir le coeur net.
j'ai compilé à neuf comme dany93 ci dessus: SIMGEAR FGFS (laissons PLIB pour le moment, et DATA est inclu par un lien)
Erreur de compilation de FGFS, un truc en rapport avec canvas et osg.

"-- Found OpenSceneGraph: /usr/lib/x86_64-linux-gnu/libosgText.so ... ... ... (found suitable version "3.2.1", minimum required is "3.2.0")" osg installé par apt

Rebelote avec: OSG SIMGEAR FGFS
Ca passe smile et fg fonctionne

"-- Found OpenSceneGraph: /home/tt/fg-3/install/openscenegraph/lib64/libosgText.so; ... ... ... (found suitable version "3.4.2", minimum required is "3.2.0")" osg compilé par d&c

Conclusion: l'informatique est loin d'être une science exacte wink
suivant la configuration matérielle ( apparemment on à la même config logicielle ou très approchant) le compilateur prend des options différentes.

J'espère que JackyB nous en voudra pas d'avoir digressé un peu smile

Dernière modification par ctesc356 (10/11/2017 17:07:29)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#33 10/11/2017 21:51:42

JackyB
Membre
Lieu : St Germain en Laye
Inscription : 16/12/2010
Messages : 26

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Bonsoir à tous,
désolé de n'avoir pu intervenir plus tôt mais la ligne n'était pas trop fonctionnelle.
j'ai opté pour une installation refaite à neuf selon Christian CLM76.
J'ai donc recrée un dossier FGFS nouveau, D&C CMAKE, PLIB, FGFS, SIMGEAR mais la j'ai déjà un soucis

- Configuring incomplete, errors occurred!
See also "/home/jackyb/Simulation/FGFS2017-4-0/build/flightgear/CMakeFiles/CMakeOutput.log".
See also "/home/jackyb/Simulation/FGFS2017-4-0/build/flightgear/CMakeFiles/CMakeError.log".
make: *** Pas de cible spécifiée et aucun makefile n'a été trouvé. Arrêt.
make: *** Aucune règle pour fabriquer la cible « install ». Arrêt.
All optional package alternatives have found a matching package

   

Je vais faire le  D&C sur DATA histoire de gagner un peu de temps ...

J'espère que JackyB nous en voudra pas d'avoir digressé un peu smile

Absolument pas il n'est pas encore interdit d'apprendre ....
.


Linux Mint 18.2 Sonia   FG2017.4  Nvidia 220   4G ram    Extreme 3D pro

Hors ligne

#34 10/11/2017 22:01:07

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 228

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

JackyB a écrit :

J'ai donc recrée un dossier FGFS nouveau, D&C CMAKE, PLIB, FGFS, SIMGEAR mais la j'ai déjà un soucis .

ne t'embête pas avec CMAKE, sous mint 18.2 tu as une version compatible.
Essaie plutôt d&c PLIB OSG SIMGEAR FGFS. Impérativement dans cet ordre.
Avec tous tes essais tu as sûrement un fgdata à récupérer. Pour ne pas perdre de temps de téléchargement. tu le copies simplement dans "/install/flightgear" de ton nouveau dossier.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#35 11/11/2017 11:36:11

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 228

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Bonjour,
à la relecture complète de ce sujet, je me rends compte que JackyB est confronté à une erreur d'éxecution et non à une erreur de compilation:

jackyb@jackyb-VG267AA-ABF-p6244fr ~/Simulation/Flightgear-2017.4 $ ./run_fgfs.sh --launcher
./fgfs: error while loading shared libraries: libosgText.so.131: cannot open shared object file: No such file or directory

Je vois aussi que lors de la compilation les libs osg sont trouvées dans "/usr/local/lib64". Normalement elles se trouvent plutôt dans "/usr/lib/x86_64-linux-gnu/". Pourquoi cet emplacement "exotique"?

Apparemment fg ne trouve pas de lib osg au lancement. Il suffirait probablement d'ajouter le chemin dans "$LD_LIBRARY_PATH="
Modifier la ligne 4 de "run_fgfs.sh" en:

export LD_LIBRARY_PATH=/usr/local/lib64:../../simgear/lib:../../openscenegraph/lib:../../openrti/lib:../../plib/lib

à tester, sans garantie...
bon... compiler osg sera peut-être plus simple wink


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#36 11/11/2017 15:53:14

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

ctesc356 a écrit :

bon... compiler osg sera peut-être plus simple wink

C'est bien possible.

Mais si JackyB a des libs osg dans "/usr/local/lib64/" , pour moi c'est qu'elles proviennent d'une compilation.

Sauf erreur de ma part, les libs compilées sont dans un "/usr/local/" .
Donc ça ne me paraît pas foncièrement anomal qu'on les trouve dans "/usr/local/lib64".
Si elles proviennent de l'installation des paquets système libopenscenegraph(version) et libopenscenegraph(version)-dev, c'est là qu'elles se trouveront dans "/usr/lib/x86_64-linux-gnu/".

Mais il faut que ça soit l'un ou l'autre.
Si on compile on désinstalle les paquets système.
Les deux ne seraint-ils pas installés ensemble ?


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#37 11/11/2017 16:00:08

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Bonjour à tous,

Je ne sais pas si çà a un rapport avec la séance de patinage de ce thread, mais ce matin impossible de mettre à jour:

--   Qt5Widgets version: 5.5.1
--   Qt5Widgets include dir: /usr/include/x86_64-linux-gnu/qt5/;/usr/include/x86_64-linux-gnu/qt5/QtWidgets;/usr/include/x86_64-linux-gnu/qt5/QtGui;/usr/include/x86_64-linux-gnu/qt5/QtCore;/usr/lib/x86_64-linux-gnu/qt5//mkspecs/linux-g++-64;/usr/include
-- Checking whether private include directories for module Qt5Gui exist
CMake Error at CMakeLists.txt:323 (message):
  The private include directory /usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1
  for module Qt5Gui do not exist! Please make sure your Qt5 installation
  contains private headers.

  The required directories:

    /usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1;/usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1/QtGui;/usr/include/x86_64-linux-gnu/qt5/QtCore/5.5.1;/usr/include/x86_64-linux-gnu/qt5/QtCore/5.5.1/QtCore
Call Stack (most recent call first):
  CMakeLists.txt:352 (check_private_headers_exist)


-- Configuring incomplete, errors occurred!
See also "/home/titi38/FGFS/next/build/flightgear/CMakeFiles/CMakeOutput.log".
See also "/home/titi38/FGFS/next/build/flightgear/CMakeFiles/CMakeError.log".
Makefile:1165 : la recette pour la cible « cmake_check_build_system » a échouée
make: *** [cmake_check_build_system] Erreur 1
CMAKE Build type: RelWithDebInfo
-- System is: Linux
-- Linux distro is: LinuxMint
-- Web browser launcher command is: xdg-open
-- Using explicit data directory for base package: /home/titi38/FGFS/next/install/flightgear/lib/FlightGear
-- libudev stable: 1
-- Found UDev: /usr/lib/x86_64-linux-gnu/libudev.so
--    include: /usr/include
-- Git revision is 9eaa2f7efc00898b87802bb99127ebe54aaa2b89
-- event-based input enabled. Using /usr/lib/x86_64-linux-gnu/libudev.so
-- Boost version: 1.58.0
-- Using DBus
-- Qt launcher enabled, checking for Qt 5.4 / qmake
-- Will enable Qt launcher GUI
--   Qt5Widgets version: 5.5.1
--   Qt5Widgets include dir: /usr/include/x86_64-linux-gnu/qt5/;/usr/include/x86_64-linux-gnu/qt5/QtWidgets;/usr/include/x86_64-linux-gnu/qt5/QtGui;/usr/include/x86_64-linux-gnu/qt5/QtCore;/usr/lib/x86_64-linux-gnu/qt5//mkspecs/linux-g++-64;/usr/include
-- Checking whether private include directories for module Qt5Gui exist
CMake Error at CMakeLists.txt:323 (message):
  The private include directory /usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1
  for module Qt5Gui do not exist! Please make sure your Qt5 installation
  contains private headers.

  The required directories:

    /usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1;/usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1/QtGui;/usr/include/x86_64-linux-gnu/qt5/QtCore/5.5.1;/usr/include/x86_64-linux-gnu/qt5/QtCore/5.5.1/QtCore
Call Stack (most recent call first):
  CMakeLists.txt:352 (check_private_headers_exist)


-- Configuring incomplete, errors occurred!
See also "/home/titi38/FGFS/next/build/flightgear/CMakeFiles/CMakeOutput.log".
See also "/home/titi38/FGFS/next/build/flightgear/CMakeFiles/CMakeError.log".
Makefile:1165 : la recette pour la cible « cmake_check_build_system » a échouée
make: *** [cmake_check_build_system] Erreur 1

Le log complet:
https://pastebin.com/dRTCmrtw

smile

Dernière modification par Patten (11/11/2017 16:03:40)


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#38 11/11/2017 16:44:50

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Personnellement j'ai recompilé en début d'après-midi, pour voir où FG trouvait les libs osg, afin de comparer par rapport à JackyB et ce que disait ctesc356.
Aucun souci particulier.
Je pense que j'ai la dernière version de d&c (je ne vois pas bien où elle est mentionnée dans le script).


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#39 11/11/2017 16:52:40

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Par contre mes libqt5 sont en 5.9.1 .
Serais-ce un problème de version ?


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#40 11/11/2017 17:06:05

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 613

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Ou elle nécessite "private headers" ?

libqt5xmlpatterns5-private-dev

La dernière version de d&c est 663eaa du 03 oct 2017


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#41 11/11/2017 17:40:32

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

dany93 a écrit :

Ou elle nécessite "private headers" ?
libqt5xmlpatterns5-private-dev

Ce paquet n'existe pas dans mon système et n'est pas installé.

dany93 a écrit :

La dernière version de d&c est 663eaa du 03 oct 2017

Oui mais lorsqu'on ouvre le script en texte je ne vois pas bien où cette dernière version est mentionnée.
Donc je ne sais pas si je l'ai téléchargée après le 3 octobre.
En tout cas je compile sans problème.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#42 11/11/2017 17:43:41

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 613

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Ces derniers messages seraient mieux dans Soucis momentanés avec GIT (quitte à mettre un renvoi ici).

Pour revenir au problème de JackyB :
Bizarre cette histoire de version de OSG...
Dans compilation_log.txt de Patten, je lis (lignes 51... )

Found OpenSceneGraph: /home/titi38/FGFS/next/install/openscenegraph/lib64/libosgText.so;.... (found suitable version "3.4.1", minimum required is "3.2.0")

Dans le mien (c'est cohérent avec ma situation FG 2017.4.0 sans compile OSG),

"Found OpenSceneGraph: /usr/lib/x86_64-linux-gnu/libosgText.so;.... (found suitable version "3.2.1", minimum required is "3.2.0")

Minimum 3.2.0.
Alors pourquoi ?... hmm


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#43 11/11/2017 17:45:50

Patten
Membre
Lieu : LFLR
Inscription : 14/12/2010
Messages : 1 523
Site Web

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

dany93 a écrit :

Ou elle nécessite "private headers" ?

libqt5xmlpatterns5-private-dev

Idem.

dany93 a écrit :

.....
La dernière version de d&c est 663eaa du 03 oct 2017

Idem

smile


Intel I7.7700k 4.2 GHz 4 C 8 tr.MSI Gaming pro.MSI GTX 1080 Armor 8Go.Ram:16Go DDR4 GSKILL 3000Mhz.Stock:2*480Go SSD Kingston UV 400+2*2T HDD Seagate Baracuda.Alim:Corsair RM750X 80Plus Gold.Ventirad Be quiet pure rock.Boîtier Aérocool GT-S black édition.DVD Asus drw-24f1-mt. Wifi + Bluetooth gigabyte.Dual boot Linux Mint 18.2 Sonya Cinnamon/Windows 10
http://pattenflightgear.wifeo.com/

Hors ligne

#44 11/11/2017 17:45:53

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 613

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

f-toro a écrit :

Oui mais lorsqu'on ouvre le script en texte je ne vois pas bien où cette dernière version est mentionnée.

Exact, et c'est bien dommage.
Moi, je le sais parce que je l'ai noté, vu la faille...


FG 2017.4.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#45 11/11/2017 20:04:27

JackyB
Membre
Lieu : St Germain en Laye
Inscription : 16/12/2010
Messages : 26

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

ctesc356 a écrit :

Essaie plutôt d&c PLIB OSG SIMGEAR FGFS. Impérativement dans cet ordre.
Avec tous tes essais tu as sûrement un fgdata à récupérer. Pour ne pas perdre de temps de téléchargement. tu le copies simplement dans "/install/flightgear" de ton nouveau dossier.

J'ai fait ça très précisément ...mais j'ai un soucis en fin de D&C  FGFS

-- Qt launcher enabled, checking for Qt 5.4 / qmake
-- Will enable Qt launcher GUI
--   Qt5Widgets version: 5.5.1
--   Qt5Widgets include dir: /usr/include/x86_64-linux-gnu/qt5/;/usr/include/x86_64-linux-gnu/qt5/QtWidgets;/usr/include/x86_64-linux-gnu/qt5/QtGui;/usr/include/x86_64-linux-gnu/qt5/QtCore;/usr/lib/x86_64-linux-gnu/qt5//mkspecs/linux-g++-64;/usr/include
-- Checking whether private include directories for module Qt5Gui exist
CMake Error at CMakeLists.txt:323 (message):
  The private include directory /usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1
  for module Qt5Gui do not exist! Please make sure your Qt5 installation
  contains private headers.

  The required directories:

    /usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1;/usr/include/x86_64-linux-gnu/qt5/QtGui/5.5.1/QtGui;/usr/include/x86_64-linux-gnu/qt5/QtCore/5.5.1;/usr/include/x86_64-linux-gnu/qt5/QtCore/5.5.1/QtCore
Call Stack (most recent call first):
  CMakeLists.txt:352 (check_private_headers_exist)


-- Configuring incomplete, errors occurred!
See also "/home/jackyb/Simulation/FGFS-2017-4/build/flightgear/CMakeFiles/CMakeOutput.log".
See also "/home/jackyb/Simulation/FGFS-2017-4/build/flightgear/CMakeFiles/CMakeError.log".

MAKE flightgear
make: *** Pas de cible spécifiée et aucun makefile n'a été trouvé. Arrêt.
INSTALL flightgear
make: *** Aucune règle pour fabriquer la cible « install ». Arrêt.
***********************************
All optional package alternatives have found a matching package.

Ce qui me donne en terminal

jackyb@jackyb-VG267AA-ABF-p6244fr ~/Simulation/FGFS-2017-4 $ ./run_fgfs.sh --launcher
./run_fgfs.sh: 3: cd: can't cd to install/flightgear/bin
./run_fgfs.sh: 5: ./run_fgfs.sh: ./fgfs: not found
jackyb@jackyb-VG267AA-ABF-p6244fr ~/Simulation/FGFS-2017-4 $ ./run_fgfs.sh
./run_fgfs.sh: 3: cd: can't cd to install/flightgear/bin
./run_fgfs.sh: 5: ./run_fgfs.sh: ./fgfs: not found
jackyb@jackyb-VG267AA-ABF-p6244fr ~/Simulation/FGFS-2017-4 $ 

Le fichier /build/flightgear/CMakeFiles/CMakeError.log". donne

Determining if the function pthread_create exists in the pthreads failed with the following output:
Change Dir: /home/jackyb/Simulation/FGFS-2017-4/build/flightgear/CMakeFiles/CMakeTmp

Run Build Command:"/usr/bin/make" "cmTC_06288/fast"
/usr/bin/make -f CMakeFiles/cmTC_06288.dir/build.make CMakeFiles/cmTC_06288.dir/build
make[1] : on entre dans le répertoire « /home/jackyb/Simulation/FGFS-2017-4/build/flightgear/CMakeFiles/CMakeTmp »
Building C object CMakeFiles/cmTC_06288.dir/CheckFunctionExists.c.o
/usr/bin/cc    -DCHECK_FUNCTION_EXISTS=pthread_create   -o CMakeFiles/cmTC_06288.dir/CheckFunctionExists.c.o   -c /usr/share/cmake-3.5/Modules/CheckFunctionExists.c
Linking C executable cmTC_06288
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_06288.dir/link.txt --verbose=1
/usr/bin/cc   -DCHECK_FUNCTION_EXISTS=pthread_create    CMakeFiles/cmTC_06288.dir/CheckFunctionExists.c.o  -o cmTC_06288 -rdynamic -lpthreads 
/usr/bin/ld : ne peut trouver -lpthreads
collect2: error: ld returned 1 exit status
CMakeFiles/cmTC_06288.dir/build.make:97 : la recette pour la cible « cmTC_06288 » a échouée
make[1]: *** [cmTC_06288] Erreur 1
make[1] : on quitte le répertoire « /home/jackyb/Simulation/FGFS-2017-4/build/flightgear/CMakeFiles/CMakeTmp »
Makefile:126 : la recette pour la cible « cmTC_06288/fast » a échouée
make: *** [cmTC_06288/fast] Erreur 2

le Cmake output log ne mentionne rien d'anormal ....

Voila ou j'en suis


Linux Mint 18.2 Sonia   FG2017.4  Nvidia 220   4G ram    Extreme 3D pro

Hors ligne

#46 11/11/2017 21:35:45

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

A priori c'est la même erreur que Patten.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#47 12/11/2017 1:40:34

JackyB
Membre
Lieu : St Germain en Laye
Inscription : 16/12/2010
Messages : 26

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

ctesc356 a écrit :

Apparemment ce qu'il cherche se trouve dans "qtdeclarative5-private-dev" ou "qtbase5-private-dev" ou encore "qtbase5-dev"
As-tu ces paquets ?
dpkg-query -l 'paquet'

Bonsoir, j'ai monté ces paquets et la compilation a fonctionné nickel, j'ai maintenant accès à QTlauncher.
Par contre d'autres soucis se font connaître, voir la console

jackyb@jackyb-VG267AA-ABF-p6244fr ~/Simulation/FGFS-2017-4 $ ./run_fgfs.sh --launcher
FlightGear:  Version 2017.4.0
FlightGear:  Build Type Dev
Built with GNU C++ version 5.4
Jenkins number/ID 0:none
scenery path not found:Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Scenery"
NavCache at:Path "/home/jackyb/.fgfs/navdata_2017_4.cache"
NavCache read-only flags is:0
NavCache: no main cache rebuild required
init package root at:Path "/home/jackyb/.fgfs/Aircraft"
scenery path not found:Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Scenery"
reading groundnet data from Path "/home/jackyb/.fgfs/TerraSync/Airports/L/F/L/LFLG.groundnet.xml"
parsing groundnet XML took 0
reading groundnet data from Path "/home/jackyb/.fgfs/TerraSync/Airports/L/F/O/LFOH.groundnet.xml"
parsing groundnet XML took 8
aircraft = CitationX
found aircraft in dir: /home/jackyb/Simulation/Autres_avions/CitationX
Aircraft does not specify a minimum FG version: please add one at /sim/minimum-fg-version
Found language resource for: fr_FR
Reading localized strings for 'en' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/default/sys.xml"
Reading localized strings for 'fr' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/fr/sys.xml"
Reading localized strings for 'en' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/default/atc.xml"
Reading localized strings for 'fr' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/default/atc.xml"
Reading localized strings for 'en' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/default/tips.xml"
Reading localized strings for 'fr' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/fr/tips.xml"
	option:aircraft-dir = /home/jackyb/Simulation/Autres_avions/CitationX
	option:aircraft = CitationX
	option:fg-aircraft = /home/jackyb/Simulation/Autres_avions
	option:airport = LFOH
	option:runway = 22
	option:nav1 = 223.08:109.5
	option:disable-auto-coordination = 

Utilisation : fgfs [ option ... ]

Options générales:
   --help, -h                   Affiche les options de ligne de commande les
                                plus appropriées.
   --verbose, -v                Affiche toutes les options de ligne de commande
                                lorsqu'elle est combinée avec --help ou -h.
   --fg-root=path               Spécifie l'emplacement du répertoire racine
                                des données.
   --fg-scenery=path            Spécifie l'emplacement des répertoires des
                                scènes.
                                Positionné par défaut à $FG_ROOT/Scenery.
   --fg-aircraft=path           Spécifie les emplacements des répertoires des
                                aéronefs additionnels.
   --download-dir=path          Spécifie le répertoire pour les
                                téléchargements d'aéronefs et de scènes
                                (celui pour les scènes obtenues via TerraSync
                                peut éventuellement être choisi de manière
                                spécifique avec --terrasync-dir).
   --language=code              Choisit la langue pour cette session.

Aéronef:
   --aircraft=name              Choisit un profil d'aéronef défini par un
                                fichier <nom>-set.xml.
   --show-aircraft              Affiche une liste des types d'aéronefs
                                actuellement disponibles.

   --min-status={alpha,beta,early-production,production}
                                Permet de définir le niveau de statut minimum
                                (= statut de développement) pour tous les
                                aéronefs listés.

Position et orientation initiales:
   --airport=ID                 Précise la position de démarrage relative à
                                un aéroport.
   --runway=rwy_no              Précise la piste de départ (un aéroport doit
                                également être précisé).
   --carrier=[name|ID]          Précise la position de démarrage sur un
                                porte-avions AI.

Pour une liste complète des options, utilisez --help --verbose
jackyb@jackyb-VG267AA-ABF-p6244fr ~/Simulation/FGFS-2017-4 $ 

Une solution simple ?   
A priori cette version 217.4.0 semble bien plus exigeante que les précédentes, bien sur en lançant FLY  FG plante ...

Dernière modification par JackyB (12/11/2017 1:42:57)


Linux Mint 18.2 Sonia   FG2017.4  Nvidia 220   4G ram    Extreme 3D pro

Hors ligne

#48 12/11/2017 2:29:45

JackyB
Membre
Lieu : St Germain en Laye
Inscription : 16/12/2010
Messages : 26

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

J'ai réussi à faire un vol avec le C337
https://fgtracker.ml/modules/fgtracker/ … ID=6959500
par contre certaines fonctions ne sont pas utilisables  focus, train rentrant etc
le log:

jackyb@jackyb-VG267AA-ABF-p6244fr ~/Simulation/FGFS-2017-4 $ ./run-fgfs.sh --launcher
bash: ./run-fgfs.sh: Aucun fichier ou dossier de ce type
jackyb@jackyb-VG267AA-ABF-p6244fr ~/Simulation/FGFS-2017-4 $ ./run_fgfs.sh --launcher
FlightGear:  Version 2017.4.0
FlightGear:  Build Type Dev
Built with GNU C++ version 5.4
Jenkins number/ID 0:none
scenery path not found:Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Scenery"
NavCache at:Path "/home/jackyb/.fgfs/navdata_2017_4.cache"
NavCache read-only flags is:0
NavCache: no main cache rebuild required
init package root at:Path "/home/jackyb/.fgfs/Aircraft"
scenery path not found:Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Scenery"
reading groundnet data from Path "/home/jackyb/.fgfs/TerraSync/Airports/L/F/O/LFOH.groundnet.xml"
parsing groundnet XML took 0
Selecting aircraft:12
Selecting aircraft:17
reading groundnet data from Path "/home/jackyb/.fgfs/TerraSync/Airports/L/F/N/LFNG.groundnet.xml"
parsing groundnet XML took 4
*** UTM:SVC TimerManager:registerTimer called after profile-before-change notification. Ignoring timer registration for id: telemetry_modules_ping
aircraft = Cessna337
found aircraft in dir: /home/jackyb/Simulation/Autres_avions/Cessna337
Aircraft does not specify a minimum FG version: please add one at /sim/minimum-fg-version
Found language resource for: fr_FR
Reading localized strings for 'en' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/default/sys.xml"
Reading localized strings for 'fr' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/fr/sys.xml"
Reading localized strings for 'en' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/default/atc.xml"
Reading localized strings for 'fr' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/default/atc.xml"
Reading localized strings for 'en' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/default/tips.xml"
Reading localized strings for 'fr' from Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Translations/fr/tips.xml"
	option:aircraft-dir = /home/jackyb/Simulation/Autres_avions/Cessna337
	option:aircraft = Cessna337
	option:fg-aircraft = /home/jackyb/Simulation/Autres_avions
	option:airport = LFNG
	option:runway = 33
	option:disable-auto-coordination = 
	option:prop = /sim/multiplay/txhost=mpserver01.flightgear.org
	option:prop = /sim/multiplay/txport=5000
	option:callsign = JackyB
	option:enable-terrasync = 
	option:disable-fullscreen = 
	option:disable-rembrandt = 
	option:season = winter
	option:enable-real-weather-fetch = 
	option:fg-root = /home/jackyb/Simulation/FGFS-2017-4/install/flightgear/bin/../fgdata/
	option:launcher = 
Using default download dir: Path "/home/jackyb/.fgfs"
read-allowed path not found:Path "/home/jackyb/.fgfs/AI"
read-allowed path not found:Path "/home/jackyb/.fgfs/Liveries"
Using TerraSync dir: Path "/home/jackyb/.fgfs/TerraSync"
scenery path not found:Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Scenery"
EmbeddedResourceManager: selected locale 'fr_FR'
Using stock OSG implementation of GraphicsWindow
StatsHandler::StatsHandler() Setting up GL2 compatible shaders
initializing cloud layers
Enabling ATI/AMD viewport hack
Configuration State
======= ==============
aircraft-dir = "/home/jackyb/Simulation/Autres_avions/Cessna337"
fghome-dir = "Path "/home/jackyb/.fgfs""
download-dir = "/home/jackyb/.fgfs"
terrasync-dir = "/home/jackyb/.fgfs/TerraSync"
aircraft-search-paths = 
	/home/jackyb/Simulation/Autres_avions
scenery-search-paths = 
	/home/jackyb/.fgfs/TerraSync
nouveau
Gallium 0.4 on NVA5
3.0 Mesa 17.0.7
1.30
Splash screen progress loading-aircraft-list
Starting automatic scenery download/synchronization to '/home/jackyb/.fgfs/TerraSync'.
Splash screen progress loading-nav-dat
Splash screen progress init-scenery
picking entry # 2, server is http://dream.t3r.de/fgscenery
terrasync scenery provider of the day is 'http://dream.t3r.de/fgscenery'
General Initialization
======= ==============
FG_ROOT = "Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata""

Attempting to set starting position for LFNG:33
Requested to start on LFNG/33, MP is enabled so computing hold short position to avoid runway incursion
Reading timezone info from: Path "/home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Timezone/zone.tab"
Selected scenery is tilecache
FGStgTerrain::init - init tilemgr
Initializing Tile Manager subsystem.
Initializing the tile cache.
  max cache size = 100
  current cache size = 0
  done with init()
Splash screen progress finalize-position
Splash screen progress creating-subsystems
Creating Subsystems
========== ==========
sync of http://dream.t3r.de/fgscenery/Models started, queue size is 26
Reading materials from /home/jackyb/Simulation/FGFS-2017-4/install/flightgear/fgdata/Materials/regions/materials.xml
Successfully synchronized directory 'Models'
sync of http://dream.t3r.de/fgscenery/Airports/L started, queue size is 25
Successfully synchronized directory 'Airports/L'
sync of http://dream.t3r.de/fgscenery/Airports/K started, queue size is 24
Successfully synchronized directory 'Airports/K'
sync of http://dream.t3r.de/fgscenery/Airports/J started, queue size is 23
Successfully synchronized directory 'Airports/J'
sync of http://dream.t3r.de/fgscenery/Airports/I started, queue size is 22
Reading systems from Path "/home/jackyb/Simulation/Autres_avions/Cessna337/Systems/Cessna337-systems.xml"
Successfully synchronized directory 'Airports/I'
sync of http://dream.t3r.de/fgscenery/Airports/H started, queue size is 21
Initializing HUD Instrument
Reading sound sound from Path "/home/jackyb/Simulation/Autres_avions/Cessna337/Cessna337-sound.xml"
Creating subsystems took:3852
Splash screen progress binding-subsystems
Multiplayer mode active!
Failed to load file: "Aircraft\Cessna337\Models\Lights\Beacon.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\NavL.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\NavR.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\NavBack.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\LandingLights.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\LandingLights.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\taxi.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\Strobe.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\Strobe.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\Beacon.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\NavL.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\NavR.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\NavBack.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\LandingLights.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\LandingLights.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\taxi.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\Strobe.xml"
Failed to load file: "Aircraft\Cessna337\Models\Lights\Strobe.xml"
Volcanic activity off.
initialising the mp lag system

MODEL INFO: Cessna 337G Skymaster
---------------------------------
Type: Two-engine aircraft (civilian version)
Powerplant: 2 Continental IO-360-C piston engines in a push-pull line configuration, 210HP each one
Capacity: 1 pilot and 5 passengers
---
Tipo: Avioneta bimotor (version civil)
Planta motriz: 2 motores a piston Continental IO-360-C de 210HP cada uno, de configuracion tira-empuje en linea
Capacidad: 1 piloto y 5 pasajeros

Authors/Autores: Fernando Espinosa y Pavel Cueto
February/Febrero 2012
Emergency Locator Transmitter (ELT) loaded
Navomatic 400A Autopilot Loaded
KN62A DME #0 loaded
KT76A Transponder #0 loaded
Hobbs Meter #0 loaded
AL lib: (WW) FreeContext: (0x1c37e040) Deleting 1 Source(s)
AL lib: (WW) FreeDevice: (0x1ec1e9e0) Deleting 20 Buffer(s)

Il reste du travail ...


Linux Mint 18.2 Sonia   FG2017.4  Nvidia 220   4G ram    Extreme 3D pro

Hors ligne

#49 12/11/2017 10:03:39

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 202

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2017.4.0 Git.

Hors ligne

#50 12/11/2017 10:47:06

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 228

Re : [RESOLU] Échec compilation sous Mint 18 : bibliothèques non trouvées

Bonjour,

JackyB a écrit :

Il reste du travail ...

Oui mais tant que ça progresse... wink
Le lanceur intégré de fg est en plein développement, il y a des avancées et aussi des reculs.

Lors du lancement du CitationX il y a une option qui n'a pas passé. A voir si c'est lié à cet avion ou à d'autres aussi.
Tu n'aurais pas un fichier .fgfsrc qui traîne? Il peut y avoir conflit avec le lanceur.

Personnellement je n'utilise pas de lanceur graphique. Avec un fichier ".fgfsrc" bien renseigné fg démarre toujours et les adaptations sont rapides.
Chacun ses habitudes.
Je constate que par le lanceur la console est beaucoup plus bavarde. Je pense que quelques logs seront supprimés un fois le développement abouti.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

Pied de page des forums