Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#1 4/02/2016 10:44:59

BryanBZH
Membre
Inscription : 4/02/2016
Messages : 4

Flightgear reste bloqué

Bonjour, je viens solliciter votre aide pour un problème assez gênant.
Après avoir câblé mon Arduino Uno à un bouton et configuré ce dernier à Flightgear, ce dernier reste bloqué sur "Finalisation de la position" puis après il reste en "ne répond pas". Les informations de type "out" fonctionnent mais de type "in" font crasher Flightgear.

Mon schéma de câblage de l'Arduino Uno :

FGFS_basics_pushbutton.jpg

Ce que je met dans l'IDE Arduino :

void setup() {
  Serial.begin(9600);
  pinMode(7, INPUT);
}
 
void loop() {
  int sensorValue = digitalRead(7);
  Serial.println(sensorValue);
}

Fichier XML :

<?xml version="1.0"?>
<PropertyList>
 <generic>
  <input>

   <line_separator>carriagereturn</line_separator>
   <var_separator>,</var_separator>

   <chunk>
    <name>GearDown</name>
    <node>/controls/gear/gear-down</node>
    <type>bool</type>
   </chunk>

 </input>
 </generic>
</PropertyList>

Ligne de lancement :

fgfs.exe --generic=serial,in,30,\\.\COM21,9600,Arduino_GearDown_SerialInput

Console :

1454575411-console.jpg

Toute aide est la bienvenue ! smile

Cordialement, Bryan.


Windows 7 Professionel 64 bits
Intel Core i7-2760QM @ 2.40GHz
4Go RAM
Flightgear 3.4.0

Hors ligne

#2 5/02/2016 9:55:51

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 385

Re : Flightgear reste bloqué

Ben ton problème ne semble pas inspirer grand monde...

Va falloir un super ingénieur en électronique et un super programmeur pour te donner un coup de pouce !

Espérons que ça existe sur le forum !


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#3 5/02/2016 11:05:07

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 548

Re : Flightgear reste bloqué

Bonjour et bienvenue BryanBZH,
Ton bouton fonctionne bien dans la console Arduino (Arduino IDE's serial monitor)?
Ta ligne de lancement me paraît bizarre. Tu passes vraiment par un RS232 (COMxx) ou par usb?

Tu connais peut-être déjà?:
http://wiki.flightgear.org/Howto:Use_Ar … FlightGear

Note  Remember to unplug Arduino's USB cable and plug it back.

FlightGear will not be able to read serial without doing this!

You have to do this every time after you use the Arduino IDE.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#4 5/06/2018 13:00:15

kbumbaz
Membre
Lieu : NICE
Inscription : 4/06/2018
Messages : 3

Re : Flightgear reste bloqué

Bonjour BryanBZH, bonjour à tous,

Je me permet de déférer le sujet.

Avez vous un retour sur ce problème. J'ai le même et franchement, je ne peux pas croire que ca ne fonctionne pas et point.
D'autres post sur le forum de FG en parlent mais sans suite.

A coté de quoi passons nous ?

Pour ma part je test sous un Windows 10, avec un Arduino mega.

Merci pour vos retour.

PS : si besoin, je peux donner plus de détails.


Win10 / i8700K UHD630 / 16GB / FG2018

Hors ligne

Pied de page des forums