Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#1 2/07/2018 8:48:50

PatriKb
Membre
Lieu : LFGC
Inscription : 4/06/2018
Messages : 10

FGPanel: GLEW version 2.1 not supported : 1.13.0

Bonjour,

J'essaie de faire une config dans laquelle la machine principale (voir signature) est connectée à un video projecteur et rendrait la vue extérieure du cockpit, sans instrument.
publicpreview.php?x=1920&y=606&a=true&file=DSCF2324.JPG&t=GqeSsnffvXmg99o&scalingup=0
et le petit portable connecté à un écran de 15" rendrait les instruments et la stack radio.
Le portable est vieux et peu puissant, mais une représentation 2D me va très bien.

J'essaie FGPanel en suivant https://sourceforge.net/p/flightgear/fl … nel/README, mais le seul résultat que j'obtiens est:

fgpanel --fg-root=/usr/share/games/flightgear --panel=Aircraft/c172p/Panels/MyPanel.xml
GLEW version 2.1 not supported : 1.13.0

Le système sur le portable est Lubuntu 16.04 32b, fgfs est 2018.2.1, installé depuis ppa:saiarcot895 et libglew es bien 1.13.

Je ne suis pas sûr comprendre le message d'erreur, fgpanel pense que GLEW 2.1 est installé???
Toute idée ou un retour d’expérience sur fgpanel sont les bienvenus. smile


Linux Mint 18.3 / FG 2018.2.1 / AMD Athlon 2x2.5Ghz / NVidia GeForce GTX 1050Ti / 4G RAM / SSD+HDD

Hors ligne

#2 2/07/2018 10:11:39

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 390

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

J'ai plutôt l'impression qu'il voudrait une version plus récente de glew.
Mais pourquoi une version 2.1 ?
Je suis en 2.0 avec des paquets récents.

Mais une fois de plus, une solution pour avoir moins de problèmes, ou de les résoudre plus facilement, comme je le disais dans ta présentation, c'est de compiler.

Afin d'avoir un FG adapté à ton système (puisque créé sur le tien et non sur un autre), et dans un répertoire de ton dossier personnel, et indépendant de ton système.
Et non dans un répertoire de jeux (/usr/share/games) du système.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#3 2/07/2018 19:03:38

PatriKb
Membre
Lieu : LFGC
Inscription : 4/06/2018
Messages : 10

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

2.0 semble être en effet ce qu l'on peut trouver de plus récent dans les paquets les plus récents...

Je veux bien recompiler, pas de soucis smile, mais je ne suis pas trop sûr de comprendre en quoi ça va m'aider tant que que je ne modifie pas le code. Tu pourrais m'en dire plus stp?


Linux Mint 18.3 / FG 2018.2.1 / AMD Athlon 2x2.5Ghz / NVidia GeForce GTX 1050Ti / 4G RAM / SSD+HDD

Hors ligne

#4 4/07/2018 22:47:05

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 390

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

PatriKb a écrit :

Je veux bien recompiler, pas de soucis smile

Il me semble que tu n'as pas encore compilé...

FG est optimum quand il est créé à partir des sources sur son propre système (en particulier pour les versions de paquets).

Les membres sous GNU/Linux (la plupart sous Linux Mint), fonctionnent tous avec un FG compilé.
Je pense que tu trouveras plus facilement la compréhension des problèmes et de l'aide des connaisseurs avec ton FG.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#5 5/07/2018 8:14:04

PatriKb
Membre
Lieu : LFGC
Inscription : 4/06/2018
Messages : 10

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

Slt,

Je suis en train mais le script échoue lors de la récupération des DATA sur git, je n'ai pas encore cherché pourquoi/comment. Quelque chose autour de la connexion TLS, il faut que je creuse.

(pour tout dire, je suis comme le cordonnier le plus mal chaussé, je gère déjà des compils toute la journée, pas super motivé pour m'y remettre à la maison le soir tongue wink smile)


Linux Mint 18.3 / FG 2018.2.1 / AMD Athlon 2x2.5Ghz / NVidia GeForce GTX 1050Ti / 4G RAM / SSD+HDD

Hors ligne

#6 5/07/2018 9:20:25

Clm76
Membre
Lieu : LFOH
Inscription : 22/10/2012
Messages : 928

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

Bonjour,

PatriKb a écrit :

Je suis en train mais le script échoue lors de la récupération des DATA sur git, je n'ai pas encore cherché pourquoi/comment. Quelque chose autour de la connexion TLS, il faut que je creuse.

Pour éviter ce problème de déconnexion, tu copies le DATA d'une ancienne version sur ta nouvelle version puis tu compiles avec ceci :

./download_and_compile.sh -j12 DATA

ce qui va ne télécharger que les modifications intervenues depuis la dernière version, ce qui est infiniment moins long. smile


Fg 2018.3.0 - LinuxMint 18.3 Sylvia - CM Asus P8H67 MLE - CPU i3 2100T - 12 Go Ram - Nvidia Geforce GTX 770 - Driver Nvidia 384.130

Hors ligne

#7 5/07/2018 12:36:12

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 840

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

Bonjour

Il y a un problème récurrent avec l'adresse

_gitDownload https://git.code.sf.net/p/flightgear/fgdata

Celle-ci fonctionne (fonctionnait, au moins...)

_gitDownload git://git.code.sf.net/p/flightgear/fgdata

A changer dans d_&_c ("DATA"), ligne env. 614.

Pour toi, avec le script cela devrait être de la promenade, mais il y a parfois des obstacles.
Si des paquets manquent (évolutivité des libs demandées, cette adresse...) vois le tuto Script download_and_compile.sh ("Compléments éventuels suivant votre distribution"). J'essaie de le tenir à jour quand j'apprends quelque chose.

Dany


FG 2018.3.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.2.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#8 5/07/2018 18:25:46

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 390

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

PatriKb a écrit :

je gère déjà des compils toute la journée, pas super motivé pour m'y remettre à la maison le soir tongue wink smile

Je comprends.
Mais si tu gères des compils toute la journée, tu es le mieux placé pour savoir que c'est la bonne solution pour FG également.

Et tu n'auras à le faire qu'une fois.
Ou plutôt une fois de temps en temps si tu veux mettre à jour, en repassant le script par dessus, ce qui est rapide.

Quant au data, tu butes sur une difficulté devenue classique ces temps-ci, la solution t'a été donnée.

J'ajoute que si tu es spécialiste de la compil, ton aide nous sera précieuse en cas de besoin.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#9 8/07/2018 11:28:34

PatriKb
Membre
Lieu : LFGC
Inscription : 4/06/2018
Messages : 10

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

Bonjour,

voilà, compilé. smile

il semble que ce soit un soucis dans l'implémentation de GNUtls qui empêche de passer par https.

_gitDownload git://git.code.sf.net/...

fonctionne nickel, remplacé partout dans le script.

il manquait aussi une dépendance: libqt5svg5-dev, ajoutée dans la variable PKG de FG.

Merci pour votre aide. smile

Les sources de FGPanel sont bien là, mais le script ne les compile pas, faut que je regarde de plus près. Si vous avez un solution... smile

Je ne suis pas du tout du tout spécialiste de la compil sous Linux, je gère des projets aéros en C, de la cross-compilation sur des cibles uC/DSP. wink
Je peux aider au niveau code source, avec plaisir.


Linux Mint 18.3 / FG 2018.2.1 / AMD Athlon 2x2.5Ghz / NVidia GeForce GTX 1050Ti / 4G RAM / SSD+HDD

Hors ligne

#10 8/07/2018 12:29:53

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 840

Re : FGPanel: GLEW version 2.1 not supported : 1.13.0

PatriKb a écrit :

Les sources de FGPanel sont bien là, mais le script ne les compile pas, faut que je regarde de plus près. Si vous avez un solution... smile

Je ne suis pas du tout du tout spécialiste de la compil sous Linux

Et moi donc... hmm

Au cas où cela pourrait t'orienter, voici ce que j'ai appris très récemment, et pour un cas très ponctuel:

1 - J'ai modifié le fichier source fgfs/flightgear/src/FDM/JSBSim/models/propulsion/FGPropeller.cpp.
Évidemment, d_&_c.sh n'en tenait pas compte.

2 - Pour faire compiler avec ce changement, je me suis mis dans dans le dossier qui contient CMakeCache.txt, c'est-à dire
fgfs/build/flightgear/
En console, J'ai fait

make

(ou make clean puis make pour tout compiler).

3 - J'ai vérifié que l’Application fgfs  a été recompilée (voir sa date) dans build/flightgear/src/Main/

4 -  Depuis ce même  build/flightgear/src/Main/, J'ai ensuite lancé fgfs par ./fgfs en console (avec paramètres du fichier .fgfsrc, sinon par défaut)

N'ayant aucun recul, je ne peux t'en dire plus... Avec l'espoir que, compte tenu de ton niveau, tu pourras peut-être extrapoler ou adapter.


FG 2018.3.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 4Go DDR2, GEFORCE GTX 650 1GB, OSG 3.2.0
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

Pied de page des forums