Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#1 29/07/2018 16:50:14

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 555

Carte/pilote graphique non reconnu

Bonjour,
ça fait quelques temps que j'essaie de compiler terragear, mais ça coince...
Pour tester avec des paquets éventuellement plus récents que mint, j'ai installé Debian testing (Buster) + le pilote nvidia propriétaire (390.67)
Apparemment fg ne reconnait pas la cg (Geforce GTX 660)
captur10.png

Pourtant tout semble être-là:
captur11.png
$ nvidia-detect:

Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106 [GeForce GTX 660] [10de:11c0] (rev a1)

$ lspci | grep VGA

01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)

$ lspci -nn | egrep -i "3d|display|vga"

00:02.0 Display controller [0380]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0152] (rev 09)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK106 [GeForce GTX 660] [10de:11c0] (rev a1)

$ cat /proc/driver/nvidia/version

NVRM version: NVIDIA UNIX x86_64 Kernel Module  390.67  Fri Jun  1 04:04:27 PDT 2018
GCC version:  gcc version 7.3.0 (Debian 7.3.0-27)

Je loupe un truc, mais je ne vois pas ou... hmm
Si quelqu'un a une idée...

Tout fonctionne parfaitement sous Mint 18.3


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#2 29/07/2018 19:27:02

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 399

Re : Carte/pilote graphique non reconnu

Ci-joint pour comparer...

captur10.png

captur12.png

andre@debian:~$ nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)

Checking card:  NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
Your card is supported by all driver versions.
It is recommended to install the
    nvidia-driver
package.

andre@debian:~$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)

andre@debian:~$ lspci -nn | egrep -i "3d|display|vga"
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)

andre@debian:~$ lspci -nn | egrep -i "3d|display|vga"
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)
andre@debian:~$ 

Pour ma part, il m'a semblé à un moment donné, peut-être à tort, que le dernier pilote ne convenait pas bien à des cartes un peu plus anciennes.
Ce n'est pourtant pas ce que disent les messages.
Aussi je me suis limité à un pilote legacy 340 qui me semblait bien suffisant.

Je ne peux donc pas te donner un résultat comparatif avec un 390...


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#3 30/07/2018 7:59:03

Clm76
Membre
Lieu : LFOH
Inscription : 22/10/2012
Messages : 929

Re : Carte/pilote graphique non reconnu

Chez moi :

fgfs-s14.png
captur10.png

chris@chris ~ $ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 770] (rev a1)
chris@chris ~ $ lspci -nn | egrep -i "3d|display|vga"
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 770] [10de:1184] (rev a1)

Fg 2018.3.0 - LinuxMint 18.3 Sylvia - CM Asus P8H67 MLE - CPU i3 2100T - 12 Go Ram - Nvidia Geforce GTX 770 - Driver Nvidia 384.130

Hors ligne

#4 30/07/2018 20:14:27

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 555

Re : Carte/pilote graphique non reconnu

Merci pour vos retours, mais ça veut pas...
J'ai réinstallé à neuf avec Cinnamon, Gnome est tellement inbuvable...

Essayé le pilote 340, forcé le bios à utiliser la GTX660.
Il y a bien un truc OpenGL qui râle a la compilation, rapport à cmake >3.10, mais ça passe et j'ai trouvé la parade, ça ne change rien.

Maintenant fg ne se lance même plus:

getDefaultWindow: failed to create GraphicsContext

Je ne comprnds pas, les contrôles basics de cg et pilote semblent ok, pareil que dans mint.
Blender et Gimp affichent correctement.
Vais essayer une demo Xplane pour voir...


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#5 30/07/2018 22:51:41

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 399

Re : Carte/pilote graphique non reconnu

Bonsoir.

Ce qui m'intrigue ce sont les informations graphiques de FG.

Dans quoi as-tu fait ton essai d'installation de testing + FG ?

Dans une partition ou dans une machine virtuelle ? (VM ?)


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#6 31/07/2018 6:37:54

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 555

Re : Carte/pilote graphique non reconnu

Bonjour,
captur12.png
Ca marche... enfin ça marchouille, je n'ai pas d'affichage canvas?? Mais on y arrivera wink
Edit: canvas est apparu au 2e lancement, mystères de l'informatique!?

J'ai installé dans une partition, sur un disque dédié, enfin presque, différent de mint, mais ça n'a rien à voir.

Ca vient de "cmake version 3.11.2", une histoire de préférence de librairies opengl.
j'ai ajouté :

if(POLICY CMP0072)
       cmake_policy(SET CMP0072 OLD)
endif()

dans le "if(COMMAND cmake_policy)" au début des "CMakeLists.txt" de sg et fg. J'avais mis "NEW" sad
https://cmake.org/cmake/help/v3.11/policy/CMP0072.html

Reste plus qu'a réinstaller le pilote 390 wink

Dernière modification par ctesc356 (31/07/2018 6:58:41)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#7 31/07/2018 7:54:45

Clm76
Membre
Lieu : LFOH
Inscription : 22/10/2012
Messages : 929

Re : Carte/pilote graphique non reconnu

ctesc356 a écrit :

dans le "if(COMMAND cmake_policy)" au début des "CMakeLists.txt" de sg et fg. J'avais mis "NEW"

Ce qui est installé chez moi :
FG :

if(COMMAND cmake_policy)
   if(POLICY CMP0054)
       cmake_policy(SET CMP0054 NEW)
   endif()
   # Mac RPATH policy
   if(POLICY CMP0042)
       cmake_policy(SET CMP0042 NEW)
   endif()

    # AUTOMOC/AUTOUIC on generated files policy. Since we only
    # generate resource files with fgrcc which don't use Qt,
    # we set those files source property. See the help for this
    # policy for more info
    if(POLICY CMP0071)
        cmake_policy(SET CMP0071 NEW)
    endif()
endif()

Simgear :

if(COMMAND cmake_policy)
   if(POLICY CMP0054)
       cmake_policy(SET CMP0054 NEW)
   endif()
   if(POLICY CMP0042)
       cmake_policy(SET CMP0042 NEW)
   endif()
   if(POLICY CMP0067)
       cmake_policy(SET CMP0067 NEW)
   endif()
endif()

Fg 2018.3.0 - LinuxMint 18.3 Sylvia - CM Asus P8H67 MLE - CPU i3 2100T - 12 Go Ram - Nvidia Geforce GTX 770 - Driver Nvidia 384.130

Hors ligne

#8 31/07/2018 9:07:21

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 555

Re : Carte/pilote graphique non reconnu

Clm76 a écrit :

Ce qui est installé chez moi :

Oui c'est ce qui vient avec les sources. Tant que tu n'as pas cmake >3.10 c'est bon.
Avec debian testing on obtient cmake 3.11.2, avec mint 18.3 cmake 3.5.1


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#9 31/07/2018 9:18:04

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 399

Re : Carte/pilote graphique non reconnu

Pas compris.

Moi je suis en testing, j'ai cmake 3.11.2, et les mêmes en-têtes des "CMakeLists.txt" que Clm76.

Maintenant tu peux remettre un pilote 390.
Pas sûr que ça t'apporte de meilleures performances qu'un 340.

Et pour Terragear, tiens nous au courant...


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#10 31/07/2018 15:35:42

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 555

Re : Carte/pilote graphique non reconnu

f-toro a écrit :

Pas compris.

Moi je suis en testing, j'ai cmake 3.11.2, et les mêmes en-têtes des "CMakeLists.txt" que Clm76.

Si tu n'a pas fait une compilation à neuf depuis un certain temps, il reprend probablement le "makefile" existant, tant qu'il est cohérent.

Essaie de supprimer "/build" pour voir...  ou lance d&c dans un dossier vierge.

Tu n'as pas ce message dansles logs?

CMake Warning (dev) at /usr/share/cmake-3.11/Modules/FindOpenGL.cmake:270 (message):
  Policy CMP0072 is not set: FindOpenGL prefers GLVND by default when
  available.  Run "cmake --help-policy CMP0072" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  FindOpenGL found both a legacy GL library:

    OPENGL_gl_LIBRARY: /usr/lib/x86_64-linux-gnu/libGL.so

  and GLVND libraries for OpenGL and GLX:

    OPENGL_opengl_LIBRARY: /usr/lib/x86_64-linux-gnu/libOpenGL.so
    OPENGL_glx_LIBRARY: /usr/lib/x86_64-linux-gnu/libGLX.so

  OpenGL_GL_PREFERENCE has not been set to "GLVND" or "LEGACY", so for
  compatibility with CMake 3.10 and below the legacy GL library will be used.
Call Stack (most recent call first):
  CMakeLists.txt:230 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.

Edit: J'ai refait un fg neuf sans toucher les "CMakelists" et ça fonctionne... j'ai fait pareil hier, et rien a faire. Il y a des jours comme ça...  putain d'informatique roll

Dernière modification par ctesc356 (31/07/2018 17:55:09)


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#11 31/07/2018 23:05:20

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 399

Re : Carte/pilote graphique non reconnu

Je n'ai pas noté la date de ma dernière compilation, mais c'était tout au plus il y a une quinzaine de jours.
Et c'était une compilation neuve.

Et j'ai bien le message :

CMake Warning (dev) at /usr/share/cmake-3.11/Modules/FindOpenGL.cmake:270 (message):
  Policy CMP0072 is not set: FindOpenGL prefers GLVND by default when
  available.  Run "cmake --help-policy CMP0072" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  FindOpenGL found both a legacy GL library:

    OPENGL_gl_LIBRARY: /usr/lib/x86_64-linux-gnu/libGL.so

  and GLVND libraries for OpenGL and GLX:

    OPENGL_opengl_LIBRARY: /usr/lib/x86_64-linux-gnu/libOpenGL.so
    OPENGL_glx_LIBRARY: /usr/lib/x86_64-linux-gnu/libGLX.so

  OpenGL_GL_PREFERENCE has not been set to "GLVND" or "LEGACY", so for
  compatibility with CMake 3.10 and below the legacy GL library will be used.
Call Stack (most recent call first):
  CMakeLists.txt:229 (find_package)
This warning is for project developers.  Use -Wno-dev to suppress it.

mais je n'y ai prêté aucune attention, vu que la compilation s'est bien passée.
Par contre le mien indique la ligne 229 (j'ai pas été voir...).
En plus il me semble que c'est déjà ancien ce genre de message.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#12 1/08/2018 14:56:57

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 555

Re : Carte/pilote graphique non reconnu

Bon...  j'ai pas compris pourquoi la cg faisait grève hier.

Enfin, fg tourne... et l'autre bonne nouvelle: la compilation de terragear à passé et ça fonctionne.


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#13 1/08/2018 18:36:40

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 399

Re : Carte/pilote graphique non reconnu

ctesc356 a écrit :

la compilation de terragear à passé et ça fonctionne.

sous testing ! big_smile

A part ça, quelles genres de scènes tu vas nous générer avec ça ?


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

#14 1/08/2018 22:13:47

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 555

Re : Carte/pilote graphique non reconnu

f-toro a écrit :

sous testing ! big_smile

A part ça, quelles genres de scènes tu vas nous générer avec ça ?

Oui sous testing, sous mint il y a un petit rien qui coince smile
Ca fonctionnait il y a 2 ans et là, plus rien. Même la compil de 2016 qui fonctionnait encore parfaitement en début de cette année n'en veut plus.

Le but est d'arriver à comprendre la génération des fichiers btg. et à terme de pouvoir générer des altiports/altisurfaces avec des déclivités de pistes cohérentes, ou, au moins de générer le terrain autour sans "taupinière" qui gêne la pose d'un patch ac.
L'idéal serait de pouvoir intervenir sur les données d'altitude avant la génération du terrain. On verra ou j'arrive...


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#15 1/08/2018 23:00:41

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 399

Re : Carte/pilote graphique non reconnu

Voilà un objectif bien précis.

Bon courage !


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2018.3.0 Git.

Hors ligne

Pied de page des forums