Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#1 20/03/2019 15:50:22

GR
Membre
Inscription : 28/01/2019
Messages : 119

[RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,

Mon problème évoqué pour la première fois le 29-01-2019 n'a toujours pas été résolu ce qui limite quelque peu mes essais FG. Avec des manœuvres ultra douces et anticipées combinées à un usage plus important du compensateur de tangage j'arrive maintenant à faire des vols corrects (à mon sens tout au moins). Concernant l'hélicoptère c'est difficile en temps normal et là c'est impossible.

Je reviens donc sur le problème. Mon JS (SAITEK X52) est bien calibré en externe et après les réglages normaux inhérents à chaque simulateur que j'utilise j'obtiens les résultats incompréhensibles déjà évoqués :

- très forte asymétrie avec FG, FFS et AFS2;
- asymétrie "raisonnable" avec FSX et P3D;
- comportement excellent avec XP11.

J'espère que le rafraichissement de ce topic ouvrira la voie à d'autres pistes.
Je vous remercie d'avance.
Bien cordialement.
GR ma

PS Le remplacement de ce JS (déjà ancien) est prévu dans les semaines qui viennent mais j'aimerais bien comprendre cette différence de comportement.

Dernière modification par GR (16/07/2019 17:21:14)


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#2 20/03/2019 18:31:31

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 511

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Afin qu'on puisse s'y retrouver plus facilement, j'ai rajouté le lien vers la discussion d'origine.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2019.2.0 Git.

Hors ligne

#3 22/03/2019 17:29:34

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,
J'hésite à remettre ce topic dans la rubrique problème car il semblerait que cela ne soit pas un problème FG. Quoi qu'il en soit je suis maintenant bloqué sur FG car dès le démarrage le rudder se met en position -1 alors que le joystick est en position neutre. Une action sur le JS fait passer cette position à +1 quasiment instantanément et il y a retour à -1. C'est à n'y rien comprendre car ce même JS marche très bien sous XP. Le problème est identique sur plusieurs avions. J'ai essayé de mettre à 0 la variable 'binding' correspondante mais cela n'a aucun effet. Y a t'il d'autres tests que je pourrais faire ?
Désolé de vous importuner avec cette bizarrerie.
Bien cordialement
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#4 29/03/2019 12:52:52

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,

Le réglage 'rudder' est devenu complètement impossible (-1 dès le départ) et cela également sur AFS2 et FFS. Je vais donc changer le joystick très rapidement. Mais alors pourquoi n'y a t'il aucun problème avec XP11 et dans une moindre mesure avec FSX/P3D. Cette incohérence matériel/logiciel me tarabuste vraiment. Une (ou plusieurs) idée(s) ?

Le fait de brancher un JS USB 2 sur un port USB 3 peut il être la cause de ce dysfonctionnement ? Ce qui est bizarre est que ce problème n'est pas apparu tout de suite sur AFS2 et FFS alors que je l'ai rencontré immédiatement( du moins sous une forme atténuée) avec FlightGear.

Bien cordialement.
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#5 29/03/2019 13:33:53

ctesc356
Membre
Inscription : 18/05/2010
Messages : 2 715

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,
difficile à dire, surtout qu tu disais qu ça fonctionne sous w7?
Je ne connais pas Saitek, mais il me semble avoir lu qu'ils fournissent des pilotes pour leur matériel, du moins pour win. Y aurait pas un incompatibilité quelque part? Je ne pense pas que fg tienne compte de pilotes proprio? mais xplane ou p3?


Intel i5 3570 3.4Mhz, Nvidia GTX 660, 8Go Ram, Linux Mint

Hors ligne

#6 29/03/2019 17:13:38

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,

Merci pour ce commentaire. J'ai effectivement dit précédemment que cela marchait sous W7. Et bien ce n'est plus vrai, Je viens de vérifier que j'avais maintenant aussi le blocage du rudder à -1, ce qui est un indice supplémentaire qu'il y a également un problème matériel. Le pilote utilisé est le dernier récupéré sur le site officiel de Saitek tant pour W7 que pour W10. De plus je ne peux guère continuer des tests sous W7 la machine hôte étant bien trop ancienne (HP6730S). Je vais encore faire quelques recherches en attendant de commander/recevoir un nouveau Saitek 52 pro. Peut être aurais je d'ici la quelques pistes me confortant dans l'idée d'une défaillance matérielle (mais supportée et corrigée par XP).
Bien cordialement.
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#7 29/03/2019 20:11:47

rominet
Membre
Inscription : 23/03/2019
Messages : 61

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonsoir,

Le problème est assez bizarre et je n'ai pas grand-chose à suggérer de plus que ce qui a déjà été proposé. Je souhaite juste mentionner un outil de diagnostic pratique qui, je crois, n'est pas apparu dans ce fil : lancer FG avec l'ufo, appuyer sur 'h' afficher le HUD et faire joujou avec le joystick à tester. C'est complémentaire de la boîte de dialogue “Joystick Configuration” et permet d'apprécier visuellement la progressivité de la réponse sur tel ou tel axe. Je trouve cela utile par exemple pour régler les combinaisons de paramètres 'power' et 'factor'. Et pour s'assurer rapidement que tous les axes sont bien réglés en cas de doute.


Debian GNU/Linux, driver libre pour carte Radeon HD 4670, FG 'next', 8 Go de RAM

Hors ligne

#8 30/03/2019 11:27:43

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,

J’ai mis en œuvre la suggestion d’utiliser l’UFO comme aide au diagnostic. C’est effectivement très intéressant. J’ai fait 3 petites vidéos illustrant les résultats obtenus.

La première vidéo montre bien le comportement des 4 axes principaux du JS :
-    Comportement normal pour l’axe « throttle » ;
-    Comportement normal pour l’axe roulis ;
-    Comportement semi normal pour l’axe tangage. En montée le débattement est progressif et en descente il est plutôt brutal. C’est d’ailleurs ce comportement que j’ai observé lors de ma première utilisation de FG et qui a fait l’objet de mon premier post ;
-    Comportement complètement anormal de l’axe « rudder ». Dès le départ il est bloqué à -10 sur le HUD. Cette anomalie n’est présente que depuis peu de temps.

La deuxième vidéo m’a un peu surpris mais vous devriez en avoir l’explication. Un clic gauche de souris sur l’écran amène des formes 3D très agrandies. Ceci ne se produit qu’avec l’UFO.

La troisième vidéo, toujours avec l’UFO, est également bizarre (pour moi tout au moins). Dès le démarrage alors que le mode pause est encore actif la scène est animée d’un mouvement incontrôlable. Je suis alors obligé de quitter le simulateur. Il est à noter que ce problème se présente maintenant chaque fois que je veux démarrer avec l’UFO.
La première fois qu’il y a eu ce mouvement de scène tout était statique avec le HUD présent. Le mouvement de scène est apparu après une action sur un bouton du joystick. C’est d’ailleurs ce problème que je voulais capturer en vidéo mais je ne suis pas arrivé à le reproduire après 4 essais et un restart du PC.

J’espère que cela vous donnera quelques indications pour aider au diagnostic. Il est fort probable que ce problème ne soit pas directement lié à FG et alors je suis désolé de vous importuner avec ça mais à cause du bon comportement sous XP11 et FSX/P3D je ne peux pas tout mettre sur le dos d’une défaillance matérielle car je ne suis pas complètement assuré que le problème disparaîtra avec un nouveau joystick.

Merci encore pour votre aide.
Bien cordialement.
GR

Vidéo 1 : comportement des axes principaux
https://www.dropbox.com/s/4mr6pb4hwlgp5 … 1.mp4?dl=0

Vidéo 2 : Ajout de formes 3D après un clic gauche de la souris
https://www.dropbox.com/s/urp7udv2hye4a … 2.mp4?dl=0

Vidéo 3 : Mouvements de scène incontrôlables
https://www.dropbox.com/s/1m72m5j71ly82 … 3.mp4?dl=0


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#9 30/03/2019 11:55:03

rominet
Membre
Inscription : 23/03/2019
Messages : 61

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

En fait, la méthode doit être valable avec tout aéronef du moment que l'on sait faire apparaître le HUD par défaut de FG, par opposition à un HUD spécifique de l'aéronef. Disons qu'avec l'ufo, je suis sûr que quand tu fais 'h', c'est bien ce HUD qui est affiché.

Concernant les « formes 3D très agrandies », c'est normal, effectivement : l'ufo peut être utilisé pour placer des objets au sein du paysage. On peut placer comme tu as fait, et ensuite récupérer les coordonnées des objets ainsi « virtuellement placés » pour les mettre au bon endroit (fichiers .stg si je me souviens bien), avec mention du bon fichier, etc.

Quant au problème qui fait l'objet du fil, je me demande : n'y aurait-il pas un paramétrage du joystick spécifique à telle ou telle application, non pas dans FG mais soit au niveau de la config « contrôleurs de jeu » Windows, soit au niveau du driver Saitek (je précise que je ne connais ni l'un ni l'autre). Ceci pourrait expliquer que tu aies un bon fonctionnement sur certaines applis et pas d'autre, ainsi qu'en testant sur un autre ordi ou un autre OS.

Pour tester sous Linux sans installer de distribution Linux, il y a en principe la possibilité d'utiliser un Live DVD. En 2012, j'avais testé FG sur Debian Live 'unstable' de cette façon, mais je ne suis pas sûr que Debian Live soit bien maintenue aujourd'hui (à vérifier). Cette façon de faire n'est pas terrible pour une vraie utilisation de FG car le système Live est chargé en RAM, donc il mange pas mal de ressources bien utiles pour FG, mais pour tester ce genre de truc, ça doit marcher, à supposer que le tout est encore bien maintenu. Je mentionne la possibilité, mais je ne garantis pas que c'est simple sans expérience préalable avec Linux (par exemple, si on veut des aéronefs et des payages persistants d'un boot à l'autre, il faut bien savoir les mettre sur un disque dur et non en RAM, et amener FG à les utiliser ; mais pour juste-un-test-de-joystick, on peut sans doute s'en passer).

P.S. : pour les mouvements de scène incontrôlables, essaie de 1) déplacer un peu le joystick pour éliminer tout pb d'init et 2) d'appuyer sur la touche 5 du pavé numérique pour « recentrer les contrôles » (je parle comme un gourou tongue).

Dernière modification par rominet (30/03/2019 11:57:41)


Debian GNU/Linux, driver libre pour carte Radeon HD 4670, FG 'next', 8 Go de RAM

Hors ligne

#10 30/03/2019 17:20:38

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,

Merci pour les dernières infos. J'ai fait des recherches sur le site Saitek et n'ai rien vu (ou pas su voir) des informations relatives à des réglages spécifiques liés à FG. D'ailleurs FG ne figure pas dans la liste officielle des logiciels compatibles bien que j'ai pu voir dans le forum que ce JS (la version pro tout au moins) était bien présent sur ce simulateur. Je pourrais reprendre des tests sous ubuntu mais la machine hôte est bien trop ancienne (c'est la même que pour W7 via un dual boot).

Les mouvements de scènes incontrôlables ne sont pas arrêtés par un mouvement du JS ou une action sur la touche 5 du pavé numérique. Par contre cette touche est très pratique pour mettre au neutre toutes les gouvernes et surtout le "rudder" qui resterait autrement bloqué sur -1. Cela permet, à condition de ne pas toucher à cette gouverne, de faire des vols 'presque' normaux mais il est clair que ce n'est pas la solution, cette solution ne pouvant vraisemblablement venir que d'un remplacement du JS.

Je reste à l'écoute de vos suggestions.
Bien cordialement.
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#11 30/03/2019 18:14:34

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 996

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour GR,

Désolé, je ne t'apporte pas de solution...

Mais ce que j'ai connu plaide en faveur d'une usure des potards ou d'un dysfonctionnement logiciel du JS.
Avec un JS ancien (Thrusmaster T-Flight Stick X) j'ai eu une période ou la zone morte en torsion débloquait de manière aléatoire, à l’allumage et au cours d'un même journée. Bien que la torsion ne soit pas l'axe le plus sollicité (je m'en servais pour la vue, j'ai un palonnier). Aussi, souvent bruiteux près du centre (classique potentiomètres). Ceci se voyait immédiatement (sans inertie) pour la vue qui tournait et tremblait. Et zone morte décalée veut dire sensibilité exacerbée dans la course qui reste... Je n'en étais pas au point d'être à +1 comme toi mais....
Et si j'écris "aléatoire", c'est bien parce que je n'ai pas réussi à trouver de corrélation entre mon comportement (manière de mettre en fonction) et les pannes, mes essais de calibration ont été aussi inutiles.
Par contre, ceci n'explique pas les différences d'un OS ou d'un simulateur à l'autre chez toi.

En résumé, j'espère que pour toi c'est un problème similaire qui s'oubliera avec un nouveau JS.

Les formes 3D, c'est normal, c'est le curseur de l'UFO.

Même avec un JS qui fonctionne, l'état initial au lancement de FG est souvent extrême (rudder ou un axe à fond). Mais ça s'arrange au premier mouvement.

Si tu avais la possibilité de tester la linéarité des potentiomètres avec un ohmmètre, tu aurais peut-être des réponses. JS débranché évidemment, mais attention quand même : sans dessouder, il y a un risque de destruction de l'électronique logique, alors à faire quand tu auras l'autre, par curiosité.


FG 2019.2.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.2
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#12 31/03/2019 11:11:49

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,

Le résultat d'un autre test : j'ai branché le JS sur un HUB USB 3.0 'powered' et pour les simulateurs FFS et AFS2 qui présentaient des problèmes similaires à FG le comportement du JS s'est nettement amélioré. Il est toujours aussi bon pour XP11 et FSX/P3D. Par contre FG ne reconnait pas le JS . le champ correspondant est vide. Il n'y a reconnaissance que si le JS branché sur un HUB USB 2 lui même évidemment branché sur un USB 3 puisque mon PC n'en a pas d'autres. Peut être devrais je faire un autre essai en modifiant la fonctionnalité xHCI dans le BIOS mais ces manipulations ne me rassurent guère.
Bien cordialement
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#13 4/04/2019 10:41:14

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,
J'ai vu que ce topic avait été déplacé dans la rubrique matériel. N'ayant pas trouvé cette rubrique je reprends ici. J'ai suivi le conseil qui m'a été donné à la réponse précédente (qui est où ?) et j'ai voulu changer le pilote pour un ancien Saitek. J'ai fait une erreur et ai pris un pilote X52 HOTAS : maintenant FG reconnait mon JS "SAITEK X52 Flight Control system" comme étant un HOTAS et je peux pas revenir en arrière. J'ai essayé de changer dans les emplacements normalement dédiés (../input/joystick, ../roaming/...) mais cela n'a rien donné. Merci de m'indiquer quelle est la bonne procédure.
Bien cordialement
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#14 4/04/2019 11:48:43

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 511

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

GR a écrit :

J'ai vu que ce topic avait été déplacé dans la rubrique matériel.

   ?

Il n'a effectivement pas pu être déplacé dans une rubrique qui n'existe pas.

De quel topic veux-tu exactement parler ?
Rien n'a été déplacé depuis ta dernière réponse, dimanche dernier.

Par contre il est vrai que tu avais ouvert une première discussion dans la rubrique "Problèmes".
Puis, curieusement, tu as choisi d'en ouvrir une deuxième dans la rubrique "Hors sujet".
Pour la cohérence du suivi de ton problème, il aurait mieux valu que tu continues tes remarques dans la discussion d'origine.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2019.2.0 Git.

Hors ligne

#15 4/04/2019 12:01:31

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,
Autant pour moi, cela doit être l'âge (74). Le message de déplacement m'a été notifié sur un autre forum où j'ai posté sur ce sujet qui commence à me prendre la tête. Veuillez m'excuser. Néanmoins ma question demeure : comment faire en sorte que FG retrouve le "Saitek X52 flight control" qui maintenant est devenu "X52 HOTAS" ?
Bien cordialement
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#16 4/04/2019 12:07:05

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 996

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,

Est-ce FlightGear qui le reconnaît comme HOTAS, ou Windows en amont qui reçoit ce nom, et le transmet à FG ?
Voir Windows,
Panneau de configuration, ... quelque chose comme Périphériques et Imprimantes ?, "Contrôleurs de jeu"... l’utilitaire de test, qui devrait te donner ce nom.
Si c'est ça, il faudra sans doute désinstaller ton pilote pour un autre. FlightGear est en aval.


FG 2019.2.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.2
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#17 4/04/2019 12:41:23

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,
Apparemment c'est encore plus compliqué : le nom de l'icône est correct (Saitek X52 Flight Control System) mais dans propriétés le nom est "X52 HOTAS". Le pilote installé correspond bien au Saitek ainsi que vérifié dans Device Manager.
Bien cordialement
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#18 4/04/2019 16:04:36

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 996

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Et est-il reconnu par FG ? Que donnent tes commandes vu de FG ? Parce que finalement....

Aussi, c'est pas pour faire de la provocation mais, même sous Windows, je ne crois pas avoir installé de pilotes. Installé tout seul au branchement pour mon palonnier Saitek, et pas de souvenir d'installation explicite de pilote pour mon premier JS Thrustmaster. Ni pour mon deuxième sous Linux, d'ailleurs.


FG 2019.2.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.2
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#19 4/04/2019 16:53:48

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,
Il est effectivement reconnu par FG mais cela ne marche toujours pas. N'ayant pas de chance avec Windows ou n'étant pas doué (ou les deux à la fois) je vais arrêter de vous embêter avec cà, En tous cas merci pour votre aide et à bientôt j'espère pour des problèmes moins stupides.
Bien cordialement.
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#20 13/04/2019 21:45:20

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonsoir,

Ma saga Saitek se termine car suite à une erreur (j'ai voulu procéder à une désinstallation / réinstallation) le JS ne peut plus fonctionner sous W10 (il continue à bien marcher sous W7). J'ai alors une double question :

1) que pensez vous pour FG du joystick MK II de VKBSim ? Il me paraît séduisant avec en plus l'avantage de ne pas avoir besoin de pilote et
2) bien que le JS Sidewinder de MS soit référencé dans data de FG il n'est absolument pas vu. Que faire pour y remédier ? C'est un très ancien JS qui marche encore très bien, notamment encore et toujours avec XP11, et je voulais le reprendre comme solution d'attente pour FG.

Merci encore pour vos commentaires.
Bien cordialement
GR

Dernière modification par GR (13/04/2019 21:45:53)


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#21 14/04/2019 18:18:14

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 996

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour GR,

désinstallation / réinstallation : de FG ? Ne devrait pas empêcher d'être vu et de fonctionner, au moins pour Windows (10 ou autre). Pour FG non plus, d’ailleurs... Peut-être un peu de ménage à faire pour FG (Roaming ?) si ton installation précédente était désordonnée.
Si tu trouvais, tu aurais probablement intérêt à désinstaller le pilote que tu as pour ton Saitek à problèmes. En n'oubliant pas que, souvent, un changement de pilote n'est pris en compte qu'après redémarrage de l'ordi. Maintenant, si le JS est HS (il ne semblait pas péter la santé), bof...

MK II de VKBSim : je ne connais pas, mais si je comprends bien c'est une technologie sans contacts (habituellement effet Hall ?), ce qui élimine le problème des potentiomètres qui deviennent bruiteux à l'usage. De plus, il semble 32 bits, ce qui donne une bonne résolution (précision).
Je dis ça vu de loin, avec ce que j'ai lu... tongue
Par contre, je ne le vois pas dans la liste FG. Contournable mais moins facile. Faut encore mettre les mains dans le cambouis... hmm. Fichier Flightgear/data/joystick.xml. Normalement on peut t'aider, mais quand je vois l'expérience précédente je suis un peu inquiet.

Tu te focalises sur la nécessité de pilote mais je te rappelle que, pour mes trois JS (dont deux installés quand j'étais encore sous Windows) je n'ai jamais installé de pilote. Souvent, le pilote se charge au premier branchement de l'USB (comme les souris). Je me demande si leur software dit "pilote" n'est pas simplement un utilitaire pour faciliter les personnalisations ou calibrages. Un JS c'est très standard et les signaux envoyés à l'USB sont semblables pour tous : des axes de -1 à +1 et des boutons 0 ou 1. Au pire pour compliquer, des combinaisons de boutons. Non obligatoires pour pouvoir l'utiliser.

Sidewinder de MS : est-il vu pour commencer par Windows ("Contrôleurs de jeux") ? Si oui, il devrait être reconnu par FG grâce au nom qu'il fournit à Windows.
S'il fonctionne vu de Windows "Contrôleurs de jeux" et si tu tiens à essayer de le faire fonctionner sous FG, il y a des choses à regarder et à essayer (on peut forcer FG à lire un fichier JS truc.xml par son chemin, même s'il n'est pas reconnu par son nom (ce qui est de plus en plus rare). "Microsoft SideWinder Joystick" ? "Microsoft SideWinder 3D Pro" ?


FG 2019.2.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.2
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#22 14/04/2019 19:00:22

Clm76
Membre
Lieu : LFOH
Inscription : 22/10/2012
Messages : 1 043

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Sidewinder de MS : C’est celui que j’utilisais sous Windows (XP) et que j’utilise toujours sous Linux pour tous mes essais du Citation X. Aussi bien avec Windows que Linux, je n’ai jamais eu besoin de pilote ni de parametrage, si ce n’est la programmation des quelques boutons.


Fg 2019.2.0 - LinuxMint 19.1 Tessa - CM Asus P8H67 MLE - CPU i3 2100T - 12 Go Ram - Nvidia Geforce GTX 770 - Driver Nvidia 384.130
+ Hp notebook-15-da0118nf -  CPU i3-7020u - Ram 4Go - Intel Graphics 620.

Hors ligne

#23 14/04/2019 23:55:51

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonsoir,

Il est clair que l’on n’est jamais assez précis quand on écrit. L’opération de désinstallation / réinstallation à laquelle je faisais allusion concernait le Joystick. Je pensais, à tort apparemment, qu’une remise logicielle à zéro pourrait être bénéfique. N’oublions pas que ce JS ne présente aucun défaut matériel : il fonctionnait à merveille avec la plupart de mes simulateurs sous W10 et également sous W7 avec FS9 et FSX. A l’issu de cette désinstallation il n’a plus été possible de le réinstaller (CD d’installation ne marchant que sous Window XP, d’ailleurs je me demande comment j’ai pu le faire marcher lors du passage HP W7 à ALW W10).

D’où mes questions sur MK II et Sidewinder. Cet ancien JS Microsoft est parfaitement reconnu par Windows 10 (cf la copie d'écran) et je sais bien qu’il n’a jamais eu besoin de pilote. Je l’ai seulement branché et après les réglages habituels il a parfaitement fonctionné sur tous mes simulateurs sauf FG (qui m’en veut vraiment) pour lequel il n’y a aucune reconnaissance (cf la deuxième copie d'écran). J’ai même renommé le fichier XML correspondant dans le répertoire data/input/joystick/Microsoft pour qu’il ait le même nom que celui indiqué dans le panneau de contrôle W.

Il doit y avoir d’autres manipulations à faire pour arriver à ce que cet ancien JS soit reconnu. Je compte également sur vous pour les manipulations éventuellement à venir dans l’hypothèse du choix du MK II.

Bien cordialement
GR

https://www.dropbox.com/s/vt352t0jm81y3 … 9.jpg?dl=0

https://www.dropbox.com/s/66sqtl74zqya0 … 9.jpg?dl=0


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

#24 15/04/2019 10:42:17

dany93
Administrateur
Lieu : Région Parisienne
Inscription : 5/07/2009
Messages : 2 996

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

GR a écrit :

J’ai même renommé le fichier XML correspondant dans le répertoire data/input/joystick/Microsoft pour qu’il ait le même nom que celui indiqué dans le panneau de contrôle W.

1 - Ce n'est pas le "nom" de fichier sindewinder.xml ou autre qu'il faut changer. Ce nom est secondaire, à ton choix.
FG reconnaît automatiquement un JS par le <name> s'il correspond dans le fichier.

Essaie, dans le fichier qui t'intéresse, d'ajouter une ligne avec le nom donné par ton JS à Windows, pour donner ça :

<PropertyList>

 <name>Microsoft SideWinder Joystick</name>
 <name>SideWinder Joystick</name>

Exactement, avec les espaces au milieu, éventuellement à droite, à gauche. (j'ai recopié visuellement ta copie d'écran)

Ce qui m'ennuie est que, en l'absence de reconnaissance par le <name>, FG devrait lire et lui appliquer un fichier Default.... Je me demande effectivement s'il le voit tout court.... On n'en sort pas. Cette réticence de FG à voir tes JS est vraiment inhabituelle.
Je suppose que tu as essayé "Reset Configuration" et "Refresh Joysticks".

Si tu pouvais lancer js_demo.exe (qui devrait être sous FlightGear/bin ou FlightGear/bin/Win32), on aurait peut-être une info supplémentaire pour ce (défaut de ?) nom vu de FG en amont de tout fichier de configuration. S'il est vu par js_demo, cela ouvre beaucoup d'espoir pour continuer.

2 - Saitek : Je suppose que tu as redémarré ton PC depuis la désinstallation de pilote Saitek. As-tu essayé en débranchant - rebranchant le JS ?
Comme tu le supposais, la désinstallation du pilote Saitek n'aurait pas dû créer de problème (au contraire dans ton cas). De toutes façons au premier branchement USB, le pilote (au moins un pilote minimal) devrait se charger automatiquement.

.... il n’a plus été possible de le réinstaller (CD d’installation ne marchant que sous Window XP, d’ailleurs je me demande comment j’ai pu le faire marcher lors du passage HP W7 à ALW W10)

Ne serait-ce pas un indice qu'il n'y a pas besoin d'installer un pilote ?

3 - A tout hasard, lis cette discussion Adieu Joysitcks au cas où...

4 - Après réinstallation de FG : As-tu bien nettoyé ton fichier <User>/../AppData/Roaming de tout FlightGear ? Au moins et surtout d'un éventuel fichier de commande mon-joystick.xml (par précaution, en déplaçant seulement le dossier dans un premier temps).
Ce fichier conserve tes infos personnelles d'une version à l'autre (en bien ou en mal). S'il n’existe pas, il est automatiquement créé au premier démarrage ou lors de la sortie propre (pas par la croix) de FG.


FG 2019.2.0, Linux Mint 18 (64b), Quad Q6600 (2.4 GHz), RAM 8Go DDR2, GEFORCE GTX 650 1GB, OSG 3.4.2
Boeing 787-8 (YASim, avec nickyivyca, aco)
DR400 JSBSim (PAF)
DC3 JSBSim (PAF)

Hors ligne

#25 15/04/2019 13:12:57

GR
Membre
Inscription : 28/01/2019
Messages : 119

Re : [RESOLU]Retour sur le problème d'asymétrie des réponses gouvernes

Bonjour,

Cette mise en conformité du nom dans le fichier XML avec le nom donné par Windows n’a strictement rien changé. J’ai aussi essayé de changer ce nom via la commande /, en vain.

Une information supplémentaire : sous W7 et flightgear 2018.3.1 le joystick est bien reconnu. Le nom dans le fichier XML est « SideWinder Joystick » et après les réglages le fichier « SideWinder- Joystick.xml » a bien été créé dans « roaming ».  A noter que le nom dans le fichier sidewinder.xml dans « ..\data\Input\Joystick\Microsoft » est « Microsoft SideWinder Joystick ».

Une question cependant : comment activer le mode « auto rudder » puisque ce JS ne possède pas la torsion du manche ?

Sous W10 je n'ai pas fait de réinstallation de Flightgear 2018.3.2 et le dossier roaming\flightgear.org\..ne comporte aucun fichier de type joystick. Le fichier JS_demo.exe n'est visible nulle part (le dossier Win32 n'existe d'ailleurs pas). Peut être serait il judicieux de procéder à cette réinstallation ?

Tu as raison il y a vraiment de quoi être inquiet si je choisis un nouveau joystick qui n'est pas dans la base officielle.
Désolé pour la perte de temps.
Bien cordialement
GR


Alienware 15R3, W10 Home, core i7 6700hq, 32 GB RAM, SSD 512 GB, HDD 1 TB, Nvidia GTX 1060, T16000M et TWCS
FlightGear 2018.3.2 (+ autres simulateurs)

Hors ligne

Pied de page des forums