Forum Flightgear France

Une communauté prend son envol

Vous n'êtes pas identifié(e).

Annonce

Futur nouvel inscrit, tu dois au préalable lire l'intégralité des 10 articles des règles, s'il te plaît. Tout nouveau compte qui ne respecte pas les règles sera supprimé par l'administration.

#26 16/04/2021 17:50:04

Clm76
Membre
Lieu : LFOH
Inscription : 22/10/2012
Messages : 1 419

Re : Nouvelle erreur de compilation en next...

f-toro a écrit :

Oui, mais avec quelle version de gcc ?

Voici ce qui est installé chez moi :
gcc10.png


Fg 2020.2.1 et 2020.4.0 - Linux Mint 20.1 Ulyssa - Cinnamon et Mate en dual boot - CM Asus P8H67 MLE - CPU i7 3770K - 12 Go Ram - Nvidia Geforce GTX 1660TI - Driver Nvidia 460.67
+ Hp notebook-15 - Linux Mint 20.1 Ulyssa -  CPU i3-7020u - Ram 4Go - Intel Graphics 620.

Hors ligne

#27 16/04/2021 18:35:46

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 846

Re : Nouvelle erreur de compilation en next...

Le premier paquet en haut, gcc, version installée 4.9.3.0-1ubuntu2, donc manifestement gcc-9.

Donc, ça passe.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2020.4.0 Git.

Hors ligne

#28 5/06/2021 9:01:25

jdt37b
Membre
Inscription : 14/08/2020
Messages : 48

Re : Nouvelle erreur de compilation en next...

Bonjour à tous,

Problème du même genre aujourd'hui.
En compilant "FGFS" en "next" avec Xubuntu 20.04 (OSG 3.6.4 pris dans les dépôts)  :

Les paquets suivants contiennent des dépendances non satisfaites :
 libudev-dev : Dépend: libudev1 (= 245.4-4ubuntu3) mais 245.4-4ubuntu3.6 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

(nb : la compil de "SIMGEAR" et "DATA" s'est bien terminée.)

Dans Synaptic : "libudev-dev 245.4-4ubuntu3" n'est pas installé mais "libudev1 245.4-4ubuntu3.6" l'est.
Si je veux installer libudev-dev :

"dépend : libudev1 (=245.4-4ubuntu3) mais 245.4-4ubuntu3.6 doit être installé"

Si je tente de supprimer "libudev1 245.4-4ubuntu3.6" pour le réinstaller, une foultitude de modules est à  supprimer !

Une solution pour pouvoir compiler et remettre les paquets d'aplomb (un paquet cassé)  ?
Merci d'avance.


Acer XC330 - Xubuntu 18.04 LTS (FG 2020.3.8, compilé avec options CC=gcc-8 et CXX=g++-8, OSG 3.4.1) - Carte AMD Radeon R5 5 - RAM  4 Go - Processeur AMD A9-9420

Hors ligne

#29 5/06/2021 9:31:28

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 846

Re : Nouvelle erreur de compilation en next...

Non, ce n'est pas le même problème (version de gcc).

C'est une incompatibilité entre les deux paquets qui ne sont pas de même version.
Chez moi ces deux paquets sont en version 247.3-5 (quelle version sur la dernière Mint ?).

Ce qu'il te faudrait c'est installer libudev-dev 245.4-4ubuntu3.6, qui sera cohérent avec libudev1 245.4-4ubuntu3.6, mais qui ne semble pas encore arrivé dans les paquets de ton système...
Ou bien alors il faut attendre qu'une mise à jour l'y amène, soit, si il existe, le trouver dans les paquets disponibles sous Ubuntu, le télécharger, et l'installer manuellement avec un outil de paquets style gdebi.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2020.4.0 Git.

Hors ligne

#30 5/06/2021 13:03:38

jdt37b
Membre
Inscription : 14/08/2020
Messages : 48

Re : Nouvelle erreur de compilation en next...

Ok, c'est bon.
Effectivement, avec Xubuntu 20.04 (Focal), la LTS la plus récente d'Ubuntu, le paquet "libudev-dev_245.4-4ubuntu3.6" n'est pas dans les dépôts officiels. Il faut le récupérer sur launchpad.net et l'installer à la mano.
Curieusement, libudev1 245.4-4ubuntu3.6, qui n'est pas dans les dépôts était lui installé par la compil.
Nb : dans Synaptic les 2 paquets sont indiqués avec un lien cassé avec eux-mêmes, sans incidence apparente.

Merci de ton aide !


Acer XC330 - Xubuntu 18.04 LTS (FG 2020.3.8, compilé avec options CC=gcc-8 et CXX=g++-8, OSG 3.4.1) - Carte AMD Radeon R5 5 - RAM  4 Go - Processeur AMD A9-9420

Hors ligne

#31 5/06/2021 14:38:13

f-toro
Administrateur
Lieu : LFLA
Inscription : 16/12/2007
Messages : 2 846

Re : Nouvelle erreur de compilation en next...

jdt37b a écrit :

Curieusement, libudev1 245.4-4ubuntu3.6, qui n'est pas dans les dépôts était lui installé par la compil.

Ça c'est bizarre autant qu'étrange.
La compil, ou plutôt l'apt update puis upgrade qui se produit au début de la compil, n'a pas le pouvoir d'aller dégoter des paquets qui ne sont pas dans le système et de les installer !
Il devait forcément être quelque part dans les dépôts.


André. anciennement taureau89_9
Debian Testing Amd64. CM Sabertooth 990FX, FX8350, 32 Go Ram DDR3 1866 Mhz, GTX 750ti 2Go, DD 2To Sata 3, THRUSTMASTER T.Flight StickX, FG 2020.4.0 Git.

Hors ligne

#32 5/06/2021 16:48:18

jdt37b
Membre
Inscription : 14/08/2020
Messages : 48

Re : Nouvelle erreur de compilation en next...

Dans les dépôts officiels de Xub 20.04, pour les 2 paquets libudev-dev et libudev1, la version présente est suffixée .....ubuntu3 (et non 3.6) et dans ma partition Xub 20.04, pas d'autre dépôt ajouté (pas de PPA).
On le voit avec Synaptic, fonction "Forcer la version" du paquet, il ne propose que "....ubuntu3 (focal)"
Mystère, au moins pour moi.


Acer XC330 - Xubuntu 18.04 LTS (FG 2020.3.8, compilé avec options CC=gcc-8 et CXX=g++-8, OSG 3.4.1) - Carte AMD Radeon R5 5 - RAM  4 Go - Processeur AMD A9-9420

Hors ligne

Pied de page des forums